Subject: [Pana] NEW: [issue58] Fast-reauthentication and authorization issues

From: [email-masked]
Date: Thu, 5 Feb 2004 11:42:05 +0200

TmV3IHN1Ym1pc3Npb24gZnJvbSBEYW4gRm9yc2JlcmcgPGRhbi5mb3JzYmVyZ0Bub2tpYS5jb20+Og0KDQpGcm9tIEphcmkgQXJra286DQo+ICAgICAgLSAiRmFzdC1yZWF1dGhlbnRpY2F0aW9uIGFuZCBhdXRob3JpemF0aW9uIGlzc3VlcyINCj4gDQo+ICAgICAgICBJIGhhdmUgcmVzZXJ2YXRpb25zIGFib3V0IHRoZSBpbmNsdXNpb24gb2YgdGhlIGZhc3QNCj4gICAgICAgIHJlLWF1dGhlbnRpY2F0aW9uIHNjaGVtZSBpbiB0aGUgYmFzZSBQQU5BIGRvY3VtZW50LiBUaGVyZSBhcmUNCj4gICAgICAgIGEgbnVtYmVyIG9mIHNlY3VyaXR5IGlzc3VlcyBhdCB0aGUgc3lzdGVtIGxldmVsIHdoZW4geW91IHRyeQ0KPiAgICAgICAgdG8gZG8gdGhpcy4gU2VlIGRyYWZ0LWlldGYtZWFwLWtleWluZy0wMS50eHQsIFNlY3Rpb25zIDEuNCBhbmQNCj4gICAgICAgIDEuNC4xIGluIHBhcnRpY3VsYXIgZm9yIHNvbWUgZXhhbXBsZXMuDQo+IA0KPiAgICAgICAgTm90ZSBhbHNvIHRoYXQgbWFueSBFQVAgbWV0aG9kcyBwcm92aWRlIGZhc3QgcmUtYXV0aGVudGljYXRpb24uDQoNCkFscGVyIFllZ2luOg0KSSB0aGluayB3ZSBzaG91bGQgb3BlbiBhbiBpc3N1ZSBhbmQgaW52ZXN0aWdhdGUgdGhpcy4NCg0KLS0tLS0tLS0tLQ0KY2F0ZWdvcnk6IFRlY2huaWNhbA0KZG9jdW1lbnQ6IGRyYWZ0LWlldGYtcGFuYS1wYW5hLXh4LnR4dA0KbWVzc2FnZXM6IDE5OA0Kbm9zeTogZGZvcnNiZXINCnByaW9yaXR5OiBNdXN0IEZpeA0Kc3RhdHVzOiBQZW5kaW5nDQp0aXRsZTogRmFzdC1yZWF1dGhlbnRpY2F0aW9uIGFuZCBhdXRob3JpemF0aW9uIGlzc3Vlcw0KX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX18NClBBTkEgSXNzdWVzIDxwYW5hX2lzc3Vlc0BkYW5mb3JzYmVyZy5pbmZvPg0KPGh0dHA6Ly9kYW5mb3JzYmVyZy5pbmZvOjgwODAvcGFuYS1pc3N1ZXMvaXNzdWU1OD4NCl9fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fDQo=_______________________________________________Pana mailing [email-masked]://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Fri, 06 Feb 2004 16:45:09 -0800

>> From Jari Arkko:
>>      - "Fast-reauthentication and authorization issues"
>> 
>>        I have reservations about the inclusion of the fast
>>        re-authentication scheme in the base PANA document. There are
>>        a number of security issues at the system level when you try
>>        to do this. See draft-ietf-eap-keying-01.txt, Sections 1.4 and
>>        1.4.1 in particular for some examples.
>> 
>>        Note also that many EAP methods provide fast re-authentication.

The method we are proposing is described as "fast handoff" in the eap-keying
draft. You are right that there are system  level issues, and section "1.4.1
Correctness in fast handoff" elaborates on that. I think we should minimally
update the text to take people's attention to these issues. I think the
eap-keying draft is identifying this scenario, but also warning about
several limitations and considerations.

The other relevant text is in the Appendix E. AAA-key derivation. Although
the eap-keying draft identifies two different approaches to fast handoffs
(namely, based on context transfers, and pre-emptive state distribution),
the appendix only outlines how keys are generated for the latter case. Note
that PANA is using the former approach. As I understand simply passing MSK
(or AAA-key) from one PAA to another is not recommended. So, we'd need to
specify how derivative keys are generated for this.

So, overall I'm under the impression that what PANA aims is an application
of so-called fast handoffs as defined in eap-keying draft. Providing the
above enhancements should be sufficient. Unless I'm missing something...

What do you think?

Alper

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Fri, 06 Feb 2004 16:45:09 -0800

What do you think?

Alper