Subject: [Pana] NEW: [issue64] Two separate codes for Session ID AVP

From: [email-masked]
Date: Tue, 10 Feb 2004 09:09:06 +0200

TmV3IHN1Ym1pc3Npb24gZnJvbSBEYW4gRm9yc2JlcmcgPGRhbi5mb3JzYmVyZ0Bub2tpYS5jb20+Og0KDQo5LjQuMyBTZXNzaW9uLUlkIEFWUA0KDQogICBTZXNzaW9uLUlkIEFWUCAoQ29kZSAxMDI2KSBoYXMgYW4gb3BhcXVlIGRhdGEgZmllbGQsIHdoaWNoIGlzDQogICBhc3NpZ25lZCBieSB0aGUgUEFBLiBBbGwgbWVzc2FnZXMgcGVydGFpbmluZyB0byBhIHNwZWNpZmljIFBBTkENCiAgIFNlc3Npb24gTVVTVCBpbmNsdWRlIG9ubHkgb25lIFNlc3Npb24tSWQgQVZQIGFuZCB0aGUgc2FtZSB2YWx1ZSBNVVNUDQogICBiZSB1c2VkIHRocm91Z2hvdXQgdGhlIGxpZmV0aW1lIG9mIGEgc2Vzc2lvbi4gIFdoZW4gcHJlc2VudCwgdGhlDQogICBTZXNzaW9uLUlkIFNIT1VMRCBhcHBlYXIgaW1tZWRpYXRlbHkgZm9sbG93aW5nIHRoZSBQQU5BIGhlYWRlci4NCg0KICAgVGhlIFNlc3Npb24tSWQgTVVTVCBiZSBnbG9iYWxseSBhbmQgZXRlcm5hbGx5IHVuaXF1ZSwgYXMgaXQgaXMgbWVhbnQNCiAgIHRvIGlkZW50aWZ5IGEgUEFOQSBTZXNzaW9uIHdpdGhvdXQgcmVmZXJlbmNlIHRvIGFueSBvdGhlcg0KICAgaW5mb3JtYXRpb24sIGFuZCBtYXkgYmUgbmVlZGVkIHRvIGNvcnJlbGF0ZSBoaXN0b3JpY2FsIGF1dGhlbnRpY2F0aW9uDQogICBpbmZvcm1hdGlvbiB3aXRoIGFjY291bnRpbmcgaW5mb3JtYXRpb24uDQoNCiAgIFRoZSBTZXNzaW9uLUlkIEFWUCBNQVkgdXNlIERpYW1ldGVyIFtSRkMzNTg4XSBtZXNzYWdlIGZvcm1hdHRpbmcuIEluDQogICB0aGlzIGNhc2UgdGhlIEFWUCBjb2RlIGlzIDI2My4NCg0KSkFSSTogKFRlY2huaWNhbCkgU3VyZWx5IHRoZSBBVlAgY29kZSBpcyBhbHdheXMgMjYzLCBkZXNwaXRlIHRoZQ0KICAgICAgdHlwZSBvZiBmb3JtYXR0aW5nIHVzZWQgaW4gdGhlIGFjdHVhbCBpZGVudGlmaWVyPw0KDQotLS0tLS0tLS0tDQpjYXRlZ29yeTogVGVjaG5pY2FsDQpkb2N1bWVudDogZHJhZnQtaWV0Zi1wYW5hLXBhbmEteHgudHh0DQptZXNzYWdlczogMjA2DQpub3N5OiBkZm9yc2Jlcg0KcHJpb3JpdHk6IFNob3VsZCBGaXgNCnN0YXR1czogQ2xhcmlmeWluZyBUZXh0IFJlcXVpcmVkDQp0aXRsZTogVHdvIHNlcGFyYXRlIGNvZGVzIGZvciBTZXNzaW9uIElEIEFWUA0KX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX18NClBBTkEgSXNzdWVzIDxwYW5hX2lzc3Vlc0BkYW5mb3JzYmVyZy5pbmZvPg0KPGh0dHA6Ly9kYW5mb3JzYmVyZy5pbmZvOjgwODAvcGFuYS1pc3N1ZXMvaXNzdWU2ND4NCl9fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fDQo=_______________________________________________Pana mailing [email-masked]://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 11 Feb 2004 12:33:16 -0800

On Tue, Feb 10, 2004 at 09:09:06AM +0200, [email-masked] wrote:
> New submission from Dan Forsberg <[email-masked]>:
> 
> 9.4.3 Session-Id AVP
> 
>    Session-Id AVP (Code 1026) has an opaque data field, which is
>    assigned by the PAA. All messages pertaining to a specific PANA
>    Session MUST include only one Session-Id AVP and the same value MUST
>    be used throughout the lifetime of a session.  When present, the
>    Session-Id SHOULD appear immediately following the PANA header.
> 
>    The Session-Id MUST be globally and eternally unique, as it is meant
>    to identify a PANA Session without reference to any other
>    information, and may be needed to correlate historical authentication
>    information with accounting information.
> 
>    The Session-Id AVP MAY use Diameter [RFC3588] message formatting. In
>    this case the AVP code is 263.
> 
> JARI: (Technical) Surely the AVP code is always 263, despite the
>       type of formatting used in the actual identifier?

I agree with Jari.  When we say "globally and eternally unique" we
need to specify the exact format in order to possible ambiguity.
Based on this, re-using the same formatting rule as Diameter is the
easiest way to specify the PANA Session-Id format.  On the other hand,
the code can still be 1026 instead of 263...

Yoshihiro Ohba

> 
> ----------
> category: Technical
> document: draft-ietf-pana-pana-xx.txt
> messages: 206
> nosy: dforsber
> priority: Should Fix
> status: Clarifying Text Required
> title: Two separate codes for Session ID AVP
> __________________________________________________
> PANA Issues <[email-masked]>
> <http://danforsberg.info:8080/pana-issues/issue64>
> __________________________________________________

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 11 Feb 2004 12:33:16 -0800

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Wed, 11 Feb 2004 13:14:33 -0800

> the code can still be 1026 instead of 263...

As we discussed under issue 23, we don't care about Diameter codes. So I
suggest we only use one code (1026), while borrowing the formatting from
Diameter spec.

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 11 Feb 2004 13:14:33 -0800

Alper

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Feb 2004 07:30:05 +0200

> suggest we only use one code (1026), while borrowing the formatting from

Ok. My only complaint was that the AVP code appeared to depend on
the specific formatting inside the AVP value. So 1026 is fine.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Thu, 12 Feb 2004 07:30:05 +0200

--Jari