Subject: [Pana] Bug in sequence number management

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 15 Jul 2004 18:47:13 -0400

In section 4.1.4 of draft-ietf-pana-pana-04, change:

"
   o  When a message is received, it is considered valid in terms of
      sequence numbers if and only if (i) its tseq is greater than the
      tseq of the last accepted message and (ii) its rseq falls in the
      range between the tseq of the last acknowledged message + 1 and
      the tseq of the last transmitted message.
"

to:

"
   o  When a message is received, it is considered valid in terms of
      sequence numbers if and only if (i) its tseq is greater than the
      tseq of the last accepted message and (ii) its rseq falls in the
      range between the tseq of the last acknowledged message and
      the tseq of the last transmitted message.
"

Yoshihiro Ohba

----- Forwarded message from Alper Yegin <[email-masked]> -----

From: Alper Yegin <[email-masked]>
Subject: RE: [Pana] New: [issue98] Lost answer problem
To: 'Yoshihiro Ohba' <[email-masked]>,
	'Rafael Marin Lopez' <[email-masked]>
Importance: Normal
X-VirusChecked: Checked
X-Env-Sender: [email-masked]
X-Msg-Ref: server-13.tower-76.messagelabs.com!1089756330!2585408
X-StarScan-Version: 5.2.10; banners=-,-,-
X-Originating-IP: [203.254.224.33]
X-SpamReason: No, hits=0.0 required=7.0 tests=CYNIC_B,

Hmmm, looks like it.

Does increasing the range by 1 fix the problem (without breaking
anything else)? 

Like:

[tseq of the last acknowledged message, tseq of the last
transmitted message]

Alper

> -----Original Message-----
> From: Yoshihiro Ohba [mailto:[email-masked]]
> Sent: Tuesday, July 13, 2004 2:49 PM
> To: Rafael Marin Lopez; Alper Yegin
> Cc: Yoshihiro Ohba
> Subject: Re: [Pana] New: [issue98] Lost answer problem
> 
> Hi Rafa,
> 
> I think your are right.  The discarding rule seems to be a bug.
> What do you think, Alper?
> 
> Yoshihiro Ohba
> 
> 
> On Tue, Jul 13, 2004 at 12:21:48PM +0200, Rafael Marin Lopez wrote:
> > Hi Yoshihiro...
> >
> > Maybe I am missing something but sentence "There would not be any
> > discarding due to sequence numbers" I am not sure if it completely
true.
> > For example:
> >
> >
> > PaC PAA
> > <------------PBR(x,y)-----------
> >
> > -------------PBA(y+1,x)--X--->
> >
> > <-----------PBR(x+1,y)--------
> > (silently discarded by PaC: "x+1" is correct but "y" does not belong
to
> > [ y (tseq of the last acknowledged message) + 1, y+1(tseq of the
last
> > transmitted message)]
> >
> > <---------- PBR(x+2,y)--------
> >
> > same situation
> >
> > Am I wrong?
> >
> >
> > Yoshihiro Ohba wrote:
> >
> > >On Mon, Jul 12, 2004 at 04:49:20PM -0700, Alper Yegin wrote:
> > >
> > >
> > >>I'm trying to understand the issue...
> > >>
> > >>
> > >>
> > >>>From Yoshihiro Ohba:
> > >>>--------------------
> > >>>There might be some cases in which a PaC or a PAA might need to
send
> a
> > >>>duplicate answer to a retransmitted old request (as well as a
fresh
> > >>>answer to a new request if any) considering that an answer
message
> for
> > >>>an old request can be lost.  Without this, a PANA session may
stall
> in
> > >>>a way that the requester keeps retransmitting the old request
while
> > >>>the responder may keep discarding them with waiting for a new
request.
> > >>>
> > >>>
> > >>There would not be any discarding due to sequence numbers. I guess
the
> > >>only problem could be that the PaC has jumped to the next state in
the
> > >>state machine as soon as it responded to a message, and in that
state
> it
> > >>does not expect the same request it had already responded earlier.
Is
> > >>that the issue?
> > >>
> > >>
> > >
> > >Yes.
> > >
> > >Yoshihiro Ohba
> > >
> > >
> > >
> > >
> > >>Alper
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>>The cases are described below.
> > >>>
> > >>>- When a PaC sends a PANA-Start-Answer message in response to a
valid
> > >>>PANA-Start-Request message without a Cookie AVP, the answer
message
> > >>>can be lost.  The PANA-Start-Request would be retransmitted.  To
deal
> > >>>with the case, it might be better for the PaC to return a
duplicate
> > >>>PANA-Start-Answer message after the PaC has been sent the first
> > >>>PANA-Start-Answer message until the PaC receives a valid
> > >>>PANA-Auth-Request message.
> > >>>
> > >>>- When a PaC sends a PANA-FirstAuth-End-Answer message in
response to
> > >>>
> > >>>
> > >>a
> > >>
> > >>
> > >>>valid PANA-FirstAuth-End-Request message (remember that a
> > >>>PANA-FirstAuth-End exchange is used for delimiting the first and
> > >>>second EAP authentications), the answer message may be lost.  The
> > >>>PANA-FirstAuth-End-Request would be retransmitted (with updating
> > >>>transmission sequence number).  To deal with the case, it might
be
> > >>>better for the PaC to return a duplicate
PANA-FirstAuth-End-Answer
> > >>>message (with updating transmission and received sequence
numbers)
> > >>>after the PaC has been sent the first PANA-FirstAuth-End-Answer
> > >>>message until the PaC receives a valid PANA-Auth-Request message
for
> > >>>the second EAP authentication.
> > >>>
> > >>>- When a PaC sends a PANA-Bind-Answer message in response to a
valid
> > >>>PANA-Bind-Request message, the answer message can be lost.  As as
> > >>>result, the PAA will retransmit the PANA-Bind-Request (but with
using
> > >>>a different transmission sequence number).  To deal with the
case, it
> > >>>might be better for the PaC to return a duplicate
PANA-Bind-Answer
> > >>>message (but with using different transmission and received
sequence
> > >>>numbers) for a while after the first PANA-Bind-Request was
received.
> > >>>The same thing can also apply to a PANA-Address-Update-Answer
message
> > >>>that is sent by a PaC.
> > >>>
> > >>>- When a PaC or a PAA sends a PANA-Termination-Answer message in
> > >>>response to a valid PANA-Termination-Request message, the answer
> > >>>message can be lost.  As as result, the requester will retransmit
the
> > >>>request (but with using a different transmission sequence
number).
> To
> > >>>deal with the case, it might be better for the sender of the
answer
> to
> > >>>return a duplicate answer (with using different transmission and
> > >>>received sequence numbers) for a while after the first
> > >>>PANA-Termination-Request was received.  The same thing can also
apply
> > >>>to a PANA-Reauth-Answer message that is sent by a PaC or a PAA.
> > >>>
> > >>>Those could improve robustness of the PANA protocol against loss
of
> > >>>answer message.
> > >>>
> > >>>Comments?
> > >>>
> > >>>Yoshihiro Ohba
> > >>>
> > >>>----------
> > >>>category: Technical
> > >>>document: draft-ietf-pana-pana-xx.txt
> > >>>messages: 335
> > >>>nosy: dforsber
> > >>>priority: Must Fix
> > >>>status: Pending
> > >>>title: Lost answer problem
> > >>>__________________________________________________
> > >>>PANA Issues <[email-masked]>
> > >>><http://danforsberg.info:8080/pana-issues/issue98>
> > >>>__________________________________________________
> > >>>
> > >>>
> > >
> > >_______________________________________________
> > >Pana mailing list
> > >[email-masked]
> > >https://www1.ietf.org/mailman/listinfo/pana
> > >
> > >
> > >
> > >
> >
> >
> > --
> > ------------------------------------------------------
> > Rafael Marin Lopez
> > Faculty of Computer Science-University of Murcia
> > 30071 Murcia - Spain
> > Telf: +34968367645    e-mail: [email-masked]
> > ------------------------------------------------------
> >

----- End forwarded message -----

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Thu, 15 Jul 2004 17:54:30 -0700

I created a record in the issue tracker: Issue 107.

This seems to solve the problem, and I couldn't think of any issues with
the proposed change.

Alper

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Yoshihiro Ohba
> Sent: Thursday, July 15, 2004 3:47 PM
> To: [email-masked]
> Subject: [Pana] Bug in sequence number management
> 
>