Subject: RE: [Pana] Mobility Handling in PANA

From: Giaretta Gerardo <[email-masked]>
Date: Wed, 14 Jul 2004 09:50:50 +0200

Hi Alper,

> 
> > Thus we propose this:
> > 
> > 
> >      PaC           nPAA              pPAA
> >      ----------------------------------------
> >            PDI
> >       -------------->
> >            PSR
> >      <---------------
> >           PSA [old Session-ID, Nonce, CTAR]
> >       --------------->
> > 
> >                            CT-Request
> >                         -------------->
> >                                CTD
> >                         <--------------
> > 
> >       PBR[new Session-ID, Key-Id, Nonce, PPAC, MAC]
> >      <-------------
> >       PBA[new Session-ID, Key-Id, PPAC, MAC]
> >       ------------->
> 
> This is the flow I had in my mind, but I don't see the need 
> to have an explicit CTAR AVP in the PSA.
> 
> Looking at the draft, CTAR carries:
> - PaC's address. Why do we need this? The Pac is identified 
> with its session id.
> - PAA's address. I don't think we need this either. Session 
> id reveals the ID of the pPAA. It's just a matter of mapping 
> that to an IP address (use DNS).
> - Authorization token. MAC AVP already does the job.
>

CTAR (and thus a CTAR AVP in our draft) is always required by CTP as
specified in draft-ietf-seamoby-ctp-10.txt. It is not possible to use
CTP without sending a CTAR message both in predictive and reactive mode.
This is because in CTP the transfer is authorized trough the
authorization token that is shared between pAR and MN. However, I
completely agree with you that the information carried by CTAR can be
obtained by other means as you stated above. 

I think here the issue is whether we want to apply the Seamoby CTP or to
define a context transfer mechanism only for PANA (which exploits PANA
features).

--Gerardo

> Alper

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Julien Bournelle <[email-masked]>
Date: Thu, 15 Jul 2004 10:58:41 +0200

Hi,

see comments inline,

> define a context transfer mechanism only for PANA (which exploits PANA

I would like to add that we need CTAR message if we want to support
predictive handover. 

-- 
[email-masked]