Subject: RE: [Pana] and network selection

From: Avi Lior <[email-masked]>
Date: Mon, 8 Nov 2004 17:06:16 -0500

One more thing to add to Jarri's comments:

One method maybe better than the other but both method can be used at the
same time right? What can go wrong. What if they conflict.

Or do we say if one is used the other shouldn't be used.

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Monday, November 08, 2004 4:56 PM
> To: Alper Yegin
> Cc: 'Avi Lior'; 'Yoshihiro Ohba'; [email-masked]
> Subject: Re: [Pana] and network selection
> 
> 
> Alper Yegin wrote:
> 
> > PANA allows ISP discovery as early as PANA-Start-Request. 
> Depending on 
> > the deployment this message may be sent unsolicited, but it is 
> > unicast.
> >  
> > I agree that the enabling discovery as early as possible (at the 
> > lowest possible layer) is more optimal. When that's not possible 
> > (e.g., lack of supporting technology) you need to keep popping up 
> > layers to accomplish that. If using PANA, then you are 
> done. If not, 
> > then you can fall back to EAP-based discovery.
> 
> Yes. Two things remain, however:
> 
> (1) Does someone have an answer as to how all this can be
>      accomplished in the current AAA protocols while
>      still allowing the local access provider to have
>      a proxy AND roaming? I'm not quite sure how the
>      destination realm value is set in the case of
>      Diameter EAP, for instance.
> 
> (2) We need to consider this in light of Avi's question,
>      which was what additional value the PANA ISP selection
>      provides over things that already exist in EAP. I
>      personally do not believe you absolutely need to
>      have additional value, but of course it would be
>      useful if you could demonstrate, for instance, that
>      your "L2" network selection scheme is better than
>      what exists in 802.1X.
> 
>      Speaking of multicast packets, how does a PANA client
>      know that it needs to initiate a PANA exchange? What
>      if you added a new PANA multicast message that told
>      the client about this and carries the ISP/ASP info
>      within it?
> 
> --Jari
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 09 Nov 2004 10:03:42 -0500

> same time right? What can go wrong. What if they conflict.

I've read draft-adrangi-eap-network-discovery and I agree that 
they can conflict if EAP-based network selection is used for 
ISP selection instead of AAA intermediary selection.

> Or do we say if one is used the other shouldn't be used.

I think so.  It is the responsibility of implementation 
to avoid such conflict.

Yoshihiro Ohba