Subject: [Pana] A new PAA discovery scheme in multi-hop PANA

From: "Junghoon Jee" <[email-masked]>
Date: Fri, 18 Mar 2005 16:46:07 +0900

Hello ALL,

Here is a short description of a new PAA discovery scheme in the multi-hop PANA environment.

+ New PANA discovery message for locating PAA 
    - Use of anycast message
    - Seed information to look up the specific PAA : network prefix of PAA
   - Steps  
         * PaC sends an anycast PANA discovery message using the home network prefix to its home PAA domain.
         * A PAA responds to it with a PANA-start-request (PSR) message.  
         * The MN responds with a PANA-start-answer (PSA) message to the PAA. 

As you expect, this scheme requires the pre-configuration of PAA's network prefix to the PaC.

BTW, related with the on-going discussion of MIP6 WG's bootstrapping solution,
we can assume the pre-configuration of home network prefix or domain name(FQDN) of HA.

Can we use similar approach by pre-configuring the specific information in the multi-hop PANA environment ?

Any comments and questions are welcome.

Regards,
Junghoon

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Jari Arkko <[email-masked]>
Date: Fri, 18 Mar 2005 11:19:44 +0200

Hi Junghoon,

and thanks for bringing up the details of the discovery scheme.

>As you expect, this scheme requires the pre-configuration of PAA's network prefix to the PaC.
What's a "home PAA domain"? Presumably PANA is used for network access (even
when you run it in multi-hop mode). This would seem to imply that
depending on
where you are, you get a different PAA. So why would we need to send
something
to a ?home PAA"? Or is your idea that you send a message towards the
home PAA,
and then the local PAA captures that on the path, and starts doing PANA with
you?

How about having a fixed anycast address for "local PAAs", or a DHCP
option for discovering a PAA and that there is a need for PAA? Or a
solution that is triggered by an attempt to send packets. The DHCP
solution has worked well for DNS discovery.

--Jari

---

From: "Junghoon Jee" <[email-masked]>
Date: Fri, 18 Mar 2005 19:14:43 +0900

Hi Jari,
Please see my comments inline.

----- Original Message ----- 
From: "Jari Arkko" <[email-masked]>
To: "Junghoon Jee" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, March 18, 2005 6:19 PM
Subject: Re: [Pana] A new PAA discovery scheme in multi-hop PANA

> and then the local PAA captures that on the path, and starts doing PANA with

Well, Hannes and me are thinking about the use of PANA for mobility service.
Please look at Hannes's draft, http://www.ietf.org/internet-drafts/draft-tschofenig-mip6-bootstrapping-pana-00.txt
Now, I am trying to fill the blank line in this draft about dynamic HA discovery.
Yes, i am somewhat biased to the MIPv6 bootstrapping solution work.
Anyway, I would like to receive any comment whether it is O.K. to pre-configure the PAA's prefix information to the PaC.

Regards,
--Junghoon

---

From: Rafa Marin Lopez <[email-masked]>
Date: Fri, 18 Mar 2005 12:21:11 +0100

Hi Jari, Junghoon

Jari Arkko wrote:

>when you run it in multi-hop mode).
>
I agree on that . I also think that PAA should be placed in the local
domain for network access. Under my understanding for network access
service PAA should be placed on local domain if not how could for
example PAA placed on Home Domain configure EP in the visited domain?

On the other hand I think PANA WG should only resolve problematic with
network access service. For other services we are discussing it in
multi-hop EAP I-D.

However if we consider PAA for network access (I think PANA WG should
only resolve problematic with network access service. For other services
we are discussing it in multi-hop EAP I-D) c

> This would seem to imply that
>depending on
With respect to DHCP discover, if PAA is placed on visited domain it is
ok though it is not clear that it was OK for MANET scenario shown in
multi-hop EAP I-D.
As Gerardo has commented , we should be consider that PANA specification
is already providing a method to discover the PAA when EP detects
traffic from unauthenticated source.

Regards.

-- 
------------------------------------------------------
Rafael Marin Lopez
Faculty of Computer Science-University of Murcia
30071 Murcia - Spain
Telf: +34968367645    e-mail: [email-masked]
------------------------------------------------------

---

From: Alper Yegin <[email-masked]>
Date: Fri, 18 Mar 2005 13:13:28 -0800

Folks,

As we explicitly stated at IETF 62, the scope of multi-hop PANA is same
as before: simple network access. It does NOT include ad-hoc scenarios,
or other services like Mobile IPv6. Please stick to this scope as you
tackle PAA discovery.

Alper

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Junghoon Jee
> Sent: Friday, March 18, 2005 2:15 AM
> To: Jari Arkko
> Cc: Tschofenig Hannes; [email-masked]
> > >Here is a short description of a new PAA discovery scheme in the
multi-
> hop PANA environment.
> > >    - Seed information to look up the specific PAA : network prefix
of
> PAA
> > >   - Steps
> > >         * PaC sends an anycast PANA discovery message using the
home
> network prefix to its home PAA domain.
> > >         * The MN responds with a PANA-start-answer (PSA) message
to
> the PAA.
> > What's a "home PAA domain"? Presumably PANA is used for network
access
> (even
> > and then the local PAA captures that on the path, and starts doing
PANA
> with
> Please look at Hannes's draft,
http://www.ietf.org/internet-drafts/draft-
> tschofenig-mip6-bootstrapping-pana-00.txt
> Anyway, I would like to receive any comment whether it is O.K. to pre-
> configure the PAA's prefix information to the PaC.
> 
> Regards,
> --Junghoon
>