Subject: RE : [Pana] A new PAA discovery scheme in multi-hop PANA

From: "MORAND Lionel RD-CORE-ISS" <[email-masked]>
Date: Fri, 18 Mar 2005 10:26:55 +0100

Hi Jari,

We (Alper and I) are producing a detailed description of the PAA discovery procedure based on the use of a specific DHCP option.
I think that this scheme will some the problem of PAA discovery in a multi-hop context (as mentioned by Alper during the meeting).

BR,

Lionel

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De 
> la part de Jari Arkko
> Envoyé : vendredi 18 mars 2005 10:20
> À : Junghoon Jee
> Cc : [email-masked]
> Objet : Re: [Pana] A new PAA discovery scheme in multi-hop PANA
> 
> 
> Hi Junghoon,
> 
> and thanks for bringing up the details of the discovery 
> scheme. I have a few questions, however:
> 
> >Here is a short description of a new PAA discovery scheme in the 
> >multi-hop PANA environment.
> >
> >+ New PANA discovery message for locating PAA
> >    - Use of anycast message
> >    - Seed information to look up the specific PAA : network 
> prefix of PAA
> >   - Steps  
> >         * PaC sends an anycast PANA discovery message using 
> the home network prefix to its home PAA domain.
> >         * A PAA responds to it with a PANA-start-request 
> (PSR) message.  
> >         * The MN responds with a PANA-start-answer (PSA) message to 
> > the PAA.
> >
> >As you expect, this scheme requires the pre-configuration of PAA's 
> >network prefix to the PaC.
> >
> What's a "home PAA domain"? Presumably PANA is used for 
> network access (even when you run it in multi-hop mode). This 
> would seem to imply that depending on where you are, you get 
> a different PAA. So why would we need to send something to a 
> ?home PAA"? Or is your idea that you send a message towards 
> the home PAA, and then the local PAA captures that on the 
> path, and starts doing PANA with you?
> 
> How about having a fixed anycast address for "local PAAs", or 
> a DHCP option for discovering a PAA and that there is a need 
> for PAA? Or a solution that is triggered by an attempt to 
> send packets. The DHCP solution has worked well for DNS discovery.
> 
> --Jari
> 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Rafa Marin Lopez <[email-masked]>
Date: Fri, 18 Mar 2005 11:56:38 +0100

Hi Lionel ...

>I think that this scheme will some the problem of PAA discovery in a multi-hop context (as mentioned by Alper during the meeting).
I would not be so sure that this option would be suitable for MANET 
scenario.
Regards.

-- 
------------------------------------------------------
Rafael Marin Lopez
Faculty of Computer Science-University of Murcia
30071 Murcia - Spain
Telf: +34968367645    e-mail: [email-masked]
------------------------------------------------------