Subject: Re: [Pana] pana-snmp issue

From: Julien Bournelle <[email-masked]>
Date: Fri, 1 Apr 2005 10:47:51 +0200

Hi yoshi,

 it makes sense to me.
 what about provide key length ?

 regards,

On Thu, Mar 31, 2005 at 02:09:38AM -0500, Yoshihiro Ohba wrote:
> After taking a look at draft-ietf-eap-keying-05, I think that the most
> generic set of cryptographic protection parameters that are common to
> any link-layer security (and IPsec as well) is the parameters used by
> a secure association protocol.  Possible parameters are (1) a key, and
> (2) the name of the key, and (3) the DI of the PaC (the DI can be a
> locally significant identifier, e.g., PPP interface-id).
> 
> In the case of 802.11i, the key is PMK and the name of the key is
> PMKID, and the DI of the PaC is the MAC address of the PaC.
> 
> Just a note that in the case of IPsec, the key is IKE pre-shared key
> and the name of the key is ID_KEY_ID, and the device identifier of the
> PaC is the IP address of the PaC.
> 
> Comments?
> 
> Yoshihiro Ohba
> 
> 
> On Tue, Mar 15, 2005 at 04:15:21PM -0800, Alper Yegin wrote:
> > > The following issue was raised in the IETF62 PANA meeting with regard
> > > to pana-snmp I-D:
> > > 
> > >   Can we define MIB objects to carry cryptographic protection
> > >   parameters of any link-layer type?
> > 
> > I am hoping that we can simply define a structure that can serve the
> > need of practically any link type. If we can convey a "L2 address" and a
> > "master key" to the EP, that should be sufficient. We don't need to
> > define the exact format of all L2 types for the "L2 address". Instead we
> > can follow the scalable approach taken in RFC 2461, where exact format
> > for FOO address type is deferred to IP-over-FOO document.
> > 
> > This way we don't have to rely on any other document but a single
> > PANA-SNMP spec.
> > 
> > Does this make sense?
> > 
> > Alper
> > 
> > 
> > 
> > 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana

-- 
julien.bournelle at int-evry.fr

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 01 Apr 2005 08:51:35 -0500

>  what about provide key length ?

Key length should be appropriately treated in key encoding.

BTW, we might need a lifetime of the key as an additional parameter.
What do you think?

Yoshihiro Ohba