Subject: [Pana] Session Lifetime field in draft-ietf-pana-cxtp-00

From: Vijayarajan <[email-masked]>
Date: Tue, 29 Nov 2005 16:47:24 +0530

Hi Julien,
 
In the working group draft draft-ietf-pana-cxtp-00 i.e.
"Use of Context Transfer Protocol (CXTP) for PANA",
the PANA context to be transferred from previous PAA to
new PAA includes the "Session-Lifetime Elapsed" field.
Should'nt this rather be the "Session-Lifetime Remaining"
instead? With just the elapsed session-lifetime, how can
new PAA determine the session-lifetime for the new PANA
session b/w PaC and itself?
 
Regards,
Vijayarajan
_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Julien Bournelle <[email-masked]>
Date: Tue, 29 Nov 2005 13:17:30 +0100

Hi vijayarajan,

> session b/w PaC and itself?

 yes you're right. If we only send the "Session-Lifetime Elapsed", the
 nPAA can't determine the remaining Session-Lifetime. I can't remember
 why we put this. 

 So we have 2 choices:
 
 a/ the pPAA sends:
 	- Session-Lifetime (as sent by AAA)
	and
	- Session-Lifetime Elapsed 
 
  and then the nPAA computes the Session-Lifetime remaining

 b/ the pPAA directly sends the Session-Lifetime remaining.
	
 I think solution b/ is simpler and is sufficient.

 Would you agree on that ?

 Julien

-- 
julien.bournelle at int-evry.fr