Subject: [Pana] Query about panaL2FiltEPIfIndex in draft-ietf-pana-snmp-04

From: Nagaraju <[email-masked]>
Date: Mon, 07 Nov 2005 17:08:45 +0530

PANA-EP-MIB defines panaL2FiltEpIfIndex as:

               panaL2FiltEpIfIndex OBJECT-TYPE
               SYNTAX         InterfaceIndex
               MAX-ACCESS     read-create
               STATUS         current
               DESCRIPTION
               "The index identifying the EP interface where the filter
               policy must be enforced on."
               ::= { panaL2FilterEntry 1 }

How does PAA know on which EP interfaces filter policy has to be enforced?
Is it mandatory that PAA should have knowledge of EP interfaces on which filter policy has to be enforced?

Regards,
Nagaraju.
_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Mon, 07 Nov 2005 13:55:01 +0100

please see inline.

> How does PAA know on which EP interfaces filter policy has to be enforced?

the PAAs/EPs (or PAAs/EP interfaces) relation is out of the SNMP 
document scope -> see the pana-frwk doc, which should handle this.

> filter policy has to be enforced?

the table you quoted is used in the *L2-based* filtering context. in 
this context, it is indeed mandatory for the PAA to know the interface. 
do note that IP-based filtering does not require this.

yacine

>  
> Regards,
> Nagaraju.
> 
> 
> ------------------------------------------------------------------------
>

---

From: Nagaraju <[email-masked]>
Date: Mon, 07 Nov 2005 19:34:04 +0530

Please see inline.

----- Original Message ----- 
From: <[email-masked]>
To: "Nagaraju" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 07, 2005 6:25 PM
Subject: Re: [Pana] Query about panaL2FiltEPIfIndex in
draft-ietf-pana-snmp-04

> do note that IP-based filtering does not require this.

  Yes, panaL2FiltEpIfIndex is used for  L2-based filtering.
But I did not understand the purpose of interface index.
What is the need of interface index in L2-based filtering?
How is L2-based filtering different from IP-based filtering?

Because we can use device Link-layer address (DI) for L2-based
filtering(irrespective of on which interface the packet is received).
In IP-based filtering also it is possible that we may receive packets from
PaCs on any interface of EP,
but we filter the packets only based on device-id.
Is it not possible to follow the same approach in L2-based filtering?

Nagaraju

---

From: [email-masked]
Date: Mon, 07 Nov 2005 16:03:36 +0100

ifIndex provides the pointer towards this information in the interface 
table, which provides address type, according to the interface table 
defined in RFC2863:

IfEntry ::=
   SEQUENCE {
     ifIndex                 InterfaceIndex,
     ifDescr                 DisplayString,
  -> ifType                  IANAifType, <-
     ifMtu                   Integer32,
     (...)

yacine

Nagaraju wrote:

>>>How does PAA know on which EP interfaces filter policy has to be
> 
> enforced?
>

---

From: Nagaraju <[email-masked]>
Date: Tue, 08 Nov 2005 12:18:27 +0530

Can you please elaborate why we are sending interface index instead of
sending interface type directly?
Are we sending interface index to get interface type so that we can
determine the physical address length or any other reason?

Regards,
Nagaraju

----- Original Message ----- 
From: <[email-masked]>
To: "Nagaraju" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 07, 2005 8:33 PM
Subject: Re: [Pana] Query about panaL2FiltEPIfIndex in
draft-ietf-pana-snmp-04

> >>>Is it mandatory that PAA should have knowledge of EP interfaces on
which
> >>>filter policy has to be enforced?
> >>

---

From: [email-masked]
Date: Wed, 09 Nov 2005 13:02:50 +0100

nagaraju,

1) strictly speaking the L2 address has only a link-local significance: 
the PAA MUST provide the couple [ifIndex, L2 @] to perform L2-filtering 
at the EP level.

2) there is another reason for not provisioning the EP simply with the 
couple [ifType, L2 @]: for consistency reasons, we must avoid providing 
twice the same information (ifType) in two different fields (ifTable and 
panaL2FiltEpIfTable).

the MIB design has enough to be generic: we can make no assumption on L2 
adressing or L2 type.

regards,
yacine

Nagaraju wrote:

>>>In IP-based filtering also it is possible that we may receive packets
> 
> from
>