Subject: [Pana] Index problem in panaL2FilterTable in snmp draft

From: Nagaraju <[email-masked]>
Date: Tue, 29 Nov 2005 18:26:39 +0530

For 'panaL2FilterTable' we have 'panaL2FiltEpIfIndex' as the index.
(Please find text from pana-snmp-draft at the end of the mail.)

We can install a filter for PaC1 on EPIfIndex1, 
 using
                 panaL2FilterTable.panaL2FiltAddr.EPIfIndex1  = PaC1
 
Similarly, 
We can install a filter for PaC2 on EPIfIndex2,
 using
                 panaL2FilterTable.panaL2FiltAddr.EPIfIndex2  = PaC2

Now, the question is ,

    How can we install a filter for PaC3 on EPIfIndex1?

Because, doing

        panaL2FilterTable.panaL2FiltAddr.EPIfIndex1  = PaC3

will overwrite the rule for PaC1.

Does panaL2FiltAddr also need to be part of the panaL2FilterTable's index?

Thanks&Regards,
Nagaraju.

Text from pana-snmp-draft:

                panaL2FilterTable OBJECT-TYPE
               SYNTAX      SEQUENCE OF PanaL2FilterEntry
               MAX-ACCESS  not-accessible
               STATUS      current
               DESCRIPTION
               "Link-layer filter definitions."
               ::= { panaConfigObjects 1 }

               panaL2FilterEntry OBJECT-TYPE
               SYNTAX      PanaL2FilterEntry
               MAX-ACCESS  not-accessible
               STATUS      current
               DESCRIPTION
               "An entry in the Link-layer filter table."
               INDEX       { panaL2FiltEpIfIndex }
              ::= { panaL2FilterTable 1 }

               PanaL2FilterEntry ::= SEQUENCE {
               panaL2FiltEpIfIndex         InterfaceIndex,
               panaL2FiltAddr              PhysAddress,
               panaL2FiltPmk               PanaKey,
               panaL2FiltPmkName           PanaKeyName,
               panaL2FiltPmkLifetime       TimeInterval,
               panaL2FiltLastChanged       TimeStamp,
               panaL2FiltStorageType       StorageType,
               panaL2FiltRowStatus         RowStatus
               }

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Tue, 29 Nov 2005 15:07:41 +0100

hello nagaraju,

I think you're right and we should extend the indexing of this table to 
the L2FiltAddr as well.

s/
                 INDEX       { panaL2FiltEpIfIndex }
/
                 INDEX       { panaL2FiltEpIfIndex, panaL2FiltAddr }

thanks for bringing this up. we will update the next evrsion accordingly.

Yacine

Nagaraju wrote:
> We can install a filter for /PaC1/ on /EPIfIndex1, /
>  using
>                  panaL2FilterTable.panaL2FiltAddr./EPIfIndex1  = PaC1/
> //
>  
> Similarly,
> We can install a filter for /PaC2/ on /EPIfIndex2,/
>  using
>                  panaL2FilterTable.panaL2FiltAddr./EPIfIndex2/  = /PaC2/
> // 
> Now, the question is ,
>  
>     How can we install a filter for /PaC3/ on /EPIfIndex1/?
>  
> Because, doing
>  
>         panaL2FilterTable.panaL2FiltAddr./EPIfIndex1  = PaC3/
> // 
> ------------------------------------------------------------------------
>