Subject: [Pana] pana-pana Issue234: Unsupported message handling

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 27 Dec 2005 12:04:50 -0500

>         AVPs with the 'M' bit cleared are informational only and a
>         receiver that receives a message with such an AVP that is not
>         supported, or whose value is not supported, MAY simply ignore
>         the AVP.
>  
>
Unrecognized and unsupported are slightly different ideas. I think you 
mean 'unrecognized' here.

The way the code should work is, the M bit is ONLY inspected if the 
Attribute number is unrecognized. If the attribute number is 
unrecognized, the M bit says whether this is a detrimental situation or 
not. If the Attribute is recognized, even if it is "unsupported" and 
regardless of the Value itself, then the implementation at least knows 
enough to know whether to care about the AVP or not (even if that simply

means ignoring it), in which case the M bit need never be inspected.

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Jari Arkko <[email-masked]>
Date: Wed, 28 Dec 2005 15:46:09 +0200

(Mark: I'm guessing these are your review issues
even if Yoshi did not Cc you. Apologies for the
extra e-mails otherwise.)

>means ignoring it), in which case the M bit need never be inspected.
I think the behaviour we want is that when an attribute with M=1
arrives, we perform one of the following operations:

- determine that we do not recognize it, send back an error
- determine that we do not recognize a value within the attribute,
send back an error
- determine that we do recognize both the attribute and the
value, and execute actions specified for them in this RFC

(I would not like to see that it becomes possible to ignore
the rules of the RFC just by "recognizing" an attribute but
not really having implemented it.)

--Jari

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 29 Dec 2005 11:16:21 -0500

> value, and execute actions specified for them in this RFC

Yes, and I think this is what the 'M=1' description in the earlier
part of the section means.

> not really having implemented it.)

Going back to the case of M=0, replacing "supported" with "recognized"
in the original text should be OK?

Yoshihiro Ohba