Subject: [Pana] pana-pana Issue228: Lock step behavior

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 27 Dec 2005 12:00:38 -0500

>5.2  Sequence Number and Retransmission
>
>   PANA uses sequence numbers to provide ordered and reliable delivery
>   of messages.
>
>   The PaC and PAA maintain two sequence numbers: the next one to be
>   used for a request it initiates and the next one it expects to see
in
>   a request from the other end.  These sequence numbers are 32-bit
>   unsigned numbers.  They are monotonically incremented by 1 as new
>   requests are generated and received, and wrapped to zero on the next
>   message after 2^32-1.  Answers always contain the same sequence
>   number as the corresponding request.  Retransmissions reuse the
>   sequence number contained in the original packet.
>  
>
So, packet exchange is always lock step? If not, some details of the 
windowing algorithm need to be provided.

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Jari Arkko <[email-masked]>
Date: Thu, 29 Dec 2005 08:50:01 +0200

Yoshihiro Ohba wrote:

>So, packet exchange is always lock step? 
>

I think so.

--Jari