Subject: [Pana] pana-fwk section 10.2.3: Take II

From: Rafa Marin Lopez <[email-masked]>
Date: Mon, 30 Jan 2006 09:07:38 -0500

Following you can find new text for section 10.2.3

Classification has been made based on types of APs which (we hope) 
removes certain ambiguity
in the previous classification (i.e "free network").

If there is no comments in a couple of days, this text will be applied.

Regards.

"10.2.3 Capability Discovery
 
When a PaC is a mobile, there may be multiple APs available in its
vicinity. Each AP can be one of the following types:
 
a) AP without IEEE 802.11i
 
    There is no IEEE 802.11i link-layer security on this AP.

b) AP with IEEE 802.11i using PSK mode bootstrapped from PANA

    The clients are required to perform PANA authentication
    which allows the PaC to bootstrap a dynamic PSK to access this AP.

c) AP with IEEE 802.11i using native PSK mode

    AP and PaC must share a statically configured PSK to access this AP.

d) AP with IEEE 802.11i using 802.1X/EAP mode

    The clients are required to perform IEEE 802.1X/EAP authentication for
    this AP.

Checking the capability information advertised in
IEEE 802.11 Beacon/Probe Response frames (IEEE 802.11i defines
RSN Information Element (IE) for this purpose), PaC can extract
certain information about the different types of APs.
 
Specifically, if no RSN IE is contained in Beacon/Probe Response frames
then the AP is Type (a). Additionally, Type (d) can be
recognized because IEEE 802.1X-EAP mode is advertised in the RSN IE.
 
However Type (b) and Type (c) may not be distinguished by PaC because in
both cases PSK mode is advertised in the RSN IE. Due to this, the PaC needs
to take an additional action of trying to associate to the AP.
 
If either the PaC receives a disassociation frame from the AP as the AP
does not hold a PSK for the PaC, or AP inmediately
starts 4-way handshake after association, PaC can consider AP as
Type (c). Otherwise it is Type (b).
 
The PaC behavior after identifying an Type (b) AP is
described in Section 10.2, Section 10.2.1 and Section 10.2.2. "

-- 
------------------------------------------------------
Rafael Marin Lopez
Faculty of Computer Science-University of Murcia
30071 Murcia - Spain
Telf: +34968367645    e-mail: [email-masked]
------------------------------------------------------

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Mon, 30 Jan 2006 12:26:15 -0500

Rafa,

The text looks good.  One minor comment below.

> to take an additional action of trying to associate to the AP.

The PaC can distinguish (b) and (c) if the PaC already has a PSK
bootstrapped from PANA.  So the text should be:

"
However Types (b) and (c) are not distinguishable by a PaC that
does not have a PSK bootstrapped from PANA for the AP, because in both
cases PSK mode is advertised in the RSN IE.  Thus, the PaC will 
need to take an additional action of trying to associate to the AP.
"

> described in Section 10.2, Section 10.2.1 and Section 10.2.2. "

Yoshihiro Ohba

---

From: Rafa Marin Lopez <[email-masked]>
Date: Mon, 30 Jan 2006 13:50:25 -0500

Hi Yoshi,

Agree with the modification.