Subject: AW: [Pana] Re: [issue229] Comments on Device-ID choice

From: "Tschofenig, Hannes" <[email-masked]>
Date: Thu, 26 Jan 2006 01:25:57 +0100

what guidance would you like to see, alper? 

i had problems understanding the initial review comments. 

so, what sort of info should we deliver (without trying to write the text already in a specification type of style)? 

hannes

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im 
> Auftrag von Alper Yegin
> Gesendet: Donnerstag, 26. Januar 2006 01:04
> An: 'Yoshihiro Ohba'; 'Hannes Tschofenig PANA-Issues'; 
> Tschofenig, Hannes
> Cc: [email-masked]
> Betreff: RE: [Pana] Re: [issue229] Comments on Device-ID choice
> 
> > > > >or an identifier that is not carried in data
> > > > >   packets but has local significance in identifying a 
> connected
> > device
> > > > >   (e.g., circuit id, PPP interface id).  The last type of
> > identifiers
> > > > >   are commonly used in point-to-point links where MAC 
> addresses are
> > > > not
> > > > >   available and lower-layers are already physically or
> > > > >   cryptographically secured.
> > > > >
> > > > >
> > > > PPPoE and L2TP use an identifier for a PPP session that 
> is carried in
> > > > the header itself, and have nothing to do with physical or
> > cryptographic
> > >
> > > [hannes] i think that this issue will be resolved once we use two
> > different
> > > terms for layer-two addresses and for security mechanisms.
> > >
> > > >
> > > > security.
> > >
> > > We will revise the text to include the PPPoE/L2TP cases.
> > >
> > > [hannes] what text do you have in mind?
> > 
> > Something like:
> > 
> > "
> >    The device identifier used in the context of PANA can be an IP
> >    address, a MAC address, or an identifier that is not 
> carried in data
> >    packets but has local significance in identifying a 
> connected device
> >    (e.g., circuit id, PPP interface id).  The last type of 
> identifiers
> >    are commonly used in point-to-point links where MAC 
> addresses are not
> >    available and lower-layers are already physically or
> >    cryptographically secured.  Identifiers that are not related to
> >    physical or cryptographic security (e.g., session identifiers in
> >    PPP tunneling protocols) are not used as device identifiers.
> > "
> 
> 
> I'm not sure if this last sentence really helps. It does not 
> really give any
> guidance.
> 
> Alper
> 
> 
> 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: "Alper Yegin" <[email-masked]>
Date: Fri, 27 Jan 2006 01:55:50 +0200

> what guidance would you like to see, alper?

I'm not after any particular guidance or message. It's just that reading the
above sentence did not really clarify what cannot be a device identifier. 

When I read it again, now I found it confusing too. On one side we are
talking about "device identifiers", and on the other side we are talking
about "identifiers related to physical or crypto security". 

I don't know what (if anything?!?) we should say here. But the current text
is not good, imho.

Alper

> so, what sort of info should we deliver (without trying to write the text
> already in a specification type of style)?

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 27 Jan 2006 10:28:38 -0500

Alper and Hannes,

We can further improve the text something like:

"
Device identifiers used in the context of PANA are identifiers 
that are related to physical or cryptographic security.  Any of the 
following identifiers can be used for device identifiers: an IP 
address, a MAC address and an identifier that is not carried in data
packets but has local significance in identifying a connected device
(e.g., circuit id, PPP interface id).  The last type of identifiers 
is commonly used in point-to-point links where MAC addresses are not
available and lower-layers are already physically or cryptographically
secured.
"

Relationship between "device identifiers" and "identifiers related
to physical or crypto security" is clearly stated in the first
sentence.  Now we do not need to talk about PPPoE/L2TP session
identifiers.

Does this make sense?

Yoshihiro Ohba