Subject: RE: [Pana] pana-pana Issue240: PaC Updating its IP address [Proposedtext]

From: "Alper Yegin" <[email-masked]>
Date: Mon, 6 Feb 2006 14:01:47 +0200

I had few comments on this. Sorry for the late response.

> 5.8  PaC Updating its IP Address and Device Identifier
> 
>    A PaC's IP address can change in certain situations.  For example,
>    the PANA framework [I-D.ietf-pana-framework] describes a case in
>    which a PaC replaces a pre-PANA address (PRPA) with a post-PANA
>    address (POPA).  In another situation a PaC may change its IP
>    address used for PANA when it moves from one IP link to another
>    within the same PAA's realm.  In order to maintain the PANA
>    session, the PAA needs to be notified about the change of PaC
>    address.
> 
>    On the other hand, the device identifier of the PaC can also change
>    in the same situations.  In order to maintain the device identifier
>    state at EP(s), the PAA needs to be notified about the change of
>    device identifier as well so that the PAA can update the EP(s) with
>    the change (in addition, if there is an IPsec SA between the PaC
>    and an EP, the EP will need to be notified by the PaC about the
>    change using MOBIKE [I-D.ietf-mobike-protocol]).

I'd propose retuning of the last paragraph as:

    If the device identifier of the PaC is the IP address, it is also
    subject to the same change. The PAA needs to be notified about the 
    change of device identifier as well so that the PAA can update the 
    EP(s). If IPsec is used between the PaC and the EPs, an IKE
    or MOBIKE [I-D.ietf-mobike-protocol] run is needed following such 
    a change.

>    After the PaC has changed its IP address and/or device identifier,

I think we should not say "and/or device identifier". Changing IP address is
the only condition leading to transmission of the PUR message.

>    it MUST send a PANA-Update-Request message to the PAA.  When the
>    PaC has changed its device identifier, the PANA-Update-Request

"If the PaC has also changed its device identifier,"

>    message MUST include a Device-Id AVP containing the new device
>    identifier.  The PAA MUST update the PANA session
>    with the new PaC address carried in the Source Address field of
>    the IP header and the new device identifier carried in the
>    Device-Id AVP, and return a PANA-Update-Answer message.  The
>    PANA-Update-Answer message MAY contain one or more Device-Id AVPs
>    for the EP(s) associated with the new subnet.  

     The PANA-Update-Answer message MUST contain one or more Device-Id AVPs
     for the EPs if the set of EPs serving the PaC has also changed. 

>    If there is an
>    established PANA SA, both PANA-Update-Request and
>    PANA-Update-Answer messages MUST be protected with a MAC AVP.
> "
> 
> [2] Change Section 7.18 from:
> 
> "
> 7.18  PANA-Update-Request (PUR)
> 
>    The PANA-Update-Request (PUR) message is sent either by the PaC or
>    the PAA to deliver attribute updates and notifications.  In the scope
>    of this specification only the PaC IP address can be updated via this
>    mechanism.
> 
>    PANA-Update-Request ::= < PANA-Header: 10, REQ >
>                        < Session-Id >
>                        [ Notification ]
>                     *  [ AVP ]
>                    0*1 < MAC >
> "
> 
> to:
> 
> "
> 7.18  PANA-Update-Request (PUR)
> 
>    The PANA-Update-Request (PUR) message is sent either by the PaC or
>    the PAA to deliver attribute updates and notifications.  In the scope
>    of this specification only the IP address and device identifer of the
> PaC
>    can be updated via this message.
> 
>    PANA-Update-Request ::= < PANA-Header: 10, REQ >
>                        < Session-Id >
>                        [ Device-Id }

[ Device-Id ]

>                        [ Notification ]
>                     *  [ AVP ]
>                    0*1 < MAC >
> "
> 
> [3] Change Section 7.19 from:
> 
> "
> 7.19  PANA-Update-Answer (PUA)
> 
>    The PANA-Update-Answer (PUA) message is sent by the PAA (PaC) to the
>    PaC (PAA) in response to a PANA-Update-Request from the PaC (PAA).
> 
>    PANA-Update-Answer ::= < PANA-Header: 10 >
>                        < Session-Id >
>                        [ Notification ]
>                     *  [ AVP ]
>                    0*1 < MAC >
> "
> 
> to:
> 
> "
> 7.19  PANA-Update-Answer (PUA)
> 
>    The PANA-Update-Answer (PUA) message is sent by the PAA (PaC) to the
>    PaC (PAA) in response to a PANA-Update-Request from the PaC (PAA).

We shall also add:

     When the incoming PUR message includes the new device identifier of the
     PaC, the PAA may include a list of EP device identifiers in the PUA
     message.

> 
>    PANA-Update-Answer ::= < PANA-Header: 10 >
>                        < Session-Id >
>                     *  [ Device-Id ]
>                        [ Notification ]
>                     *  [ AVP ]
>                    0*1 < MAC >
> "
> 
> [4] Add a normative reference to draft-ietf-mobike-protocol.
> 
> 
> Comments are appreciated,

Alper

> 
> Yoshihiro Ohba
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Mon, 06 Feb 2006 09:52:46 -0500

Alper,

>     or MOBIKE [I-D.ietf-mobike-protocol] run is needed following such 

OK.

> the only condition leading to transmission of the PUR message.

I guess removing "and/or device identifier" should work, then.

> "If the PaC has also changed its device identifier,"

OK.

>      for the EPs if the set of EPs serving the PaC has also changed. 

OK.

> >    PANA-Update-Request ::= < PANA-Header: 10, REQ >

Sorry about this.

>      PaC, the PAA may include a list of EP device identifiers in the PUA

OK.

Thank you,
Yoshihiro Ohba