Subject: Re: [Pana] Re: review pana spec

From: Mohan Parthasarathy <[email-masked]>
Date: Thu, 30 Nov 2006 13:53:20 -0800 (PST)

Yoshi,

Inline..

> 
> the draft looks pretty good. I mainly went through the differences. Here are my comments. 
> 
> - Abstract calls it "link-layer" agnostic where as in the Introduction, there is
>   "minimum" link-layer dependency. Having gone through this discussion many
>   times it might be better to remove both these terms to avoid lengthy discussions :-)

For Abstract, we can replace "link-layer agnostic transport" with 
"network layer transport".  For Introduction we can remove 
"minimum link-layer dependency".

mohan> That sounds good.

> -Section 5.6 " Pac Updating its IP addresses" : Is this needed for basic operation of PANA ?
>  The example given in the section makes me believe that it is not required. But it is required
>  depending on what IP address you start with. Hence, some clarification is required.

Perhaps what we need to say is that PaC needs to update its IP address
*used for PANA*.  (We don't need to say which IP address is used for
PANA, which may be described by deployment-specific PANA applicability
documents.)

Here is revised text for Section 5.6 (also reflecting Alper's
comment):

"
5.6.  PaC Updating its IP Address

   A PaC's IP address used for PANA can change in certain situations,
   e.g., when the PaC moves from one IP link to another within the
   same PAA's realm.  In order to maintain the PANA session, the PAA
   needs to be notified about the change of PaC address.  In order to
   maintain the PANA session, the PAA needs to be notified about the
   change of the IP address of the PaC.

   After the PaC has changed its IP address used for PANA, it MUST
   send a PANA-Update-Request message to the PAA.  The PAA MUST update
   the PANA session with the new PaC address carried in the Source
   Address field of the IP header and return a PANA-Update-Answer
   message.  If there is an established PANA SA, both
   PANA-Update-Request and PANA-Update-Answer messages MUST be
   protected with an AUTH AVP.
"

mohan> It is still confusing because it is still not clear whether it is required when
the PaC is not moving (which is the basic operation).  At least refer to PANA framework
document here.

Rest are fine.

-mohan

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 30 Nov 2006 20:39:17 -0500

Mohan,

On Thu, Nov 30, 2006 at 01:53:20PM -0800, Mohan Parthasarathy wrote:
(snip)
> the PaC is not moving (which is the basic operation).  At least refer to PANA framework

The PaC is considered as moving if an IP address used for PANA changes
but the same PAA is discovered (note PAA discovery is outside the
scope of PANA).  Isn't the first paragraph clear about that?  

BTW, PANA framework does not discuss IP address configuration stuff
any more, so referring to PANA framework does not help.

Regards,
Yoshihiro Ohba