Subject: Re: [Pana] Re: review pana spec

From: Mohan Parthasarathy <[email-masked]>
Date: Fri, 1 Dec 2006 11:26:18 -0800 (PST)

the problem with removing "Other situations" is that my question still
remains. When i read the draft it makes me feel that for PANA basic
operation, IP address updates are not needed. We need some rewording
to make sure that it does not give the wrong impression.

-mohan

----- Original Message ----
From: Alper Yegin <[email-masked]>
To: Yoshihiro Ohba <[email-masked]>; Mohan Parthasarathy <[email-masked]>
Cc: [email-masked]
Sent: Friday, December 1, 2006 7:48:40 AM
Subject: RE: [Pana] Re: review pana spec

> 5.6.  PaC Updating its IP Address
> 
>    A PaC's IP address used for PANA can change in certain situations,
>    e.g., when the PaC moves from one IP link to another within the
>    same PAA's realm.  Other situations may be described in deployment-
>    specific PANA applicability documents.  In order to maintain the

I'd recommend deleting the last sentence ("Other situations...."). It does
not provide any useful information.

>    PANA session, the PAA needs to be notified about the change of PaC
>    address.  In order to maintain the PANA session, the PAA needs to
>    be notified about the change of the IP address of the PaC.

Last sentence repeated.

> 
>    After the PaC has changed its IP address used for PANA, it MUST
>    send a PANA-Update-Request message to the PAA.  The PAA MUST update
>    the PANA session with the new PaC address carried in the Source
>    Address field of the IP header and return a PANA-Update-Answer
>    message.  If there is an established PANA SA, both
>    PANA-Update-Request and PANA-Update-Answer messages MUST be
>    protected with an AUTH AVP.
> "

Alper

> 
> Regards,
> Yoshihiro Ohba
> 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 4 Dec 2006 00:32:36 +0200

> operation, IP address updates are not needed. 

I think the first part already answers this question:

   same PAA's realm.

> We need some rewording

Isn't the above statement sufficient?

Alper