Subject: [Pana] References

From: "Alper Yegin" <[email-masked]>
Date: Thu, 13 Mar 2008 16:07:23 +0200

We discussed these two issues during the PANA WG meeting on Wednesday. Now
running this by the ML...

RFC Editor said:

----------8<------------------
Our editor has started working on <draft-ietf-pana-pana-18.txt>, and points
out that Section 1 states:

   These components are
   described in separate documents (see [I-D.ietf-pana-framework] and
   [I-D.ietf-dhc-paa-option]).  The readers are recommended to read
   the PANA Framework document [I-D.ietf-pana-framework] prior to
   reading this protocol specification document.

We note that <draft-ietf-pana-framework> is listed as an informative
reference, but it seems strange that it is recommended reading that should
take place before reading the current <draft-ietf-pana-pana> document.  
-------------8<-----------------------------------

There was an agreement at the meeting to delete the last sentence ("The
readers ... document.") to avoid confusion.

...

We also discussed if we should provide informative references to pana
specification documents (pana-pana, pana-ipsec) from framework document
(pana-framework) instead of the normative ones as currently done in the
document. There was no objection to this change.

Unless there is objection in the next few days, we are going to make these
changes. 

Alper 

_______________________________________________
Pana mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pana

---

From: <[email-masked]>
Date: Thu, 13 Mar 2008 17:07:56 +0100

Hi Alper,

I suggested that we could keep the sentence but to change "recommended" fro something else...
We may put something like:

"The readers are invited to read the PANA Framework document [I-D.ietf-pana-framework]
to find further details on the general PANA functional elements, high-level call flow,
and deployment environments."

Just to indicate that such info details exist... But not in this document!

Lionel

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De 
> la part de Alper Yegin
> Envoyé : jeudi 13 mars 2008 15:07
> À : [email-masked]
> Objet : [Pana] References
> 
> 
> We discussed these two issues during the PANA WG meeting on 
> Wednesday. Now running this by the ML...
> 
> RFC Editor said:
> 
> Our editor has started working on 
> <draft-ietf-pana-pana-18.txt>, and points out that Section 1 states:
> 
>    These components are
> We note that <draft-ietf-pana-framework> is listed as an 
> informative reference, but it seems strange that it is 
> recommended reading that should take place before reading the 
> current <draft-ietf-pana-pana> document.  
> There was an agreement at the meeting to delete the last 
> sentence ("The readers ... document.") to avoid confusion.
> 
> ...
> 
> We also discussed if we should provide informative references 
> to pana specification documents (pana-pana, pana-ipsec) from 
> framework document
> (pana-framework) instead of the normative ones as currently 
> done in the document. There was no objection to this change.
> 
> 
> Unless there is objection in the next few days, we are going 
> to make these changes. 
> 
> 
> Alper 
> 
>

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 31 Mar 2008 14:33:53 +0300

Hi Lionel,

Sorry for the late response. I got a note from RFC Editor and she said the
doc is held up by this issue.

> and deployment environments."

I'm afraid this'd still cause the same issue. Recommended vs. invited --
does not read much different to me. IMO, that's the intent in providing the
first sentence below, and the second sentence becomes redundant (and
troubling, according to the RFC Editor). 

    These components are

I don't think we lose anything if we don't use the last sentence.

Alper