Subject: [Pana] What to do with I-D: draft-ietf-pana-ipsec

From: <[email-masked]>
Date: Thu, 9 Apr 2009 21:05:53 +0200

Hello,

The PANA WG developed the concept of securing the link between the host and
the access router (PaC and EP) using IPsec. The I-D: draft-ietf-pana-ipsec
has not been revised since 2005 and I do not see any interest in doing so
either. 
Additionally I believe that the need to use PANA for securing the access
link does not have much traction.

Two questions:
1. Should we drop this I-D from the PANA WG scope
2. If the answer to (1) is no, are there any volunteers who would be willing
to revise the I-D and complete the work.

-Raj

---

From: "Glen Zorn" <[email-masked]>
Date: Fri, 10 Apr 2009 08:25:07 +0700

> 1. Should we drop this I-D from the PANA WG scope

No.

> to revise the I-D and complete the work.

I'll do it.

> 
> -Raj
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pana

---

From: Julien Bournelle <[email-masked]>
Date: Fri, 10 Apr 2009 09:00:36 +0200

Hello,

>> 1. Should we drop this I-D from the PANA WG scope

No. If one day PANA is used. This would be a missing piece. Thus I
would prefer to keep it.

>> to revise the I-D and complete the work.

If needed, I can help.

 Regards,

 Julien

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Apr 2009 12:12:10 +0300

My primary issue with this document was the lack of cycles, if there had 
been no one interested in taking it to completion we should have dropped 
it. Since you two are volunteering, can you work with the chairs to take 
over the work, and do whatever is needed to bring the document to a 
reasonable state?

Jari

---

From: <[email-masked]>
Date: Tue, 14 Apr 2009 10:12:23 +0200

I'm also volunteering for helping in this work.

Lionel 

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De 
> la part de Jari Arkko
> Envoyé : lundi 13 avril 2009 11:12
> À : Julien Bournelle; Glen Zorn
> Cc : [email-masked]; [email-masked]
> Objet : Re: [Pana] What to do with I-D: draft-ietf-pana-ipsec
> 
> My primary issue with this document was the lack of cycles, 
> if there had been no one interested in taking it to 
> completion we should have dropped it. Since you two are 
> volunteering, can you work with the chairs to take over the 
> work, and do whatever is needed to bring the document to a 
> reasonable state?
> 
> Jari
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 14 Apr 2009 19:50:11 -0400

There is a related document (i.e., draft-ohba-pana-pemk-02) that
defines PaC-EP Master Key (PEMK).  PEMK is derived to be
cryptographically independent across multiple different types of lower
layers including IPsec.  What should we do with pana-pemk draft?

Yoshihiro Ohba

---

From: <[email-masked]>
Date: Wed, 15 Apr 2009 04:05:33 +0200

Hi Yoshi,

Current intent is to complete the WG I-Ds. Given that the PEMK I-D is not a WG document at this time, I would be reluctant to consider any further action from the PANA WG perspective. 

-Raj 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Yoshihiro Ohba
Sent: Tuesday, April 14, 2009 6:50 PM
To: Jari Arkko
Cc: [email-masked]; Patil Basavaraj (Nokia-D/Dallas)
Subject: Re: [Pana] What to do with I-D: draft-ietf-pana-ipsec

There is a related document (i.e., draft-ohba-pana-pemk-02) that defines PaC-EP Master Key (PEMK).  PEMK is derived to be cryptographically independent across multiple different types of lower layers including IPsec.  What should we do with pana-pemk draft?

Yoshihiro Ohba

On Mon, Apr 13, 2009 at 12:12:10PM +0300, Jari Arkko wrote:
> My primary issue with this document was the lack of cycles, if there 
> had been no one interested in taking it to completion we should have 
> dropped it. Since you two are volunteering, can you work with the 
> chairs to take over the work, and do whatever is needed to bring the 
> document to a reasonable state?
>
> Jari
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 15 Apr 2009 09:22:25 +0300

Can we technically specify the IPsec parts without PEMK? If yes, we 
should do it. If not, we have an issue.

Quickly scanning through the documents, PaC-EP-Master-Key does not seem 
to be defined in RFC 5191 but it is used by draft-ietf-pana-ipsec. At 
the very least we need a definition of Pac-EP-Master-Key in 
draft-ietf-pana-ipsec, not sure if a separate document is needed.

Jari

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 15 Apr 2009 17:10:38 +0700

Jari Arkko [mailto:[email-masked]] writes:

> to be defined in RFC 5191 but it is used by draft-ietf-pana-ipsec. 

One of the problems w/draft-ietf-pana-ipsec is that the precise nature of
the protection between the PaC & EP doesn't seem to be specified _anywhere_
(please correct me if I'm wrong).  For the purposes of
draft-ietf-pana-ipsec, the connection should probably be protected using
IPsec (to avoid a weakest-link attack), but that needs to be specified.  As
for draft-ohba-pana-pemk-02, it specifies (as does 5191) the use of the MSK
which is a _really_ bad idea IMHO -- the EMSK should really be used instead.

> At the very least we need a definition of Pac-EP-Master-Key in

...

~ gwz

Nuclear power: more toxic than Britney Spears.

---

From: "Alper Yegin" <[email-masked]>
Date: Wed, 15 Apr 2009 16:51:19 +0300

Jari,

PaC-EP-Master-Key used to be defined in PANA base specification.
Sam Hartman had asked it be split into a separate document, so we did.

PaC-EP-Master-Key is the glue between PANA and the PaC-EP secure association
protocols.
PaC-EP-Master-Key definition is agnostic to the PaC-EP secure association
protocol, therefore I don't think it makes sense to embed that into
individual protocol document(s).

Alper

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Jari Arkko
> Sent: Wednesday, April 15, 2009 9:22 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> > Current intent is to complete the WG I-Ds. Given that the PEMK I-D is
> not a WG document at this time, I would be reluctant to consider any
> further action from the PANA WG perspective.
> >
> > -Raj
> >

---

From: "Alper Yegin" <[email-masked]>
Date: Wed, 15 Apr 2009 16:55:18 +0300

> As

Why so?

Secure association protocols have been using MSK-driven keys.
And it makes sense, as MSK is what NAS knows (not EMSK).
I have no idea what value using EMSK has, but the obvious cost is to impact
the AAA deployment between the NAS and AAA servers. Today AAA protocols
deliver MSK, not EMSK or any of its children.

Alper

---

From: Jari Arkko <[email-masked]>
Date: Wed, 15 Apr 2009 17:05:43 +0300

I think I agree with what Alper is saying below. It is obviously 
important to have separated keys for PANA itself and the per-packet 
protection (such as for IPsec). But given the definition of the keys 
used for PANA in the RFC, I think it is possible to have other 
MSK-derived keys for IPsec.

Jari

---

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Fri, 17 Apr 2009 09:40:22 -0700

If the use of the key is entirely within the PANA authenticator and PANA
specifications then using the MSK is OK.  If the same key is going to be
used in specifications independent of PANA (802.11, etc) or used
somewhere other than the authenticator then the MSK may not be a good
choice.  

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jari Arkko
> Sent: Wednesday, April 15, 2009 7:06 AM
> To: Alper Yegin
> Cc: [email-masked]; [email-masked]; [email-masked]
> I think I agree with what Alper is saying below. It is 
> obviously important to have separated keys for PANA itself 
> and the per-packet protection (such as for IPsec). But given 
> the definition of the keys used for PANA in the RFC, I think 
> it is possible to have other MSK-derived keys for IPsec.
> 
> Jari
> 
> Alper Yegin wrote:
> >> As
> >> for draft-ohba-pana-pemk-02, it specifies (as does 5191) 
> the use of 
> >> the MSK which is a _really_ bad idea IMHO -- the EMSK 
> should really 
> >> be used instead.
> >>     
> >
> > Why so?
> >
> > I have no idea what value using EMSK has, but the obvious 
> cost is to 
> > impact the AAA deployment between the NAS and AAA servers. 
> Today AAA 
> > protocols deliver MSK, not EMSK or any of its children.
> >
> > Alper
> >
> >
> >
> >
> >
> >
> >   
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 17 Apr 2009 20:36:15 +0300

Right.

Jari

---

From: "Alper Yegin" <[email-masked]>
Date: Fri, 17 Apr 2009 20:49:51 +0300

Joe,

PaC-EP key is used by the PaC and the EP.
EP may be physically separate from the PAA (e.g., a base station separated
from NAS).
PaC-EP key is used by the secure association protocol between the PaC and
the EP.

I'm not sure if these satisfy your conditions. Please let us know.

Alper

> From: Joseph Salowey (jsalowey) [mailto:[email-masked]]
> Sent: Friday, April 17, 2009 7:40 PM
> To: Jari Arkko; Alper Yegin
> Subject: RE: [Pana] What to do with I-D: draft-ietf-pana-ipsec
>