Subject: [Pana] FW: I-D Action:draft-yegin-pana-unspecified-addr-00.txt

From: "Alper Yegin" <[email-masked]>
Date: Mon, 1 Mar 2010 16:47:31 +0200

Comments are welcome.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of [email-masked]
Sent: Monday, March 01, 2010 3:00 PM
To: [email-masked]
Subject: I-D Action:draft-yegin-pana-unspecified-addr-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Protocol for Carrying Authentication for Network
Access (PANA) with IPv4 Unspecified Address
	Author(s)       : A. Yegin, Y. Ohba
	Filename        : draft-yegin-pana-unspecified-addr-00.txt
	Pages           : 9
	Date            : 2010-03-01

This document defines how PANA client (PaC) can perform PANA authentication
prior to configuring an IP address.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-yegin-pana-unspecified-addr-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Richard Pruss <[email-masked]>
Date: Tue, 2 Mar 2010 08:25:43 +1000

This will break networks in so many ways it is hard to even predict.
What will the average ARP implementation do with this horror.

On 02/03/2010, at 12:47 AM, Alper Yegin wrote:

> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pana

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 2 Mar 2010 10:09:30 +0200

> What will the average ARP implementation do with this horror.

Please elaborate.

---

From: Richard Pruss <[email-masked]>
Date: Tue, 2 Mar 2010 18:16:34 +1000

>> What will the average ARP implementation do with this horror.

You really do like to answer a question with a question,
What will ARP do with the packets of your draft?
All parts of ARP, gratuitous, probe, arp learning, spoofing protection, it all seems to fall apart.

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 2 Mar 2010 11:56:46 +0200

Ric, you have to be really specific.
You are not explaining what specific problem you are seeing, and I'm not
able to imagine.
Why would ARP break, please tell us. Both DHCP and Mobile IPv4 already work
with unspecified IP addresses.

> From: Richard Pruss [mailto:[email-masked]]
> Sent: Tuesday, March 02, 2010 10:17 AM
> To: Alper Yegin
> Cc: [email-masked]
> Subject: Re: [Pana] FW: I-D Action:draft-yegin-pana-unspecified-addr-
> 00.txt
> 
>

---

From: Richard Pruss <[email-masked]>
Date: Tue, 2 Mar 2010 20:09:38 +1000

Well the protection of the ARP table will simply drop your packets specification
because they are not DHCP and do not have a valid IP address and thus illegal.

http://tools.ietf.org/html/draft-baker-sava-cisco-ip-source-guard-00

Have you thought of running PANA over DHCP instead.

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 2 Mar 2010 13:28:58 +0200

> because they are not DHCP and do not have a valid IP address and thus

Are you talking about your/a product, or a spec?
I don't see that in any spec, including the one you referenced below.

> >> All parts of ARP, gratuitous, probe, arp learning, spoofing
> protection,
> >> it all seems to fall apart.
> >>
> >>
> >>>
> >>>
> >>>