Subject: [PANRG] I-D Action: draft-irtf-panrg-what-not-to-do-04.txt

From: [email-masked]
Date: Sun, 03 Nov 2019 19:01:58 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Path Aware Networking RG RG of the IRTF.

        Title           : Path Aware Networking: Obstacles to Deployment (A Bestiary of Roads Not Taken)
        Author          : Spencer Dawkins
	Filename        : draft-irtf-panrg-what-not-to-do-04.txt
	Pages           : 34
	Date            : 2019-11-03

Abstract:
   At the first meeting of the Path Aware Networking Research Group, the
   research group agreed to catalog and analyze past efforts to develop
   and deploy Path Aware technologies, most of which were unsuccessful,
   in order to extract insights and lessons for path-aware networking
   researchers.

   This document contains that catalog and analysis.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-04
https://datatracker.ietf.org/doc/html/draft-irtf-panrg-what-not-to-do-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 3 Nov 2019 21:08:37 -0600

Dear PANRG,

On Sun, Nov 3, 2019 at 9:02 PM <[email-masked]> wrote:

> _______________________________________________
> Panrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/panrg

I've included a description of our discussion at IETF 105 on whether the
Lessons we've Learned are design invariants, or whether Path Aware
Networking technology designers need to look at their proposals and
consider those lessons.

I've also added a correction from David Black (thanks, David!).

My apologies for not pushing harder on this draft since IETF 105, but I've
now secured ongoing IETF sponsorship, so please expect more of me in the
future.

Please feel free to send comments or corrections via e-mail or Github pull
requests, as described in the draft.

I look forward to continued discussion in Singapore, whether you're there
in person or on Meetecho.

Travel safely.

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 Nov 2019 17:37:01 +0800

Dear PANRG,

I realized three things as I worked on slides for IETF 106.

   - I am planning to ask for a Last Call within the research group in the
   near future, and
   - There is significant new text in -04 describing the IETF 105
   discussion that I haven't heard comments on, from the research group, and
   - Our session is in the last slot of Friday, and I have 15 minutes, and
   I would LOVE it if we don't spend precious face to face time wordsmithing
   new text that Spencer has written.

If you have an opportunity to take a look at
https://tools.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04.txt
before
Friday, focusing on Section 3, that would be great, and if you have an
opportunity to send email or pull requests about anything that seems
strange or insane, that would be REALLY great.

Thanks,

Spencer, as editor

---

From: Michael Welzl <[email-masked]>
Date: Wed, 20 Nov 2019 17:59:16 +0800

Hi,

I recently read this, for the first time after a long break (I think my last time was -00), and I must say that I love this document.
So useful, and so well written!  Congratulations!

Cheers,
Michael

> On Nov 20, 2019, at 5:37 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Dear PANRG,
> 
> I am planning to ask for a Last Call within the research group in the near future, and 
> There is significant new text in -04 describing the IETF 105 discussion that I haven't heard comments on, from the research group, and
> Our session is in the last slot of Friday, and I have 15 minutes, and I would LOVE it if we don't spend precious face to face time wordsmithing new text that Spencer has written. 
> If you have an opportunity to take a look at https://tools.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04.txt <https://tools.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04.txt> before Friday, focusing on Section 3, that would be great, and if you have an opportunity to send email or pull requests about anything that seems strange or insane, that would be REALLY great.
> 
> Thanks,
> 
> Spencer, as editor
> 
> 
> On Mon, Nov 4, 2019 at 11:08 AM Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> Dear PANRG, 
> 
> On Sun, Nov 3, 2019 at 9:02 PM <[email-masked] <mailto:[email-masked]>> wrote:
> 
> https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/ <https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/>
> 
> https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-04 <https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-04>
> https://datatracker.ietf.org/doc/html/draft-irtf-panrg-what-not-to-do-04 <https://datatracker.ietf.org/doc/html/draft-irtf-panrg-what-not-to-do-04>
> 
> https://www.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04 <https://www.ietf.org/rfcdiff?url2=draft-irtf-panrg-what-not-to-do-04>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/panrg <https://www.irtf.org/mailman/listinfo/panrg>
> 
> I've included a description of our discussion at IETF 105 on whether the Lessons we've Learned are design invariants, or whether Path Aware Networking technology designers need to look at their proposals and consider those lessons. 
> 
> My apologies for not pushing harder on this draft since IETF 105, but I've now secured ongoing IETF sponsorship, so please expect more of me in the future.  
> 
> Please feel free to send comments or corrections via e-mail or Github pull requests, as described in the draft.
> 
> I look forward to continued discussion in Singapore, whether you're there in person or on Meetecho. 
> 
> Travel safely.
> 
> Spencer