Subject: Re: [PANRG] Just a quick comment about the PANRG work

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 4 Feb 2021 08:51:42 -0600

Hi, Adrian,

I'm adding the IRSG and PANRG, because this comment is arriving post-RG,
but I think it's a good comment.

On Wed, Feb 3, 2021 at 5:53 PM Adrian Farrel <[email-masked]> wrote:

> Hi there,
>
> I just had cause to go back and look at the PANRG drafts. I was trying to
> see the relationship with APN and with PCE for some other stuff I'm doing.
>
> What I found was that there is great clarity about "path aware" but
> absolutely no clarity about "path". I suspect this is because each of the
> people contributing knows exactly what they mean by the term, but I also
> suspect that they don't all mean the same thing.
>
> For some, a path is a transport-level thing (cf. MPTCP). For others it is a
> set of major hops (cf. CDN). For still others it is the choice of NFV
> function instances (cf. SFC). For still more it may be a meta-routing idea
> (such as an AS path). And lastly, for others it might be a routing-level
> hop-by-hop path.
>
> All of those would be valid things to consider, but I think the document is
> mainly working at the transport layer or higher.
>
> Do you think it would be possible to get a definition of "path" included?
>

I think this is an excellent suggestion, and
https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2
does include a defintion of "Path" that the RG is working with.

I think that
https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2
("What Does "Path Awareness" Mean in this Document?") would be an excellent
place to include a reference to our terminology draft. which is already
used as a reference later in the document..

https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2
includes this text:

   Because this document reflects work performed over several decades,
   some technologies described in Section 6
<https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-16#section-6>
may not reflect the current
   definition, but these technologies were considered "path aware" by
   their contributors, so these contributions are included in this
   retrospective document.

I think adding

   Because this document reflects work performed over several decades,
   some technologies described in Section 6
<https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-16#section-6>
may not reflect the current

-   definition, but these technologies were considered "path aware" by

+   definitions of "path" and "path awareness", but but these
technologies were considered "path aware" by

   their contributors, so these contributions are included in this
   retrospective document.

would be accurate.

Does anyone have an objection to making this change?

Best,

Spencer

Cheers,
> Adrian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 4 Feb 2021 08:53:50 -0600

And now, actually including the IRSG (my apologies for the error!).

Best,

Spencer

On Thu, Feb 4, 2021 at 8:51 AM Spencer Dawkins at IETF <
[email-masked]> wrote:

>    some technologies described in Section 6 <https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-16#section-6> may not reflect the current
>    some technologies described in Section 6 <https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-16#section-6> may not reflect the current
>
>
> +   definitions of "path" and "path awareness", but but these technologies were considered "path aware" by
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 4 Feb 2021 15:10:46 -0000

Yeah, my screw up that the document is already out of the RG before I got round to reading it. I know how annoying that can be for authors and for the whole RG. 

However, I figured the RG would still want to fix any issues (if, indeed, they are issues) before the documents become RFCs.

So I also sent my own email to the list (which everyone is free to copy on to the IRSG). You’ll notice from that email that one of my concerns was that -questions does not have a definition of “path” even though it defines “path aware” quite nicely. My suggestion was that this could be solved with a normative reference to -path-properties.

Cheers,

Adrian

From: Spencer Dawkins at IETF <[email-masked]> 
Sent: 04 February 2021 14:54
To: [email-masked] Steering Group <[email-masked]>
Cc: [email-masked]; Adrian Farrel <[email-masked]>
Subject: Re: Just a quick comment about the PANRG work

Best,

Spencer

On Thu, Feb 4, 2021 at 8:51 AM Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]> > wrote:

Hi, Adrian, 

I'm adding the IRSG and PANRG, because this comment is arriving post-RG, but I think it's a good comment. 

On Wed, Feb 3, 2021 at 5:53 PM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Hi there,

I think this is an excellent suggestion, and https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2 does include a defintion of "Path" that the RG is working with. 

I think that https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2 ("What Does "Path Awareness" Mean in this Document?") would be an excellent place to include a reference to our terminology draft. which is already used as a reference later in the document.. 

https://tools.ietf.org/html/draft-irtf-panrg-path-properties-01#section-2 includes this text:

I think adding 

 

would be accurate. 

Best,

Spencer

Cheers,
Adrian