Subject: Re: [Paw] tentative PAW charter

From: "Cavalcanti, Dave" <[email-masked]>
Date: Fri, 1 Feb 2019 16:58:57 +0000

Hi Pascal and All,

Thanks for sharing the draft charter. Here is an update on the related activities in the IEEE 802.11 working group:

The RTA TIG is finalizing a report that includes several time-sensitive use cases, requirements and potential solutions/areas for enhancements in 802.11 to better support RTA/TSN applications. Here is the link to the draft report:
https://mentor.ieee.org/802.11/dcn/18/11-18-2009-04-0rta-rta-report-draft.docx

The group arrived to a consensus in the January meeting that the work to be done in support of RTA should be done in the upcoming 802.11 EHT group (currently EHT is a Study Group and it is expected to be a new TG in May). The RTA TIG will finalize its report and conclude its activities in the next meeting (March), and the work will continue in EHT. 

Given this status, we could leverage the use cases/requirements defined by the RTA TIG, but we should avoid pointing to 802.11 RTA as a new solution, this may give the wrong impression that there will be a new 802.11 RTA specific amendment. Going forward, we should refer to 802.11 EHT as the group that will develop new MAC/PHY capabilities and address the RTA/TSN requirements.

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

As you know, we asked for a non-WG forming BoF at IETF 103 in Prague. If we are successful there, the aim is for a WG-forming BoF in Montreal. 
This really means that Prague is our chance to prepare for the real deal in Montreal, where we will have to show realistic goals and a critical mass of people to achieve them.
The core of the Montreal meeting will be the charter discussion. We'll present the technologies we support, and the documents we want to produce.

The work on the charter must start now, so we can narrow it down at IEF 103 and present it mostly complete at IETF 104. 
Based on early discussions at the Bar-BoF in Bangkok, please find below a for shot at the charter. Comments welcome!

Early PAW charter v0.1
-------------------------------
	
	Deterministic IP Networks are getting traction in multiple industries 
	(manufacturing, vehicle automation, professional A/V, gaming) with new
	developments in wired technologies (IEEE 802.1 TSN, IETF DetNet), enabling 
	the promises of the IT/OT convergence. 
	
	A perfect Deterministic IP Network would ensure that a bounded throughput
	of IP packets reaches its destination within a guaranteed time. In an
	imperfect world, Deterministic Networking is an attempt to eliminate packet
	loss for a committed bandwidth while ensuring a worst case end-to-end 
	latency, regardless of the network conditions and across technologies. 
 
    	Networks become more deterministic when the effects of statistical
	multiplexing are eliminated. This can be achieved by maintaining the
	amount of traffic within the physical capabilities of the technology,
	e.g., by the use of time-shared resources (bandwidth and buffers) per
	circuit, and/or by shaping and/or scheduling the packets at every hop.

    	Other types of physical-domain issue, e.g., a radio interference, a
	broken interface adapter, or an unplugged physical wire, can also be a
	source of data loss. When such breakage occurs, multiple packets are lost
	in a row before a flow is rerouted or the system recovers. Whereas random 
	packet loss can be solved by packet redundancy techniques (FEC, ARQ) these
	systemic issues a require higher-level redundancy at the path level.

	People might argue that wireless cannot be fully "deterministic" due to 
	uncontrolled interferences, including the self-induced multipath fading. 
	At least it is possible to provide a more Predictable and Available
	Wireless service by scheduling transmissions. Scheduling enables to create 
	diversity in the network in the spatial (multipath), time (scheduling) and
	frequency (hopping) domains, and get around all forms of interferences.
	
	The development of deterministic wireless technologies was so far lagging 
	behind that of wires both at the IEEE and the IETF. But recent advances
	(3GPP 5G, IEEE 802.11 ART, IEEE 802.15.4 TSCH, as well as proprietary and 
	military approaches) indicate that wireless is finally catching up at the
	lower layer and that time has come for the IETF to implement the 6TiSCH 
	Architecture and extend DetNet to wireless interfaces.
      
    	The Working Group will leverage cross-participation with the associated 
	set of stakeholders to ensure that the work taking place corresponds to 
	real demands and that the proposed solutions are indeed applicable. It 
	will focus on enabling PAW connectivity over the following selection of 
	deterministic wireless technologies: 3GPP 5G, IEEE Real Time Application 
	(RTA) 802.11 TIG, IEEE Std. 802.15.4 TSCH and possibly the L-band Digital
	Aeronautical Communications System (LDACS).

    The group will:

        1) Produce Informational work describing deterministic wireless
           use cases, in continuation to the DetNet use cases document
		
         2) Produce Informational work describing the technologies that the
            group will cover (5G, TSCH, RTA and LDACS) 

        3) Produce a Standards Track document to define the generic data models
           to install a PAW flow along a Track providing Packet Replication, 
           Elimination and Ordering Functions with Spatial, Frequency and Time
           diversity in a Scheduled FD/TDMA wireless Network.

        4) Produce a Standards Track document to enable some operations, 
           administration and maintenance (OAM) inside a PAW network, providing
           packet loss evaluation and automated adaptation to enable a trade off
           between resilience and energy spending.

-----------------------------

Cheers,

Pascal

-- 
Paw mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/paw

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 4 Feb 2019 07:22:52 +0000

Many thanks Dave,

I'll update the tentative charter accordingly (s/RTA/EHT).

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 4 Feb 2019 11:21:06 +0000

Dear all:

Please find below the reworded text. Comments welcome!

	Deterministic Networking is getting traction in multiple industries 
	(manufacturing, vehicle automation, professional A/V, gaming) with recent
	developments in wired technologies (IEEE 802.1 TSN, IETF DetNet), enabling 
	the promises of the IT/OT convergence. 
	
	Deterministic Networking in the IP world is an attempt to eliminate packet 
	loss for a committed bandwidth while ensuring a worst case end-to-end 
	latency, regardless of the network conditions and across technologies. 
	
	IP networks become more deterministic when the effects of statistical
	multiplexing (jitter and collision loss) are eliminated. This requires a 
	tight control of the physical resources to maintain the amount of traffic
	within the physical capabilities of the underlying technology, e.g., by the 
	use of time-shared resources (bandwidth and buffers) per circuit, and/or by
	shaping and/or scheduling the packets at every hop.

	Wireless operates on a shared medium, and transmissions cannot be fully
	deterministic due to uncontrolled interferences, including the 
	self-induced multipath fading. But scheduling enables to alleviate those 
	effects	by leveraging diversity in the spatial, time and frequency domains, 
	and provide a more Predictable and Available Wireless (PAW) service.
	
	The wireless and wired media are fundamentally different at the physical 
	level, and while the generic Problem Statement for DetNet applies to the 
	wireless medium as well as to wires, the methods to achieve PAW necessarily
	differ from those used to support Time-Sensitive Networking over wires.  
	
	The development of PAW technologies was so far lagging behind that of wires
	both at the IEEE and the IETF. But recent efforts at the IEEE and 3GPP 
	indicate that wireless is finally catching up at the lower layer and that 
	time has come for the IETF to extend DetNet to wireless and implement the 
	scheduled aspect of the 6TiSCH Architecture.
	
	PAW will centralize efforts that inherit from DetNet and 6TiSCH but focus 
	on scheduled wireless. The Working Group will leverage cross-participation
	with the associated set of stakeholders to ensure that the work taking place
	corresponds to real demands and that the proposed solutions are indeed 
	applicable. It will focus on enabling PAW connectivity over the following
	selection of deterministic wireless technologies: IEEE Std. 802.15.4 
	timeslotted channel hopping (TSCH), 3GPP 5G ultra-reliable low latency 
	communications (URLLC), IEEE 802.11 extreme high throughput (EHT) and the 
	L-band Digital Aeronautical Communications System (LDACS).

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 4 Feb 2019 23:00:39 +0000

Hi Pascal,
I have a couple of general comments, and if we agree in principle then if needed I could provide some specific text. 
1) Since this is an IETF project I think the use cases you mention in the opening paragraph should be IP use cases (as opposed to TSN use cases like automotive) - I would stick with a subset of the DetNet Use Cases (not that I'm biased). 
2) The phrase about "implement the scheduled aspect of the 6TiSCH Architecture" seems too specific to 6TiSCH, given the clarification below that we would be considering scheduled wireless in general. I mean, so as not to give the impression that we are just serving that specific technology (that you happen to be heavily involved in). 

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 5 Feb 2019 07:35:47 +0000

I agree with both Ethan. Could you propose text?
For your convenience I attached a txt file.

All the best,

Pascal

-----Original Message-----
From: Grossman, Ethan A. <[email-masked]> 
Sent: mardi 5 février 2019 00:01
To: Pascal Thubert (pthubert) <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal,

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 5 Feb 2019 19:02:46 +0000

OK, here's what I put together. I also attempted to clarify some of the other language, without intending to change the import of it. 
Ethan.

-----Original Message-----
From: Pascal Thubert (pthubert) <[email-masked]> 
Sent: Monday, February 04, 2019 11:36 PM
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

All the best,

Pascal

-----Original Message-----
From: Grossman, Ethan A. <[email-masked]> 
Sent: mardi 5 février 2019 00:01
To: Pascal Thubert (pthubert) <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal,

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Feb 2019 10:49:01 +0000

Hello Ethan:

My understanding is that in the charter, which is a contract between the WG and the IESG, we cannot be vague with text like " and other wireless protocol developments, " because we will be asked precisely what they are. 
At the IETF and for all I know, only DetNet and 6TiSCH care about determinism, so I guess we'd better leave it at that.

Similarly, the sentence "
	Thus we propose to pursue deterministic wireless in PAW, an IETF Working
	Group, coordinated with (but not part of) the DetNet Working Group.
" is needed for BoF slides and Ad discussion, but then again is not really good for a charter.

I remixed a bit and there we are, please find attached a proposed revision.

All the best,

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) <[email-masked]> 
Sent: Monday, February 04, 2019 11:36 PM
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

All the best,

Pascal

-----Original Message-----
From: Grossman, Ethan A. <[email-masked]> 
Sent: mardi 5 février 2019 00:01
To: Pascal Thubert (pthubert) <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal,

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Feb 2019 10:58:10 +0000

Slight update ... 

All the best,

Pascal

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 6 février 2019 11:49
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Hello Ethan:

All the best,

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) <[email-masked]> 
Sent: Monday, February 04, 2019 11:36 PM
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

All the best,

Pascal

-----Original Message-----
From: Grossman, Ethan A. <[email-masked]> 
Sent: mardi 5 février 2019 00:01
To: Pascal Thubert (pthubert) <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal,

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 6 Feb 2019 15:39:34 +0000

Dear all:

Incorporating changes proposed by Ethan and Jerome, please fond the latest charter attached:

All the best,

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 6 Feb 2019 18:31:26 +0000

Improving! 
Ethan.

-----Original Message-----
From: Pascal Thubert (pthubert) <[email-masked]> 
Sent: Wednesday, February 06, 2019 2:58 AM
To: Pascal Thubert (pthubert) <[email-masked]>; Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Slight update ... 

All the best,

Pascal

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 6 février 2019 11:49
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Hello Ethan:

All the best,

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) <[email-masked]> 
Sent: Monday, February 04, 2019 11:36 PM
To: Grossman, Ethan A. <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

All the best,

Pascal

-----Original Message-----
From: Grossman, Ethan A. <[email-masked]> 
Sent: mardi 5 février 2019 00:01
To: Pascal Thubert (pthubert) <[email-masked]>; Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal,

Ethan.

-----Original Message-----
From: Paw <[email-masked]> On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, February 4, 2019 3:21 AM
To: Cavalcanti, Dave <[email-masked]>; [email-masked]
Subject: Re: [Paw] tentative PAW charter

Dear all:

	

	

    The group will:

What do you think?

Pascal

-----Original Message-----
From: Pascal Thubert (pthubert) 
Sent: lundi 4 février 2019 08:23
To: 'Cavalcanti, Dave' <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Many thanks Dave,

All the best,

Pascal

-----Original Message-----
From: Cavalcanti, Dave <[email-masked]> 
Sent: vendredi 1 février 2019 17:59
To: Pascal Thubert (pthubert) <[email-masked]>; [email-masked]
Subject: RE: tentative PAW charter

Hi Pascal and All,

Thanks
Dave

-----Original Message-----
From: Paw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, January 31, 2019 6:40 AM
To: [email-masked]
Subject: [Paw] tentative PAW charter

Dear all:

Early PAW charter v0.1

 

	

    The group will:

Cheers,

Pascal