Subject: [paws] [A new PAWS DB Discovery Draft]

From: Weixinpeng <[email-masked]>
Date: Mon, 18 Feb 2013 02:20:09 +0000

Hi all,
A new draft of DB Discovery has been submitted:
http://www.ietf.org/id/draft-wei-paws-database-discovery-00.txt

Comments are welcome!!

--Xinpeng Wei.

---

From: Peter Stanforth <[email-masked]>
Date: Mon, 18 Feb 2013 13:09:15 -0500

I am Still not a fan of basing DB discovery on the LOST protocol. It seems to be way to complicated and I would hope someone can explain how to reconcile the capability with the need.
That said the following comments are independent of the LOST protocol.

The introduction should be expanded to identify that there are many ways that a device could get access to a database not just the manually programmed example given.

The WSDB DS will very likely be nested. I cannot see Ofcom giving up ownership and authority of its DB discovery process for instance. So a WSDB DS would have to reconcile that a WSD was in the UK regulatory domain and provide a reference to the Ofcom DB Management system.

Under current US rules there is no concept of a WSDB DS radios are certified against a database. However a device certified in the USA may travel to other countries and then need to use a WSDB DS. So the other case that needs to be discussed is a device that in some instances has a preconfigured link to a database and the ability to use a WSDB DS in other cases.  There may be a situation (and I am making this up for an example) where a device is certified in the US along with a database, certified in Canada along with a database and certified generically in the rest of the world. This device may have a hierarchy where it checks with the US DB first. If it gets denied (because it is outside the regulatory domain) then it tries Canada and if that also fails goes to the WSDB DS.

This raises a couple of questions. Is the WDSB DS going to return all "certified" databases in a regulatory domain or only the ones that are appropriate for the device making the query?
How is the set of regulatory certified domains mapped to those databases willing to serve the device or the databases the device is willing to go to (This is a business decision)? Wearing my DB provider hat, I only want to (and only will) serve devices for which I have a business relationship with the manufacturer or possibly the owner.
Does this process work if the owner of the device is to make the decision rather than the device?
Did we cover the correct set of responses from a DB to cover this mechanism?
Although the WSDB DS thinks that the device should be associated with a DB the DB does not
The DB does not want to serve the device even though it is on the WSDB DS list
The Device does not want to work with a DB on the list (how does it know if all it gets is a URL – so radio vendor x is won't work with  DB provider y)
The device has a preference to work with DB vendor y in as many regulatory domains as possible

It seems many of these can be addressed more easily if the device uses a manufacturer provided discovery process (as it will have knowledge of the business relationships) rather than some new global entity that will have to be created, maintained and supported.  Which brings me to my final question who owns and operates the WSDB DS and who pays for it?

Regards,
Peter S.

From: Weixinpeng <[email-masked]<mailto:[email-masked]>>
Date: Sunday, February 17, 2013 9:20 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Peter McCann <[email-masked]<mailto:[email-masked]>>
Subject: [paws] [A new PAWS DB Discovery Draft]

Hi all,

Comments are welcome!!

--Xinpeng Wei.

---

From: Weixinpeng <[email-masked]>
Date: Tue, 19 Feb 2013 03:52:45 +0000

Thanks for your comments. Please see my answers inline.
Best Regards,
Xinpeng W.

From: Peter Stanforth [mailto:[email-masked]]
Sent: Tuesday, February 19, 2013 2:09 AM
To: Weixinpeng; [email-masked]
Cc: Peter McCann
Subject: Re: [paws] [A new PAWS DB Discovery Draft]

The introduction should be expanded to identify that there are many ways that a device could get access to a database not just the manually programmed example given.
[Wei] Yeah, you are right here, I there are many ways for a device getting access to a database besides manually programmed, and I will describe more in detail in the later version.

This raises a couple of questions. Is the WDSB DS going to return all "certified" databases in a regulatory domain or only the ones that are appropriate for the device making the query?
[Wei] Here the databases return from WSDB DS means all the certified databases in a regulatory domain. Whether a database is appropriate is not decided in the discovery procedure, but in the following procedure when WSD connects to the database, if the selected database cannot serve the WSD, the WSD will ignore the database and try another one and so on.

       The Device does not want to work with a DB on the list (how does it know if all it gets is a URL - so radio vendor x is won't work with  DB provider y)

It seems many of these can be addressed more easily if the device uses a manufacturer provided discovery process (as it will have knowledge of the business relationships) rather than some new global entity that will have to be created, maintained and supported.  Which brings me to my final question who owns and operates the WSDB DS and who pays for it?
[Wei] The discovery mechanism provided here is an optional method and it may be cooperated with other method to find the appropriate database for WSD.

Regards,
Peter S.

Hi all,

Comments are welcome!!

--Xinpeng Wei.

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 19 Feb 2013 14:32:13 -0500

As someone who participated in the LoST development, things like this always look complex until you try to build something "simpler".  It's just not a simple problem.  You can make it simpler only by changing the problem.  For example, you can require some amount of provisioning before it will work.

The way LoST works, the national regulator can control how resolution of the LoST servers works.  You can have all queries within a country go to a specific server that then refers or iterates to another server, or you can return a list of servers that can satisfy the response and let the client choose.

Brian

On Feb 18, 2013, at 10:52 PM, Weixinpeng <[email-masked]<mailto:[email-masked]>> wrote:

From: Peter Stanforth [mailto:[email-masked]<http://spectrumbridge.com>]
Sent: Tuesday, February 19, 2013 2:09 AM
To: Weixinpeng; [email-masked]<mailto:[email-masked]>
Cc: Peter McCann
Subject: Re: [paws] [A new PAWS DB Discovery Draft]

Regards,
Peter S.

Hi all,

Comments are welcome!!

--Xinpeng Wei.
_______________________________________________
paws mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/paws