Subject: [Pce] RE: Comment on draft-ietf-pce-pcecp-interarea-reqs-00.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Fri, 13 Jan 2006 10:22:02 +0100

Hi Zhang
 
sorry for replying so late...
 
Please see inline,

________________________________

	De : Zhang Renhai [mailto:[email-masked]] 
	Envoyé : mercredi 28 décembre 2005 08:04
	À : LE ROUX Jean-Louis RD-CORE-LAN
	Cc : [email-masked]
	Objet : Comment on draft-ietf-pce-pcecp-interarea-reqs-00.txt

	Hi, Jean-Louis
	 
	 I have some comment on the draft draft-ietf-pce-pcecp-interarea-reqs-00.txt
	 
	 In section 7.11.1, In case of network failure, jittering will be used to avoid
	simultaneous requests sent to one PCE. Could more consideration be given here to
	the preemptment, becouse the jittering timeout is stochastic, some lower request
	may be served before a higher request and the path may be calculated differently.
	which may increase the probability of a preemptment. 
	 
	JLLR: You raised a good point.
	First of all note that this point is not a protocol requirement, this is a local implementation issue, and the jittering was just given as an example...
	The PCC could apply different jitter to low priority and high priority requests, and could send
	high priority request before low priority one, this is a local PCC decision.
	Also the request prioritization function could be used so that the PCE serves high priority requests first. The way a PCE is going to handle request prioritites is also a local implementation issue.
	Maybe we should remove this sentence to avoid any confusion. 
	By the way note that this section is generic and has just been moved to the generic requirement draft.
	So we will have to clarify in the generic draft. 

	 I have always been thinking a question: if a PCC will not perform the CSPF 
	computation, why does it still maintain the TEDB any longer? which may consume 
	a lot of memory and CPU of a LSR.This question dost not aid at this draft. 
	 
	[JLLR] A LSR may be a PCC for some LSPs and a PCE for other LSPs. 
	Anyway a LSR that runs ISIS or OSPF for IP routing has to maintain a LSDB. I agree removing TE info would save some memory and CPU but the gain sounds quite low compared to the impact: For any computation, even a simple intra-area CSPF, you would have to ask a PCE, and this may lead to a high PCE stress. You would have a small CPU gain on LSRs at a cost of a huge CPU consumption on PCEs...
	 
	In inter-area environment,sometimes, a PCC may wish to get as many paths as possible,
	for all kinds of purpose,so could the PCC send the request to more than one PCEs?  
	 
	[JLLR] Yes, and this is a procedure local to the PCC, that does not imply specific PCECP procedure.
	 
	Thanks for these valuable comments
	 
	Regards,
	 
	JL

	Regards,
	Zhang 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Fri, 13 Jan 2006 08:10:51 -0500

Hi,

On Jan 13, 2006, at 4:22 AM, LE ROUX Jean-Louis RD-CORE-LAN wrote:

> First of all note that this point is not a protocol requirement,  
> this is a local implementation issue, and the jittering was just  
> given as an example...
> Also the request prioritization function could be used so that the  
> PCE serves high priority requests first. The way a PCE is going to  
> handle request prioritites is also a local implementation issue.
Thanks indeed to remove this section since this is out of scope.

JP.
> Anyway a LSR that runs ISIS or OSPF for IP routing has to maintain  
> a LSDB. I agree removing TE info would save some memory and CPU but  
> the gain sounds quite low compared to the impact: For any  
> computation, even a simple intra-area CSPF, you would have to ask a  
> PCE, and this may lead to a high PCE stress. You would have a small  
> CPU gain on LSRs at a cost of a huge CPU consumption on PCEs...
>

---

From: Zhang Renhai <[email-masked]>
Date: Mon, 16 Jan 2006 16:53:05 +0800

Hi, Jean-Louis

 Thanks for your reply, see inline.
  ----- Original Message ----- 
  From: LE ROUX Jean-Louis RD-CORE-LAN 
  To: Zhang Renhai 
  Cc: [email-masked] 
  Sent: Friday, January 13, 2006 5:22 PM
  Subject: RE: Comment on draft-ietf-pce-pcecp-interarea-reqs-00.txt

  Hi Zhang

  Please see inline,

----------------------------------------------------------------------------

    Hi, Jean-Louis

    [ZRH] I agree.

    [JLLR] A LSR may be a PCC for some LSPs and a PCE for other LSPs. 
    Anyway a LSR that runs ISIS or OSPF for IP routing has to maintain a LSDB. I agree removing TE info would save some memory and CPU but the gain sounds quite low compared to the impact: For any computation, even a simple intra-area CSPF, you would have to ask a PCE, and this may lead to a high PCE stress. You would have a small CPU gain on LSRs at a cost of a huge CPU consumption on PCEs...
    [ZRH]yes, your expanation is great, I think you are right.

    [JLLR] Yes, and this is a procedure local to the PCC, that does not imply specific PCECP procedure.
    [ZRH] I noticed that in the draft draft-ietf-pce-architecture-03, there are already restriction for a PCC to sent multiple
    requests for a LSP. So I would likt to ask if the restriction can be remove before we reach a agreement 
    on this point? 

    Regards,

    JL

    Regards,
    Zhang