Subject: [Pce] Please comment on draft-ietf-pce-disco-proto-isis-07.txt

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 13 Sep 2007 22:30:04 +0100

Hi,

http://www.ietf.org/internet-drafts/draft-ietf-pce-disco-proto-isis-07.txt 
has recently been posted. The last couple of revisions addressed comments 
raised by the IESG and by the IGP working group chairs, etc.

This is a call to you for a further review of the I-D.

We'll run with a two week deadline to 28th September.

Many thanks,
Adrian 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Meral Shirazipour <[email-masked]>
Date: Fri, 14 Sep 2007 17:36:34 -0400

Hi,
    In draft draft-ietf-pce-disco-proto-isis-07 Section 4 Page 7, it is
mentioned:
“
No additional sub-TLVs will be added to the PCED TLV in the future. If a future
application requires advertising additional PCE information in IS-IS, this will
not be carried in the CAPABILITY TLV.
“
-Is there a technical reasoning behind this decision?

-I would also change the last two words :” CAPABILITY TLV “ to “IS-IS Router
Capability TLV ([IS-IS-CAP])” to avoid any confusion with the PCE-CAP-FLAGS
sub-TLV :)

    In draft draft-ietf-pce-disco-proto-ospf-07 Section 4 Page 7, it is
mentioned:
“
No additional sub-TLVs will be added to the PCED TLV in the future. If a future
application requires advertising additional PCE information in OSPF, this will
not be carried in the Router Information LSA.
”
-Same question here.

Warm Regards,
Meral

---

From: Hannes Gredler <[email-masked]>
Date: Wed, 19 Sep 2007 11:45:54 +0200

no comment - looks good to me - /hannes

Adrian Farrel wrote:
> has recently been posted. The last couple of revisions addressed 
> comments raised by the IESG and by the IGP working group chairs, etc.
>

---

From: JP Vasseur <[email-masked]>
Date: Tue, 25 Sep 2007 08:59:48 -0400

Hi,

Some concerns were expressed by several individuals,
and OSPF WG chairs about the potential size of the PCED and more
recently issues were raised during IESG review because of the dynamic
nature of the CONGESTION TLV carried within the PCED TLV.

So the agreement we had was to:
1) Indicate in the document that no further sub-TLV will be added in the
future. Should there be a need to advertise more PCE capability, this  
can
still be part of the PCEP session establishment phase. *If* at some  
point,
there is a need to use the IGP to advertise more data, then this  
should be
done using the GENINFO TLV defined draft-ginsberg-isis-genapp
potentially using a different Is-IS instance and by using a new
Opaque LSA.
2) Remove the CONGESTION TLV from both documents.

The updated documents (rev 08) have just been posted and account for
these changes along with other comments that we received.

Thanks.

JP.

On Sep 14, 2007, at 5:36 PM, Meral Shirazipour wrote:

>> comments

---

From: Hannes Gredler <[email-masked]>
Date: Tue, 25 Sep 2007 17:23:14 +0200

hi jp,

agreed as far as pce is concerned,
one comment on the *If* section -

i do not think that replacing a bloated TLV with another
bloated TLV [genapp] will buy us anything. i.e. the
size is not getting smaller ;-)

[genapp] is primarily a vehicle for not running out of
TLV codepoints for 'per-application' use.

Given that the pced TLV is well structured and has a
proper support for TLV nesting there is no need to use
[genapp].

so at best a "may" is appropriate, certainly no "should".

/hannes

JP Vasseur wrote:
> future. Should there be a need to advertise more PCE capability, this can
> still be part of the PCEP session establishment phase. *If* at some point,
> there is a need to use the IGP to advertise more data, then this should be
>> Selon Adrian Farrel <[email-masked] <mailto:[email-masked]>>:
>>
>>> Hi,
>>>
>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
> 
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg