Subject: [Pce] I-D ACTION:draft-ietf-pce-pcep-xro-04.txt

From: [email-masked]
Date: Wed, 19 Mar 2008 10:30:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Path Computation Element Working Group of the IETF.

	Title		: Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions
	Author(s)	: E. Oki, A. Farrel
	Filename	: draft-ietf-pce-pcep-xro-04.txt
	Pages		: 16
	Date		: 2008-3-19
	
The Path Computation Element (PCE) provides functions of path 
   computation in support of traffic engineering in Multi-Protocol 
   Label Switching (MPLS) and Generalized MPLS (GMPLS) networks. 
    
   When a Path Computation Client (PCC) requests a PCE for a route, it 
   may be useful for the PCC to specify, as constraints to the path 
   computation, abstract nodes, resources, and Shared Risk Link Groups 
   (SRLGs) that are to be explicitly excluded from the computed route. 
   Such constraints are termed route exclusions. 
   
   The PCE Communication Protocol (PCEP) is designed as a communication 
   protocol between PCCs and PCEs. This document presents PCEP 
   extensions for route exclusions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pce-pcep-xro-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Fabien Verhaeghe" <[email-masked]>
Date: Thu, 20 Mar 2008 08:49:21 +0100

Hi,

Sorry to come back on this subject but it is still not clear to me why we
are using different subobject types between XRO and ERO/RRO/IRO in PCEP.

Is there any particular reason?

In http://www.ietf.org/internet-drafts/draft-ietf-pce-pcep-11.txt
     Type   Subobject
        1   IPv4 prefix
        2   IPv6 prefix
        4   Unnumbered Interface ID
       32   Autonomous system number

In http://www.ietf.org/internet-drafts/draft-ietf-pce-pcep-xro-04.txt

        Type           Subobject 
        -------------+------------------------------- 
        1              IPv4 prefix 
        2              IPv6 prefix 
        3              Unnumbered Interface ID 
        4              Autonomous system number 
        5              SRLG

Thanks
Fabien

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mercredi 19 mars 2008 18:30
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Pce] I-D ACTION:draft-ietf-pce-pcep-xro-04.txt
> 
> 	Title		: Extensions to the Path Computation Element
> Communication Protocol (PCEP) for Route Exclusions

---

From: Eiji Oki <[email-masked]>
Date: Fri, 21 Mar 2008 09:27:24 +0900

Fabien, 

Yes, you are right. We should match the base PCEP spec.
We will change 3 to 4, 4 to 32, and 5 to 34.
Is it OK to make this change during working group last call?

Thank you.
Eiji

On Thu, 20 Mar 2008 08:49:21 +0100
"Fabien Verhaeghe" <[email-masked]> wrote:

> > De?: [email-masked] [mailto:[email-masked]] De la part de
> > [email-masked]
> > Envoy鬆: mercredi 19 mars 2008 18:30
> > タ?: [email-masked]
> > Cc?: [email-masked]
> > Objet?: [Pce] I-D ACTION:draft-ietf-pce-pcep-xro-04.txt
> >

---

From: JP Vasseur <[email-masked]>
Date: Fri, 21 Mar 2008 15:24:18 -0400

Hi Eiji,

> From: Eiji Oki <[email-masked]>
> Date: Fri, 21 Mar 2008 09:27:24 +0900
> To: Fabien Verhaeghe <[email-masked]>
> Cc: <[email-masked]>
> Subject: Re: [Pce] I-D ACTION:draft-ietf-pce-pcep-xro-04.txt
> 
> Fabien, 
> 

If OK with you I would suggest to make the change now, and we will then Last
Call the document.

Thanks.

JP.

---

From: Eiji Oki <[email-masked]>
Date: Tue, 25 Mar 2008 08:35:55 +0900

Hi JP, 

Yes. I will submit the revision soon.

Thank you.
Eiji

On Fri, 21 Mar 2008 15:24:18 -0400