Subject: [Pce] Discussions on PCE requirements for GMPLS

From: Fatai Zhang <[email-masked]>
Date: Thu, 14 May 2009 17:41:45 +0800

Hi PCEers

We have a draft (draft-zhang-pce-reqs-for-tdm-00.txt) in the process. This draft describes some requirements for applying Path Computation Element (PCE) in Time-Division Multiplexing (TDM) networks. 

I think GMPLS-based TDM networks can be regarded as sub-set of GMPLS networks (for example, GMPLS-based SDH networks), so the requirements described in this draft (PCE for TDM) are sub-set of the requirments for PCE applied in GMPLS networks.

Therefore, It seems that there may be something overlapped with another draft (draft-ietf-pce-gmpls-aps-req-00.txt), but there is no discription on these requirements in draft-ietf-pce-gmpls-aps-req-00.txt.
 
In addition, I think it is not a good solution to keep PCE requirements for  GMPLS in a few separate documents, so I think it is natural to incorporate the requirements into draft-ietf-pce-gmpls-aps-req-00.txt.

Any comments or suggestions are welcome and helpful.

Thanks

Fatai
 
Advanced Technology Department
Wireline Networking Business Unit
Huawei Technologies Co., LTD.
Huawei Base, Bantian, Longgang,
Shenzhen 518129 P.R.China
Tel: +86-755-28972912
Fax: +86-755-28972935

---

From: <[email-masked]>
Date: Mon, 25 May 2009 09:58:09 +0200

Hi.

It seems that Tomohiro's comment has only reached CCAMP.

Julien

-----Original Message-----
From: Tomohiro Otani [mailto:[email-masked]] 

Hi,

The point is that our draft is now the WG document and tries to
summarize the general GMPLS requirements. In that sense, if another
contribution suggests something be updated in the WG document, 
we should relfect it in a next version. I think that within WG, there
should be a single requirement-draft about one topics and the next step
is not to merge but to update.

Regards,

Tomo

<[email-masked]> ??
   "RE: [Pce] Discussions on PCE requirements for GMPLS" ?????
   "Young Lee <[email-masked]>"????????:

Hi Julien, Diego and Fatai, 

I support the idea of merging PCE requirements for GMPLS. 

I also have a few general requirements from WSON PCEP application in the
area of computing same wavelength (labels) for primary and secondary path
computation. Lou indicated that this may be general enough to be general
GMPLS requirement that can be applied to TDM timeslots, Ethernet labels and
other labels including wavelength. 

Another requirement is bi-directional path and its label (wavelength
assignment) for each direction. We should have ability to assign the same
label or not in PCEP. I think this can be applied to TDM labels or others. 

Regards,
Young
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Diego Caviglia
Sent: Tuesday, May 19, 2009 1:37 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Pce] Discussions on PCE requirements for GMPLS

Hi Julien, hi all,
                  I think would be a good idea to merge the document and not
scatter all the GMPLS relevant info among several documents.

Thanks

Diego

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: luned?18 maggio 2009 19.05
> To: [email-masked]
> Cc: [email-masked]
> Subject: FW: [Pce] Discussions on PCE requirements for GMPLS
> 
> Hello CCAMP.
> 
> As described by Fatai below, 2 documents are on the table in the PCE WG to
> tackle PCE requirements for GMPLS networks. Any feedback that the group
> may have would be appreciated.
> 
> Thanks,
> 
> Julien
> 
> ________________________________
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Fatai Zhang
> 
> Hi PCEers
> 
> We have a draft (draft-zhang-pce-reqs-for-tdm-00.txt) in the process. This
> draft describes some requirements for applying Path Computation Element
> (PCE) in Time-Division Multiplexing (TDM) networks.
> 
> I think GMPLS-based TDM networks can be regarded as sub-set of GMPLS
> networks (for example, GMPLS-based SDH networks), so the requirements
> described in this draft (PCE for TDM) are sub-set of the requirments for
> PCE applied in GMPLS networks.
> 
> Therefore, It seems that there may be something overlapped with another
> draft (draft-ietf-pce-gmpls-aps-req-00.txt), but there is no discription
> on these requirements in draft-ietf-pce-gmpls-aps-req-00.txt.
> 
> In addition, I think it is not a good solution to keep PCE requirements
> for  GMPLS in a few separate documents, so I think it is natural to
> incorporate the requirements into draft-ietf-pce-gmpls-aps-req-00.txt.
>