Subject: Re: [Pce] I-D Action:draft-bao-pce-pre-configured-routing-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 19 Oct 2009 12:29:11 +0100

While this is a reasonably well-written draft, I don't see that it adds 
anything to what we already have in the core RFCs.

In section 4.3 you have...

   There are two options
   for PCE to send pre-configured route as follows:
   PCRep is used to respond route computation result naturally.  If it
   is used to send pre-configured route, a new flag SHOULD be defined to
   indicate the route carried is pre-configured route.

Two questions:
1. What is the other option? You only list one option.
2. Why do you need a flag to indicate that a route is pre-
   configured? Why does the PCC care how the route was
   derived?

You slighlty answer question 2, in section 5.1 where you say...

   When PCC requests pre-configured route

...but why would the PCC ask for a pre-configured route? It just wants a 
route. If there is a policy to be applied by the PCE in selection of the 
route, this should be indicated using the normal policy functions. If there 
is an objective function/algorithm to be applied in selecting the route, 
this should be indicated using the OF object.

So I think that you don't need the pre-configured route flag.

Cheers,
Adrian

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 19 Oct 2009 14:39:11 +0200

Hi, 

I think the term pre-configured route is a bit misleading, I understand
the scenario as the PCC ask for 3 routes, the first one will be
signaled, the 2 other kept in case a failure happens on the first route.

If I am not misunderstood this can be achieved by using the svec with 3
time the same endpoints and bandwidth. 

Regarding the indication that a route has changed, the PCE could send a
PCRep with RRO (not allowed in rfc5440) and ERO containing the new Path,
but what should be the request id of the PCRep?

In addition the PCC could also be aware that the route failed and
request a new Path computation for the failed path. 

In this context I do not see the need to have a new flag in the RP
object for this use case.

Best Regards
Cyril Margaria

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext Adrian Farrel
Sent: Monday, October 19, 2009 1:29 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] I-D
Action:draft-bao-pce-pre-configured-routing-00.txt

   There are two options

Two questions:

route, this should be indicated using the normal policy functions. If
there 
is an objective function/algorithm to be applied in selecting the route,

Cheers,
Adrian 

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 19 Oct 2009 14:20:42 +0100

Hi Cyril,

Fine with what you say, but...

We did consider allowing the PCE to push unsolicited routes to the PCC. We
decided this was not actually the correct information or processing flow.

The point is that a "new route" is only available if a new computation is
performed. But the PCE only performs computations on demand. How would it
know that the network event should cause it to perform a new computation,
and how would it know whether the newly computed route was wanted by the
PCC.

However a third party tool (for example, the NMS, or the VNTM, depending on
the scenario) should be able to perform this function that is heavily
associated with local network and per-LSP policy. In these cases, it is the
management entity that is requesting path computations as the PCC, and it
will push those paths to the LER according to policy.

Of course, the LER could be the PCC and could request the paths, but it is
less likely to be in control of the necessary triggers. This behavior is
actually very similar to what you might expect for reoptimization.

Cheers,
Adrian

----- Original Message ----- 
From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, October 19, 2009 1:39 PM
Subject: RE: [Pce] I-D Action:draft-bao-pce-pre-configured-routing-00.txt

Hi,

Best Regards
Cyril Margaria

-----Original Message-----

   There are two options

Two questions:

Cheers,
Adrian

---

From: [email-masked]
Date: Tue, 20 Oct 2009 16:24:13 +0800

Hi Adrian, 

Thanks for your comments.

The main idea of this draft is to solve the problem of potential 
unavailability 
of pre-configured routes and to provide better service, which is described 
in 
section 2.

For the first question, I'm sorry for the mistake, and this will be 
rectified
in the next version.

For the second question, the flag defined in the draft is to let PCE know 
PCC need
pre-configured route service. And PCC doesn't care how the route was 
derived. 
PCC can update the stored pre-configured route when it receives a PCRep 
message with
the flag set. For PCE, when it receives a PCReq message with flag set, it 
can
recognize a pre-configured route service is requested from PCC. So PCE can 
compute
and send the updated pre-configured route to PCC when the corresponding 
condition 
meets.

Best regards,
Yuanlin Bao

there

---

From: [email-masked]
Date: Tue, 20 Oct 2009 16:51:47 +0800

Hi Cyril,

If you find a better term to substitute the term "pre-configured route", 
please
let me know. Anyone who is interested is welcomed to be a co-author.

Since the main idea of this draft is to solve the potential problem of un
availability
of pre-configured routes, so I don't think it will be achieved by using 
the svec-list.
Beause using svec with multi times can't provide the requested path is 
available when
the primary path fails.

There really exists a problem of request id of the PCRep, if you have any 
good
idea, we can cooperate.

PCC can be aware that the route failed and request a new Path computation 
for the failed
path. However, this will make longer time delay of restoration process , 
since PCC needs 
to send PCReq and PCE needs to compute and send PCRep to PCC.

This context doesn't define any new flag in the RP object, only a new flag 
in LSPA object.

Best Regards,
Yuanlin Bao

"Margaria, Cyril (NSN - DE/Munich)" <[email-masked]> 写于

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 22 Oct 2009 16:54:25 +0800

Hi all,

I am also wondering what is PCE. 

Can PCE give a route or routes to someone unsolicitedly without path computation request (PCReq) from PCC?

Thanks

Fatai
 
Advanced Technology Department
Wireline Networking Business Unit
Huawei Technologies Co., LTD.
Huawei Base, Bantian, Longgang,
Shenzhen 518129 P.R.China
Tel: +86-755-28972912
Fax: +86-755-28972935
  ----- Original Message ----- 
  From: Adrian Farrel 
  To: Margaria, Cyril (NSN - DE/Munich) ; [email-masked] ; [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, October 19, 2009 9:20 PM
  Subject: Re: [Pce] I-D Action:draft-bao-pce-pre-configured-routing-00.txt

  Hi Cyril,

  Cheers,
  Adrian

  ----- Original Message ----- 
  From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
  To: "Adrian Farrel" <[email-masked]>; <[email-masked]>;
  <[email-masked]>; <[email-masked]>
  Cc: <[email-masked]>
  Sent: Monday, October 19, 2009 1:39 PM
  Subject: RE: [Pce] I-D Action:draft-bao-pce-pre-configured-routing-00.txt

  Hi,

  Best Regards
  Cyril Margaria

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf Of
  ext Adrian Farrel
  Sent: Monday, October 19, 2009 1:29 PM
  To: [email-masked]; [email-masked]; [email-masked]
  Cc: [email-masked]
  Subject: Re: [Pce] I-D
  Action:draft-bao-pce-pre-configured-routing-00.txt

     There are two options

  Two questions:

  Cheers,
  Adrian