Subject: [Pce] WG Last Call for draft-ietf-pce-questions-04

From: Julien Meuric <[email-masked]>
Date: Wed, 09 Apr 2014 10:22:51 +0200

Hi all.

This message ignites a PCE WG last call on draft-ietf-pce-questions-04. 
It will end on Wednesday, April 23, 11:59 PM (UTC-12).

Thanks,

JP & Julien

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 9 Apr 2014 16:23:02 +0000

Yes/support

Cheers,
Jeff

-----Original Message-----
From: Julien Meuric <[email-masked]>
Organization: Orange
Date: Wednesday, April 9, 2014 1:22 AM
To: "[email-masked]" <[email-masked]>
Subject: [Pce] WG Last Call for draft-ietf-pce-questions-04

>_______________________________________________
>Pce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pce

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 9 Apr 2014 16:28:57 +0000

Yes/support

Best Regards

Sergio

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Julien Meuric
Sent: mercoledì 9 aprile 2014 10:23
To: [email-masked]
Subject: [Pce] WG Last Call for draft-ietf-pce-questions-04

Hi all.

Thanks,

JP & Julien

---

From: [email-masked]
Date: Thu, 10 Apr 2014 08:01:18 +0800

yes/support

This draft do answer many quesitons.

Thanks
Qilei Wang

Julien Meuric <[email-masked]> 
发件人:  "Pce" <[email-masked]>
2014/04/09 16:22

收件人
"[email-masked]" <[email-masked]>
抄送

主题
[Pce] WG Last Call for draft-ietf-pce-questions-04

Hi all.

Thanks,

JP & Julien

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 Apr 2014 08:03:21 +0100

Thanks chairs,

As part of the last call I would like to know whether we reached complete
closure on the initiated/suggested LSP debate. I think the main protagonists
would be the authors of draft-ietf-pce-pce-initiated-lsp and Dhruv who raised
the issue in the first place.

Thanks,
Adrian

> Sent: 09 April 2014 09:23
> To: [email-masked]

---

From: Qin Wu <[email-masked]>
Date: Mon, 14 Apr 2014 08:27:05 +0000

Hi:
I have reviewed draft-ietf-pce-questions-04 and had a few comments to bellows :

1. Section 19, second paragraph says:
"
   There is a subtle distinction between an NMS and an Active PCE with
   LSP delegation.  An NMS is in control of the LSPs in the network and
   can request that they are set up, modified, or torn down.  An Active
   PCE can only make suggestions about LSPs that have been delegated to
   the PCE by a PCC .
"
Is PCC NMS or LSR headend? If PCC is NMS, it is a little bit confusing to compare Active PCE with LSP delegation with NMS?

2. Section 20 says:
"
                              | Stateless |  Stateful |
      ------------------------+-----------+-----------+
      Passive                 |     1     |     2     |
      Active delegated LSPs   |     3     |     4     |
      Active suggest new LSPs |     5     |     6     |
      Active instantiate LSPs |     7     |     7     |
"
What’s the difference between delegated LSP and suggested new LSP? What’s the difference between suggest new LSP and Instantiate LSPs? Is Active Instantiate LSPs related to PCE initiated LSP?

3. Section 22, last bullet says:
"
     The VNTM will need to issue provisioning requests/commands  to the
     lower layer networks to cause LSPs to be set up to act as TE links
     in the higher layer network.  A number of potential protocols exist
     for this function as described in [I-D.farrkingel-pce-abno-
     architecture], but it should be noted that it makes a lot of sense
     for this interface to be the same as that used by an Active PCE
     when providing paths to the network.
"
Why VNTM should issue provision request? Isn’t it the job of Provision manager? Or VNTM ask Provision manager to issue provision request?

4. Section 23, 2nd paragraph
s/network note/network node

5. Section 23, 3rd paragraph says:
"
   Conversely, a centralized database of resources and LSPs such as
   maintained by a Stateful PCE can be enhanced with a time-based
   booking system.   If the PCE is also Active, then when the time comes
   for the LSP to be set up (or later, when it is to be torn down) the
   PCE can control the network.
"
It looks this sentence breaks and can not be parsed from “and LSP such as maintained by a stateful PCE”
It looks “such as” needs to be removed or
s/ and LSPs such as maintained by/such as LSP maintained by

6. Section 23, last paragraph, says:
"
    It may also be necessary
   to reposition existing or planned LSPs  as new bookings arrive.
   Furthermore, the booking database that contains both the scheduled
   LSPs and their impact on the network resources can become quite
   large.
"
Is planned LSP scheduled LSP? If not, tell difference, if yes, make consistent.

Regards!
-Qin
-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Julien Meuric
发送时间: 2014年4月9日 16:23
收件人: [email-masked]
主题: [Pce] WG Last Call for draft-ietf-pce-questions-04

Hi all.

Thanks,

JP & Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 14 Apr 2014 19:28:09 +0530

Hi Adrian, Chairs,

Use of "recommend instantiation" as suggested by Adrian works for me. (
http://www.ietf.org/mail-archive/web/pce/current/msg03711.html)

Can the authors of draft-ietf-pce-pce-initiated-lsp confirm?

Dhruv

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 Apr 2014 22:17:47 +0100

Hi,
 
Thanks for that Dhruv.
 
On that basis, I would update the second paragraph in Section 17 as...
 
OLD
   An Active PCE is one that issues provisioning "recommendations" to
   the network.  These recommendations may be new routes for existing
   LSPs, or routes for new LSPs.  An Active PCE may be stateless or
   stateful, but in order that it can reroute existing LSPs effectively,
   it is likely to hold state for at least those LSPs that it will
   reroute.
NEW
   An Active PCE is one that issues provisioning "recommendations" to
   the network.  These recommendations may be new routes for existing
   LSPs, or routes for new LSPs (that is, an Active PCE may recommend
   the instantiation of new LSPs).  An Active PCE may be stateless or
   stateful, but in order that it can reroute existing LSPs effectively,
   it is likely to hold state for at least those LSPs that it will
   reroute.
END
 
...and the penultimate paragraph of Section 18 as...
 
OLD
   It is important, however, to distinguish between an LSP established
   within the network and subsequently delegated to a PCE, and an LSP
   that was established by a commands from an Active PCE.
NEW
   It is important, however, to distinguish between an LSP established
   within the network and subsequently delegated to a PCE, and an LSP
   that was established as the result of an  Active PCE's recommendation
   for LSP instantiation.
END
 
...and in Section 19...
 
OLD
   the PCE by a PCC.
NEW
   the PCE by a PCC, or make recommendations for the instantiation of
   new LSPs.
END
 
...and lastly in Section 20...
 
OLD
      6. This mode has potential for recommending new LSPs.
      7. These modes are out of scope for PCE as currently described.
NEW
      6. This mode has potential for recommending the instantiation of
         new LSPs.
      7. These modes are out of scope for PCE as currently described.
         That is, the PCE can recommend instantiation, but cannot 
         actually instantiate the LSPs.
END
 
Cheers,
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: 14 April 2014 14:58
To: Farrel Adrian
Cc: [email-masked]; [email-masked]
Subject: Re: [Pce] WG Last Call for draft-ietf-pce-questions-04
 
Hi Adrian, Chairs, 

Use of "recommend instantiation" as suggested by Adrian works for me. (http://www.ietf.org/mail-archive/web/pce/current/msg03711.html)

Dhruv 

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 Apr 2014 22:54:03 +0100

Thanks Qin,

See also my answer to Dhruv since that modifies some of the text you are asking
about.

> Is PCC NMS or LSR headend? If PCC is NMS, it is a little bit confusing to
compare
> Active PCE with LSP delegation with NMS?

I thought about this a bit and decided that the text is right as it stands.
The possibilities are:

- An NMS uses a passive PCE to compute paths and then instructs
   the network.
- An NMS uses an active PCE to recommend *to*it* the changes to 
   delegated LSPs and to recommend *to*it* new LSPs to be
   instantiated, then the NMS instructs the network.
- An NMS instructs an LSR to set up an LSP and the LSR consults a
   passive PCE to determine a path.
- An NMS instructs an LSR to set up an LSP and the LSR delegates
   the LSP to an active PCE.
- An LSR determines to set up an LSP and the LSR consults a
   passive PCE to determine a path.
- An LSR uses an active PCE to recommend to it the changes to 
  delegated LSPs and to recommend *to*it* new LSPs to be
  instantiated,

The distinction in all these cases is that the active PCE makes recommendations
to the PCC, but the NMS issues instructions to the network.

I think that one word of clarification comes out of this. In the text you quote
I will s/request/command/

> What’s the difference between delegated LSP and suggested new LSP? What’s
> the difference between suggest new LSP and Instantiate LSPs? Is Active
> Instantiate LSPs related to PCE initiated LSP?

Well, this is not only the subject of the previous sections, but also has been
the focus of a bit of debate on the list.

> What’s the difference between delegated LSP and suggested new LSP?

The former is an LSP that has been set up and is then passed (delegated) to the
active PCE for it to recommend changes. The latter does not exist as an LSP
until the active PCE recommends its instantiation.

> What’s the difference between suggest new LSP and Instantiate LSPs?

"Suggestion" is recommending instantiation. But just because something is
recommended, doesn't mean you do it! (Except in some cultures: I had an
interesting discussion with a TSA officer about this once ;-) On the other hand,
"instantiate LSP" implies absolute control.

> Is Active Instantiate LSPs related to PCE initiated LSP

This is the point Dhruv and I are trying to dance around. The topic only applies
to active PCEs, so we need only compare "instantiate" with "initiate". The WG
draft on LSP initiation does not (IMHO) have an active PCE issuing commands that
the PCC must obey. I think it has a PCE that "recommends the instantiation of
LSPs" and the PCC can determine according to policy and weather conditions if it
wishes to follow the recommendation.

Thus, the WG draft on LSP initiation does not talk about what I call "LSP
instantiation" because it does not compel the PCC to set up the LSP. 

This is consistent with my view that a PCE cannot instantiate an LSP, it can
only recommend instantiation.

> Why VNTM should issue provision request? Isn’t it the job of Provision
manager?
> Or VNTM ask Provision manager to issue provision request?

Good catch. Everything should go via Provisioning Manager. This text was written
before Provisioning manager added to ABNO.

I'll update.

> s/network note/network node

ack

> s/ and LSPs such as maintained by/such as LSP maintained by

The "such as" applies to the DB.
I'll reword.

> Is planned LSP scheduled LSP? If not, tell difference, if yes, make
consistent.

The term "scheduled LSP" is not used, so nothing to make consistent with, I
think.

The section begins...
   LSP scheduling or calendaring is a process where LSPs are planned
   ahead of time, and only set up when needed.  
...so to me it is clear what a planned LSP is.

If you have a specific suggestion, then I'd be happy to hear it.

Many thanks,
Adrian

---

From: Julien Meuric <[email-masked]>
Date: Thu, 24 Apr 2014 12:29:33 +0200

Hi all.

This last call has ended.

We have seen interesting discussion. If people who raised comments feel 
the proposed resolutions are not satisfying, please shout. Otherwise, we 
will move forward the accordingly updated document.

Thanks,

JP & Julien

Apr. 09, 2014 - Julien Meuric:
> Hi all.
 >
 > This message ignites a PCE WG last call on
 > draft-ietf-pce-questions-04. It will end on Wednesday, April 23,
 > 11:59 PM (UTC-12).
 >
 > Thanks,
 >
 > JP & Julien
 >
 > _______________________________________________ Pce mailing list
 > [email-masked] https://www.ietf.org/mailman/listinfo/pce
 >
 >

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 24 Apr 2014 11:39:10 +0100

Thanks Julien,

I collected changes as the discussion went on, so I'll post them now and people
can diff to see the updates.

Adrian

> Sent: 24 April 2014 11:30
> To: [email-masked]