Subject: [Pce] Ben Campbell's No Objection on draft-ietf-pce-pcep-service-aware-12: (with COMMENT)

From: "Ben Campbell" <[email-masked]>
Date: Mon, 12 Sep 2016 17:51:47 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-pce-pcep-service-aware-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-service-aware/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

A few minor, mostly editorial comments:

- Abstract: The abstract seems unnecessarily long.  The point is to
describe very briefly what the document is about. The more “motivating”
text could be left to the intro.

-3: Will this section have value to readers of the RFC, once the RFC is
published?

- General:  A lot (if not most) of the instances of “MAY” would better
serve as “can”. They seem to be saying that it is possible for an element
to do something, rather than offering permission to do that thing.

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 13 Sep 2016 11:30:05 +0000

Hi Ben, 

Thanks for your review. Please see inline...

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of Ben Campbell
> Sent: 13 September 2016 06:22
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: [Pce] Ben Campbell's No Objection on
> draft-ietf-pce-pcep-service-aware-12: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> - Abstract: The abstract seems unnecessarily long.  The point is to describe
> very briefly what the document is about. The more “motivating”

[Dhruv] I understand, but we did want to keep the look and feel of this document in line with the sister RFCs - RFC7471, RFC7810 as much as possible. Is it acceptable to you, if we keep the abstract as it is? 

> -3: Will this section have value to readers of the RFC, once the RFC is

[Dhruv] This section was written in a spirit that historically PCE WG has published requirement RFCs and text exist about the key requirements for the PCEP extensions along with the extension itself. If you feel strongly about this, perhaps I can move it to appendix?    

> - General:  A lot (if not most) of the instances of “MAY” would better serve
> as “can”. They seem to be saying that it is possible for an element to do
> something, rather than offering permission to do that thing.
> 

[Dhruv] I have gone through all instance of "MAY" and converted some of them to "can". I have kept the use of "MAY" when talking in terms of inclusion of object inside a PCEP message. I hope you are satisfied by this. I can discuss this with RFC editor during the editing stage too. 

The running working copy handling all comments received so far is attached. 

Thanks again! 

Regards,
Dhruv

> 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 13 Sep 2016 10:38:02 -0400

Hi Dhruv, thanks for the response. Comments inline:

Thanks!

Ben.

On 13 Sep 2016, at 7:30, Dhruv Dhody wrote:

[...]

\>
>> describe
> [Dhruv] I understand, but we did want to keep the look and feel of 
> this document in line with the sister RFCs - RFC7471, RFC7810 as much 
> as possible. Is it acceptable to you, if we keep the abstract as it 
> is?
>

Sure, this was not a show stopper.

> [Dhruv] This section was written in a spirit that historically PCE WG 
> has published requirement RFCs and text exist about the key 
> requirements for the PCEP extensions along with the extension itself. 
> If you feel strongly about this, perhaps I can move it to appendix?

I do not feel strongly. Again, not a show stopper.

> [Dhruv] I have gone through all instance of "MAY" and converted some 
> of them to "can". I have kept the use of "MAY" when talking in terms 
> of inclusion of object inside a PCEP message. I hope you are satisfied 
> by this. I can discuss this with RFC editor during the editing stage 
> too.

I was mainly thinking about the MAYs in sentence of the form, "A PCE/PCC 
MAY use XXX to do YYY". From a quick scan of the diff, it looks like you 
did the right thing.

Thanks!

Ben.