Subject: [Pce] Spencer Dawkins' No Objection on draft-ietf-pce-lsp-setup-type-09: (with COMMENT)

From: Spencer Dawkins <[email-masked]>
Date: Mon, 02 Apr 2018 19:22:33 -0700

Spencer Dawkins has entered the following ballot position for
draft-ietf-pce-lsp-setup-type-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-lsp-setup-type/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I'll let you folks work with Benjamin on this, but I echo his concern about the
level of specification covering sub-TLVs (Spencer's summary: "not much
specification").  As a related comment, I note that not defining any sub-TLVs
in this document prevents the authors from giving any examples of what sub-TLVs
might be appropriate, which would have been helpful for me in both the Abstract
and Introduction.

(I usually prefer clues about whether the reader should be reading a
specification or not. It would be easier for me to know whether this document
is relevant to me, if I knew what kinds of sub-TLVs were envisioned, even if
only a couple of examples were provided. But do the right thing, of course)

---

From: Jonathan Hardwick <[email-masked]>
Date: Mon, 16 Apr 2018 15:54:40 +0000

Hi Spencer

Thanks for your comments.  Please see [Jon] below.

Cheers
Jon

-----Original Message-----
From: Spencer Dawkins [mailto:[email-masked]] 
Sent: 03 April 2018 03:23
To: The IESG <[email-masked]>
Cc: [email-masked]; Julien Meuric <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Spencer Dawkins' No Objection on draft-ietf-pce-lsp-setup-type-09: (with COMMENT)

I'll let you folks work with Benjamin on this, but I echo his concern about the level of specification covering sub-TLVs (Spencer's summary: "not much specification").  As a related comment, I note that not defining any sub-TLVs in this document prevents the authors from giving any examples of what sub-TLVs might be appropriate, which would have been helpful for me in both the Abstract and Introduction.

(I usually prefer clues about whether the reader should be reading a specification or not. It would be easier for me to know whether this document is relevant to me, if I knew what kinds of sub-TLVs were envisioned, even if only a couple of examples were provided. But do the right thing, of course)

[Jon] I have proposed an update to Benjamin.  The draft does not need any sub-TLVs, hence there are no examples, which has been a frequent pattern in PCE RFCs since the working group got started!  Having said that, we could immediately point to the first real example of a PST sub-TLV by providing an informative reference to draft-ietf-pce-segment-routing.  I don't see a problem doing this as the documents were always intended to be published together.  How about

OLD
  This document does not define any sub-TLVs.
NEW
  This document does not define any sub-TLVs; an example can be found in [I-D.ietf-pce-segment-routing].
END

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 16 Apr 2018 11:35:19 -0500

Hi, Jonathan,

On Mon, Apr 16, 2018 at 10:54 AM, Jonathan Hardwick <
[email-masked]> wrote:

> Cc: [email-masked]; Julien Meuric <
> [email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> I'll let you folks work with Benjamin on this, but I echo his concern
> about the level of specification covering sub-TLVs (Spencer's summary: "not
> much specification").  As a related comment, I note that not defining any
> sub-TLVs in this document prevents the authors from giving any examples of
> what sub-TLVs might be appropriate, which would have been helpful for me in
> both the Abstract and Introduction.
>
> specification or not. It would be easier for me to know whether this
> document is relevant to me, if I knew what kinds of sub-TLVs were
> envisioned, even if only a couple of examples were provided. But do the
> right thing, of course)
>
> [Jon] I have proposed an update to Benjamin.  The draft does not need any
> sub-TLVs, hence there are no examples, which has been a frequent pattern in
> PCE RFCs since the working group got started!  Having said that, we could
> immediately point to the first real example of a PST sub-TLV by providing
> an informative reference to draft-ietf-pce-segment-routing.  I don't see
> a problem doing this as the documents were always intended to be published
> together.  How about
>
> OLD

Since I was echoing Benjamin's concern, I'll echo his relief - whatever you
folks work out, will work for me.

But that sounds like a fine plan to me.

Spencer

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 16 Apr 2018 12:25:50 -0500

> But that sounds like a fine plan to me.

Having this additional informational reference also sounds good to
me.

-Benjamin