Subject: [Pce] Martin Vigoureux's No Objection on draft-ietf-pce-lsp-setup-type-09: (with COMMENT)

From: Martin Vigoureux <[email-masked]>
Date: Tue, 03 Apr 2018 02:54:10 -0700

Martin Vigoureux has entered the following ballot position for
draft-ietf-pce-lsp-setup-type-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-lsp-setup-type/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Document says:
   If a PCEP speaker does not recognize the PATH-SETUP-TYPE-CAPABILITY
   TLV, it MUST ignore the TLV in accordance with ([RFC5440]).
and:
   If a PCEP speaker does not recognize the PATH-SETUP-TYPE TLV, it MUST
   ignore the TLV in accordance with ([RFC5440]).

I am fine with this but it does not say anything, explicitly, on what shall be
the selected signalling protocol. I guess it will be RSVP-TE because I guess we
treat this situation in the same way as if there had been no TLV. But since I
am guessing, I feel it wouldn't hurt to be explicit. On the assumption that my
guesses are correct, what about adding, for example, the following sentence (or
anything else you'd judge more appropriate):
   From a signalling protocol selection point of view, this situation is
   treated as if the ... TLV was absent.

---

From: Jonathan Hardwick <[email-masked]>
Date: Tue, 17 Apr 2018 17:27:21 +0000

Hi Martin

Yes, we can assume that implementations will use RSVP-TE if they don't support this draft.

I think the text you quoted has fallen into the mistake of using normative language to specify what is already written in RFC 5440.  Alvaro picked up another instance of this.  How about we change to:

   If a PCEP speaker does not recognize the PATH-SETUP-TYPE-CAPABILITY
   TLV, it will ignore the TLV in accordance with [RFC5440].
and:
   If a PCEP speaker does not recognize the PATH-SETUP-TYPE TLV, it will
   ignore the TLV in accordance with [RFC5440], and will use RSVP-TE to set up the path.

I have added a clarification to the second sentence above, as you requested.

Cheers
Jon

-----Original Message-----
From: Martin Vigoureux [mailto:[email-masked]] 
Sent: 03 April 2018 10:54
To: The IESG <[email-masked]>
Cc: [email-masked]; Julien Meuric <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Martin Vigoureux's No Objection on draft-ietf-pce-lsp-setup-type-09: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Document says:

I am fine with this but it does not say anything, explicitly, on what shall be the selected signalling protocol. I guess it will be RSVP-TE because I guess we treat this situation in the same way as if there had been no TLV. But since I am guessing, I feel it wouldn't hurt to be explicit. On the assumption that my guesses are correct, what about adding, for example, the following sentence (or anything else you'd judge more appropriate):
   From a signalling protocol selection point of view, this situation is
   treated as if the ... TLV was absent.