Subject: [Pce] PCEP extensions for SR-TP

From: Marina Fizgeer <[email-masked]>
Date: Mon, 20 Aug 2018 12:31:07 +0000

Dear authors of draft-xiong-pce-pcep-extension-sr-tp,
My colleagues and I are interested in some clarifications:
According to this draft, Path label can be added as the last label in the LSP SR-ERO list.
Each endpoint element needs 2 labels - one for forward path ID and one for incoming path ID
Our question is - if 2 path labels can be added to the LSP SR-ERO list (one with "R" bit) per LSP?
Path label with "R" bit set will not be added to outgoing label stack, but will be configured in the data plane as an incoming label.
Using this approach one SR-ERO list will contain outgoing Path label as well as incoming Path label
PCE path example:

Best regards,

Marina
Email: [email-masked]<mailto:[email-masked]>
            [email-masked]<mailto:[email-masked]>

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: <[email-masked]>
Date: Wed, 22 Aug 2018 11:28:19 +0800 (CST)

Hi Marina,

Thanks for your attention and comments!  I think you have proposed a good question. 

The "path label " which my draft defined is inserted into ERO list and uniquely identifies a uni-directional path.

So one label can be added to the Ingress ERO list for the  forwarding direction and 

another label with the R bit set to 0 can be added to the egress ERO list for the reverse direction.

The two path labels can be the same or diffrent and can be binded to indentify a bi-directional path.

I will update the draft soon and provide more details.  

More comments are welcome!

Quan

熊泉 xiongquan

软件工程师 Software Engineer
预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product R＆D Institute/Wireline Product Operation

武汉市东湖高新技术开发区华师园路6号中兴通讯 
2/F, R&D Building, ZTE
Corporation, Huashi Park Road 6th, 
Hi-tech Donghu District, Wuhan, P.R.China, 430022
T: +86 27 13871144372
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人：MarinaFizgeer <[email-masked]>
收件人：[email-masked] <[email-masked]>
抄送人：熊泉00091065;胡方伟10075772;詹双平10034653;Michael Gorokhovsky <[email-masked]>Alexander Ferdman <[email-masked]>Ron Sdayoor <[email-masked]>Alexander Vainshtein <[email-masked]>Rotem Cohen <[email-masked]>
日 期 ：2018年08月20日 20:31
主 题 ：PCEP extensions for SR-TP

Each endpoint element needs 2 labels – one for forward path ID and one for incoming path ID

Our question is – if 2 path labels can be added to the LSP SR-ERO list (one with “R” bit) per LSP?

Path label with “R” bit set will not be added to outgoing label stack, but will be configured in the data plane as an incoming label.

PCE path example:

 

Best regards,

Marina

Email: [email-masked] 

            [email-masked]

---

From: Marina Fizgeer <[email-masked]>
Date: Wed, 22 Aug 2018 06:06:33 +0000

Hi, Xiong Quan,
Thank you for reply.
Some comments:

1.       R bit shall be 1 for reverse direction (and not 0)

2.       As I understand, we don’t have egress ERO for reverse direction. My suggestion was to add the second (reverse) path ID to the ingress ERO of LSP.

3.       One remark: path ID is not routing object, may be make sense to add two sub-TLVs to the LSP object (one for forward path ID and one with R bit for reverse path ID). It means that LSP will have two additional attributes – forward path ID and reverse path ID

Best regards,

Marina

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 22, 2018 6:28 AM
To: Marina Fizgeer <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Michael Gorokhovsky <[email-masked]>; Alexander Ferdman <[email-masked]>; Ron Sdayoor <[email-masked]>; Alexander Vainshtein <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: 答复: PCEP extensions for SR-TP

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯
2/F, R&D Building, ZTE Corporation, Huashi Park Road 6th,
Hi-tech Donghu District, Wuhan, P.R.China, 430022
T: +86 27 13871144372
E: [email-masked]<mailto:[email-masked]>
www.zte.com.cn<http://www.zte.com.cn/>

原始邮件
发件人：MarinaFizgeer <[email-masked]<mailto:[email-masked]>>
收件人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
抄送人：熊泉00091065;胡方伟10075772;詹双平10034653;Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>Alexander Ferdman <[email-masked]<mailto:[email-masked]>>Ron Sdayoor <[email-masked]<mailto:[email-masked]>>Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>Rotem Cohen <[email-masked]<mailto:[email-masked]>>
日 期 ：2018年08月20日 20:31
主 题 ：PCEP extensions for SR-TP
Dear authors of draft-xiong-pce-pcep-extension-sr-tp,
My colleagues and I are interested in some clarifications:
According to this draft, Path label can be added as the last label in the LSP SR-ERO list.
Each endpoint element needs 2 labels – one for forward path ID and one for incoming path ID
Our question is – if 2 path labels can be added to the LSP SR-ERO list (one with “R” bit) per LSP?
Path label with “R” bit set will not be added to outgoing label stack, but will be configured in the data plane as an incoming label.
Using this approach one SR-ERO list will contain outgoing Path label as well as incoming Path label
PCE path example:

Best regards,

Marina

Subject: 答复: PCEP extensions for SR-TP
From: "[email-masked]" <[email-masked]>
To: Marina Fizgeer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Michael Gorokhovsky <[email-masked]>, Alexander Ferdman <[email-masked]>, Ron Sdayoor <[email-masked]>, Alexander Vainshtein <[email-masked]>, Rotem Cohen <[email-masked]>
Date: Wed, 22 Aug 2018 03:28:19 +0000

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯
2/F, R&D Building, ZTE Corporation, Huashi Park Road 6th,
www.zte.com.cn<http://www.zte.com.cn/>

Best regards,

Marina

---

From: <[email-masked]>
Date: Wed, 22 Aug 2018 16:10:43 +0800 (CST)

Hi Marina,

Thanks for your comments! I understand your points now. 

I agree with you that two labels need to be added to the ERO sub-object list. That is forwarding path label and reverse path label.

An  And  just one label will be inserted into the SR label stack and another one is stored for the bi-directional binding and mapping process.

The details are as following:

So there is one problem left. How to carry the path label? 

1, add two sub-TLVs to the LSP object (one for forward path ID and  one with R bit for reverse path ID).

2, add the two path labels  to the SR-ERO subobjects.

3,add one path label to the SR-ERO subobjects  and insterted into label stack together with ERO,  add another path to the LSP object sub-TLV for local processing.

Any suggestion is appreciated!

Best Regards,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯 
2/F, R&D Building, ZTE

原始邮件

发件人：MarinaFizgeer <[email-masked]>
收件人：熊泉00091065;
抄送人：[email-masked] <[email-masked]>胡方伟10075772;詹双平10034653;Michael Gorokhovsky <[email-masked]>Alexander Ferdman <[email-masked]>Ron Sdayoor <[email-masked]>Alexander Vainshtein <[email-masked]>Rotem Cohen <[email-masked]>
日 期 ：2018年08月22日 14:06
主 题 ：RE: PCEP extensions for SR-TP

Hi, Xiong Quan,

Thank you for reply.

Some comments:

 

Best regards,

Marina

 

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

 武汉市东湖高新技术开发区华师园路6号中兴通讯 

原始邮件

日 期 ：2018年08月20日  20:31

PCE path example:

 

Best regards,

Marina

---

From: Marina Fizgeer <[email-masked]>
Date: Wed, 22 Aug 2018 08:38:40 +0000

Hi, Xiong Quan,
As far as I understand your question, path label shall be allocated by PCE.
Then, forward path label shall be added to the bottom (last one) of the label stack and the reverse path label shall be configured to the data plane as incoming label for this LSP

Best regards,

Marina

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 22, 2018 11:11 AM
To: Marina Fizgeer <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Michael Gorokhovsky <[email-masked]>; Alexander Ferdman <[email-masked]>; Ron Sdayoor <[email-masked]>; Alexander Vainshtein <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: 答复: RE: PCEP extensions for SR-TP

Hi Marina,

Best Regards,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯

原始邮件
发件人：MarinaFizgeer <[email-masked]<mailto:[email-masked]>>
收件人：熊泉00091065;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>胡方伟10075772;詹双平10034653;Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>Alexander Ferdman <[email-masked]<mailto:[email-masked]>>Ron Sdayoor <[email-masked]<mailto:[email-masked]>>Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>Rotem Cohen <[email-masked]<mailto:[email-masked]>>
日 期 ：2018年08月22日 14:06
主 题 ：RE: PCEP extensions for SR-TP
Hi, Xiong Quan,
Thank you for reply.
Some comments:

Best regards,

Marina

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, August 22, 2018 6:28 AM
To: Marina Fizgeer <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; Alexander Ferdman <[email-masked]<mailto:[email-masked]>>; Ron Sdayoor <[email-masked]<mailto:[email-masked]>>; Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>;  Rotem Cohen <[email-masked]<mailto:[email-masked]>>
Subject: 答复: PCEP extensions for SR-TP

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯

原始邮件

Best regards,

Marina

---

From: "Chengli (IP Technology Research)" <[email-masked]>
Date: Wed, 22 Aug 2018 10:07:51 +0000

Hi Marina,

I fully agree with your 3rd point. Path ID is not a routing object, it is more like an SR path attribute, so It is better to add sub-TLV to the LSP object. This is proposed in   https://tools.ietf.org/html/draft-li-pce-sr-path-segment-01. In this way, the SR-ERO is not affected by path segment. The path segment can be added into the SID list based on the policy.
I appreciate your idea very much.

Also, just like you said, the reverse ID can be carried within an LSP object, we did think about this at the beginning.

However, we found that we need the detailed information of the reverse SR path in some scenarios, such as for directing the reverse path for BFD https://tools.ietf.org/html/draft-ietf-mpls-bfd-directed-09. But it is not suitable to carry the reverse SR path information within a LSP object. Also, it is a little bit weird to carry information another SR path within the LSP object.

But if we use the association group object like using the association group (https://tools.ietf.org/html/draft-ietf-pce-association-bidir-01) to associate two MPLS LSPs into a bidirectional LSP, problem solved. Therefore,  we defined a new association group called “Double-sided Bidirectional SR Path Association Group” for associating two unidirectional SR path into a bidirectional SR path in https://tools.ietf.org/html/draft-li-pce-sr-bidir-path-00. In this way, two unidirectional SR path can be associated as a unidirectional SR path in a general way without affecting SR-ERO list.

Those drafts have been presented in IETF 102, and your comments are very welcome!

BTW,  there was a discussion among the authors of draft path segment about PCEP extensions for Path segment, and there was an agreement to follow the way defined in draft-li-pce-sr-path-segment-01 and draft-li-pce-sr-bidir-path-00.

Last but not least, your comments and contributions are very welcome!

Thanks,
Cheng

From: Pce [mailto:[email-masked]] On Behalf Of Marina Fizgeer
Sent: Wednesday, August 22, 2018 2:07 PM
To: [email-masked]
Cc: Alexander Vainshtein <[email-masked]>; [email-masked]; Alexander Ferdman <[email-masked]>; Ron Sdayoor <[email-masked]>; [email-masked]; [email-masked]; Michael Gorokhovsky <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: [Pce] PCEP extensions for SR-TP

Hi, Xiong Quan,
Thank you for reply.
Some comments:

Best regards,

Marina

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯

原始邮件

Best regards,

Marina

---

From: <[email-masked]>
Date: Tue, 28 Aug 2018 11:06:53 +0800 (CST)

Hi Marina,

   Thank you for the comments and suggestions!

   I have uodated the version of the draft.  https://datatracker.ietf.org/doc/draft-xiong-pce-pcep-extension-sr-tp/

   I still add the path label extension into  the SR-ERO.   The path is similiar with SR node or adjacency and we view the path label 

   as a type of SR segmnet label or SID named SR path SID.

   Please check it and give more comments! Thanks!

Quan

熊泉 xiongquan

软件工程师 Software Engineer

武汉市东湖高新技术开发区华师园路6号中兴通讯 
2/F, R&D Building, ZTE

原始邮件

发件人：MarinaFizgeer <[email-masked]>
收件人：熊泉00091065;
抄送人：[email-masked] <[email-masked]>胡方伟10075772;詹双平10034653;Michael Gorokhovsky <[email-masked]>Alexander Ferdman <[email-masked]>Ron Sdayoor <[email-masked]>Alexander Vainshtein <[email-masked]>Rotem Cohen <[email-masked]>
日 期 ：2018年08月22日 16:38
主 题 ：RE: RE: PCEP extensions for SR-TP

Hi, Xiong Quan,

 

Best regards,

Marina

 

Hi Marina,

Best Regards,

Quan

 

 

熊泉 xiongquan

软件工程师 Software Engineer

 武汉市东湖高新技术开发区华师园路6号中兴通讯 

原始邮件

收件人：熊泉00091065;

日 期 ：2018年08月22日  14:06

Hi, Xiong Quan,

Thank you for reply.

Some comments:

 

Best regards,

Marina

 

Hi Marina,

Quan

熊泉 xiongquan

软件工程师 Software Engineer

 武汉市东湖高新技术开发区华师园路6号中兴通讯 

原始邮件

日 期 ：2018年08月20日  20:31

PCE path example:

 

Best regards,

Marina