Subject: Re: [Pce] Martin Vigoureux's No Objection on draft-ietf-pce-segment-routing-14: (with COMMENT)

From: <[email-masked]>
Date: Fri, 4 Jan 2019 11:28:50 +0100

Hi guys and happy new year! :-)

Would it temper the confusion below if we added the term "limitless" to
the L flag definition (section 5.1.1.)?

My 2 cents,

Julien

On 21/12/2018 18:14, Jonathan Hardwick wrote:
> I believe it is too late to change but I find L=1 meaning "no limit" is *very* confusing. For me L stands for Limit and when L=1 there is a limit, when L=0 there is none.
>
> [Jon] Agree, both that it is confusing and too late to change :-)

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 6 Jan 2019 11:20:36 -0800

Hi Julien,

Happy New Year to you too.
There’s a slight difference between limitless (e.g. unlimited) and limit
has not been been imposed (not configured/unknown/etc).
I think  “limitless” doesn’t convey the exact meaning. In simple terms - if
L=1, don’t use MSD as a constraint in the path computation.

Thanks,
Jeff

On Fri, Jan 4, 2019 at 02:28 <[email-masked]> wrote:

> > I believe it is too late to change but I find L=1 meaning "no limit" is
> *very* confusing. For me L stands for Limit and when L=1 there is a limit,
> when L=0 there is none.
> >
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Julien Meuric <[email-masked]>
Date: Mon, 7 Jan 2019 10:36:33 +0100

Hi Jeff,

You're right. I certainly don't want to change the specification, nor to
add another ambiguity. I was just looking for a mnemonic to mitigate the
confusion pointed out by Martin, to be considered between bracket
(leaving the definition as is).
Would "limit-blind" make sense?

Cheers,

Julien

On 06/01/2019 20:20, Jeff Tantsura wrote:
> There’s a slight difference between limitless (e.g. unlimited) and
> limit has not been been imposed (not configured/unknown/etc).
> I think  “limitless” doesn’t convey the exact meaning. In simple terms
> - if L=1, don’t use MSD as a constraint in the path computation.
>
> Thanks,
> Jeff
>
> On Fri, Jan 4, 2019 at 02:28 <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     > I believe it is too late to change but I find L=1 meaning "no
>     limit" is *very* confusing. For me L stands for Limit and when L=1
>     there is a limit, when L=0 there is none.
>     >

---

From: Jonathan Hardwick <[email-masked]>
Date: Thu, 10 Jan 2019 10:58:36 +0000

Hi Julien

At the moment, the L bit is simply called "the L bit" (not "limit" or "limitless") and is defined like this:

      *  L: A PCC sets this bit to 1 to indicate that it does not impose
         any limit on the MSD.

Although it might be the opposite of what you'd expect, I think the definition is nevertheless clear as it is written.

Cheers
Jon 

-----Original Message-----
From: Julien Meuric <[email-masked]> 
Sent: Monday, 7 January, 2019 9:37 AM
To: Jeff Tantsura <[email-masked]>
Cc: Dhruv Dhody <[email-masked]>; Jonathan Hardwick <[email-masked]>; Martin Vigoureux <[email-masked]>; The IESG <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Martin Vigoureux's No Objection on draft-ietf-pce-segment-routing-14: (with COMMENT)

Hi Jeff,

You're right. I certainly don't want to change the specification, nor to add another ambiguity. I was just looking for a mnemonic to mitigate the confusion pointed out by Martin, to be considered between bracket (leaving the definition as is).
Would "limit-blind" make sense?

Cheers,

Julien

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 10 Jan 2019 07:39:21 -0800

+1 Jon

Cheers,
Jeff

---

From: "Vigoureux, Martin (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 10 Jan 2019 15:58:15 +0000

Jon's original answer satisfied me so I'm not expecting a change.

Le 2019-01-10 à 16:39, Jeff Tantsura a écrit :
> +1 Jon
> 
> Cheers,
> Jeff
> On Jan 10, 2019, 2:58 AM -0800, Jonathan Hardwick 
> <[email-masked]>, wrote:
>> Hi Julien
>>
>> Although it might be the opposite of what you'd expect, I think the 
>> definition is nevertheless clear as it is written.
>>
>> Cheers
>> Jon
>>
>> Cc: Dhruv Dhody <[email-masked]>; Jonathan Hardwick 
>> <[email-masked]>; Martin Vigoureux 
>> <[email-masked]>; The IESG <[email-masked]>; 
>> [email-masked]; [email-masked]
>> Subject: Re: Martin Vigoureux's No Objection on 
>> draft-ietf-pce-segment-routing-14: (with COMMENT)
>>
>> Hi Jeff,
>>
>> You're right. I certainly don't want to change the specification, nor 
>> to add another ambiguity. I was just looking for a mnemonic to 
>> mitigate the confusion pointed out by Martin, to be considered between 
>> bracket (leaving the definition as is).