Subject: [Pce] algorithm for CSPF in WDM networks

From: "Vijayanand C - ERS, HCL Tech" <[email-masked]>
Date: Tue, 16 Apr 2019 06:22:53 +0000

hello all,
I have a question.

I would like to know what algorithm is recommended for path computation across WDM network by a PCE. Will it be a modified version of dijkstra - with one run to check for optical constraints at every hop included into the SPF tree and find shortest path by metric , or the K-th shortest path algorithm to continuously explore many paths and check optical constraints( such as wavelength continuity, ROADM directionality constraint etc) on each of the paths one by one

Please give your suggestions/experience.

Regards
Vijay

::DISCLAIMER::
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. E-mail transmission is not guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or may contain viruses in transmission. The e mail and its contents (with or without referred errors) shall therefore not attach any liability on the originator or HCL or its affiliates. Views or opinions, if any, presented in this email are solely those of the author and may not necessarily reflect the views or opinions of HCL or its affiliates. Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of this message without the prior written consent of authorized representative of HCL is strictly prohibited. If you have received this email in error please delete it and notify the sender immediately. Before opening any email and/or attachments, please check them for viruses and other defects.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 17 Apr 2019 21:57:03 +0100

Hi Vijay,

The thing about central computation is that you can use any algorithm you like. You could use a CSPF modification of Dijkstra. You could use AI. You could do modified random walk.

Unlike a distributed computation that needs to be consistent across the network to avoid looping, a central algorithm only has to be internally consistent.

Of course, least cost (or shortest path) is only one of the considerations in a WDM network. There are wavelength continuity concerns, optical impairments, future blocking considerations, power consumption thoughts, interference with other established light paths (which is kind of another take on optical impairments), and so on and so on. Many PhD hours have been expended 😊

Cheers,

Adrian

PS There are books on this topic. Ask Igor Bryskin if he knows a good one.

From: Pce <[email-masked]> On Behalf Of Vijayanand C - ERS, HCL Tech
Sent: 16 April 2019 07:23
To: [email-masked]
Subject: [Pce] algorithm for CSPF in WDM networks

hello all, 

I have a question.

Regards
Vijay

::DISCLAIMER::