Subject: [Pce] Shepherd review of draft-ietf-pce-stateful-pce-lsp-scheduling

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 4 Jan 2020 22:30:30 -0000

Hi authors,

Just doing the shepherd write-up after working group last call and I have a
nit in section 10.3

You ask for a new registry of bits, but you don't tell IANA the size of the
registry.

I think, to be consistent with (e.g.)
https://www.iana.org/assignments/pcep/pcep.xhtml#stateful-pce-capability-tlv
-flag-field you should have:

OLD
   The following values are defined in this document:

   Bit    Description                                    Reference
   0      R-bit                                          This document
   1      C-bit                                          This document
   2      A-bit                                          This document
NEW
   IANA is requested to populate this registry as follows:

   Bit    Description                                    Reference
   0      R-bit                                          This document
   1      C-bit                                          This document
   2      A-bit                                          This document
   3-7  Unassigned
END

However, please also consider that other TLV bit registries have started
assigning bits from the largest number (sometimes 31, sometimes 15) counting
downwards. This is not important, just "interesting".

Afraid we need a new revision before we can advance the document. While
you're at it, can you fix the references noted by idnits.

Thanks,
Adrian

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 6 Jan 2020 03:37:21 +0000

Hi Adrian,

    Thank you very much for your comments and suggestions.
    The document has been updated accordingly.

Best Regards,
Huaimo
________________________________
From: Adrian Farrel <[email-masked]>
Sent: Saturday, January 4, 2020 5:30 PM
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Shepherd review of draft-ietf-pce-stateful-pce-lsp-scheduling

Hi authors,

I think, to be consistent with (e.g.)
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fpcep%2Fpcep.xhtml%23stateful-pce-capability-tlv&amp;data=02%7C01%7Chuaimo.chen%40futurewei.com%7C233c0ebb38fb4f382d8108d79165bac7%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637137738448839025&amp;sdata=06D3YsdOtXIuB2dEhU3Yvn0y8h3bz1TvQITOxArDvig%3D&amp;reserved=0
-flag-field you should have:

OLD

HC: Updated the document to contain the unassigned bits.

HC: Revised the document to start assigning bits from the largest one.

Thanks,
Adrian