Subject: [Pce] draft-chen-pce-sr-policy-ifit-00

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 26 Mar 2020 12:07:39 +0000

Dear All,
We published draft-chen-pce-sr-policy-ifit-00 (https://datatracker.ietf.org/doc/draft-chen-pce-sr-policy-ifit/).
This document aims to define the Extensions to PCEP to distribute SR policies carrying In-situ Flow Information Telemetry information.  The scope is to enable automatically data plane on-path telemetry methods, like IOAM and Alternate Marking, when the SR policy is applied.

We would introduce it during the next virtual meeting, that has been moved to May or June, and meanwhile, we would really appreciate inputs and reviews of the document.

Best Regards,

Giuseppe

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 26 Mar 2020 18:04:28 +0530

Hi Giuseppe,

Thank you for introducing your draft on the mailing list.

A quick high level questions - Could we make this generic: to be
applied for any Path Setup Type (PST) in PCEP - RSVP-TE, SR, PCECC
etc? I agree that SR might be of immediate importance; but from PCEP
point of view, it could be useful to keep this generic so that we
don't have to reinvent it for other PST.

It might be good idea to tackle the need for this extension in PCEP -
which to me is to make sure that the PCC includes IOAM header in the
data packet with fields as specified by the PCE. Correct?

Also suggest to add capability exchange during open messages before a
peer uses this extension.

Thanks!
Dhruv (as a WG contributor)

On Thu, Mar 26, 2020 at 5:38 PM Giuseppe Fioccola
<[email-masked]> wrote:
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 26 Mar 2020 14:00:33 +0000

Hi Dhruv,
Thanks for your quick feedback.

The current version of the draft adds attribute TLVs to the SR Policy Association Group, but the same TLVs can also be generic in PCEP.
We can surely evaluate to generalize it.

Your assumption is correct, anyway this extension in PCEP would allow PCC to include in general all the available data plane on-path telemetry methods (IOAM, Alternate Marking and so on).

A capability exchange before the use of this extension is a good suggestion in particular for IOAM, but no need for Alternate Marking.

Regards,

Giuseppe

-----Original Message-----
From: Dhruv Dhody [mailto:[email-masked]] 
Sent: Thursday, March 26, 2020 1:34 PM
To: Giuseppe Fioccola <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [Pce] draft-chen-pce-sr-policy-ifit-00

Hi Giuseppe,

A quick high level questions - Could we make this generic: to be applied for any Path Setup Type (PST) in PCEP - RSVP-TE, SR, PCECC etc? I agree that SR might be of immediate importance; but from PCEP point of view, it could be useful to keep this generic so that we don't have to reinvent it for other PST.

It might be good idea to tackle the need for this extension in PCEP - which to me is to make sure that the PCC includes IOAM header in the data packet with fields as specified by the PCE. Correct?

Also suggest to add capability exchange during open messages before a peer uses this extension.

Thanks!