Subject: [Pce] A pending item for draft-peng-pce-entropy-label-position

From: Dhruv Dhody <[email-masked]>
Date: Sun, 26 Jul 2020 17:25:09 +0530

Hi Authors, Stephane,

In the last meeting [1], Stephane mentioned that the PCE is unaware of
the PCC's capability to push ELI/EL pairs and thus questioned the
usability of your I-D. He mentioned that existing information in
IGP/BGP-LS i.e. MSD, ELC, ERLD does not tell the PCC's capability to
push ELI/EL pairs.

The current draft has a single bit ELP -

    A PCC sets this flag to 1 to
    indicate that it supports the capability of inserting multiple ELI/EL
    pairs and and supports the results of SR path with ELP from PCE.

I want to confirm if this bit and BMI-MSD enough? If not, what else?
It would be good if this can be discussed here or during the meeting.

Thanks!
Dhruv

[1] https://datatracker.ietf.org/doc/minutes-106-pce/

---

From: <[email-masked]>
Date: Mon, 27 Jul 2020 14:22:13 +0800 (CST)

Hi Dhruv and Stephane,

Thanks for your review and comments! 

I appreciated the comments from you last meeting and updated the draft this meeting.

Multiple <ELI, EL> pairs MAY be inserted in the SR-MPLS label stack as defined in RFC8662 secssion 7.1.

So from implementation view, the ingress MUST support the capability of  inserting multiple ELI/ELs.

And in case of inter-domain scenario, PCE would be useful for computing both SR path and the placement of entropy labels.

So I agree with you.  We need to extend the capability at ingress node in control plane.  But I think the capability is no need to be advertised  by IGP protocol.

PCE might not be aware of the capability of ingress to push ELI/EL pairs. We should add the capability in OPEN message from PCC to PCE.  

There are two options for us.

A, add a new bit to indicate the capability of ingress to push ELI/EL pairs.

B, reuse the E (ELP)  bit to indicate the capability of inserting multiple ELI/EL pairs at PCC and support the SR path with ELP from PCE when PCC send OPEN message to PCE.

I updated the draft as the option 2.  Could you please tell me what is your suggestion?

And any comments are welcome!

Thanks,

Quan

原始邮件

发件人：DhruvDhody <[email-masked]>
收件人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2020年07月26日 19:56
主 题 ：A pending item for draft-peng-pce-entropy-label-position

Hi Authors, Stephane,

Thanks!
Dhruv