Subject: [Pce] Éric Vyncke's No Objection on draft-ietf-pce-stateful-pce-lsp-scheduling-18: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Mon, 06 Jul 2020 08:02:14 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-pce-stateful-pce-lsp-scheduling-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-pce-stateful-pce-lsp-scheduling/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document.

Please find below one non-blocking COMMENTs.

I hope that this helps to improve the document,

Regards,

-éric

== COMMENTS ==

-- Section 4.2.2.1 --
May be am I failing to understand this part of the sentence "|X| is the minimum
value from 0 to max(P, Q)" as it is not the same as "where -P <= X <= Q" or
does the "|X|" not represent the absolute value of X ?

== NITS ==

-- Section 4.2.2.1 --
Please use "are" rather than "is" in "Note that both Ta and Tb is shifted by
the same 'X'"

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 6 Jul 2020 19:05:30 +0000

Hi Eric,

    Thank you very much for your valuable comments, which improve the quality of the document.
    My explanations/answers are inline below with prefix [HC].

Best Regards,
Huaimo
________________________________
From: Éric Vyncke via Datatracker <[email-masked]>
Sent: Monday, July 6, 2020 11:02 AM
To: The IESG <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Adrian Farrel <[email-masked]>; [email-masked] <[email-masked]>
Subject: Éric Vyncke's No Objection on draft-ietf-pce-stateful-pce-lsp-scheduling-18: (with COMMENT)

Please refer to https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&amp;data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce52618a253284bdcf29608d821bd921a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296445383410363&amp;sdata=avjm%2BwJ4A%2FKpyAnTbGY0hN6nut2w5uDwjOxu%2BV2j%2B%2FI%3D&amp;reserved=0
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-pce-stateful-pce-lsp-scheduling%2F&amp;data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce52618a253284bdcf29608d821bd921a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296445383420360&amp;sdata=q4C8iND0oAGJgcy6HfpVt1zvlC6ck%2BKrfQxVBpN8jG0%3D&amp;reserved=0

Regards,

-éric

== COMMENTS ==

-- Section 4.2.2.1 --

[HC]: "|X|" represents the absolute value of X.
There are two sentences:
1) "[Ta, Tb] within -P and Q" means a time period from (Ta+X) to (Tb+X),
   where -P <= X <= Q.
2) When an LSP is configured with elastic time interval "[Ta, Tb] within
   -P and Q", a path is computed such that the path satisfies the
   constraints for the LSP in the time period from (Ta+X) to (Tb+X)
   and |X| is the minimum value from 0 to max(P, Q).
In the first sentence, an acceptable range of X is given by -P <= X <= Q.
In the second sentence, a value of X is found within the acceptable range
to satisfies the constraints.
If we change X to Xv in the second sentence, it may be clear.
2)' When an LSP is configured with elastic time interval "[Ta, Tb] within
   -P and Q", a path is computed such that the path satisfies the
   constraints for the LSP in the time period from (Ta+Xv) to (Tb+Xv)
   and |Xv| is the minimum value for Vx from -P to Q.
We have rephrased the related text in the updated document.

== NITS ==

-- Section 4.2.2.1 --

[HC]: We have changed "is" to "are".

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 7 Jul 2020 06:07:06 +0000

Thank you Huaimo for your reply.

Please note that you used ‘Vx’ rather than ‘Xv’ in your proposed text.

Regards

-éric

From: Huaimo Chen <[email-masked]>
Date: Monday, 6 July 2020 at 21:05
To: The IESG <[email-masked]>, Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Adrian Farrel <[email-masked]>, Adrian Farrel <[email-masked]>
Subject: Re: Éric Vyncke's No Objection on draft-ietf-pce-stateful-pce-lsp-scheduling-18: (with COMMENT)

Hi Eric,

Best Regards,
Huaimo

Regards,

-éric

== COMMENTS ==

-- Section 4.2.2.1 --

== NITS ==

-- Section 4.2.2.1 --

---

From: Huaimo Chen <[email-masked]>
Date: Tue, 7 Jul 2020 16:40:37 +0000

Hi Eric,

    Thank you very much.
    We will correct it (change Vx to Xv) accordingly.

Best Regards,
Huaimo
________________________________
From: Eric Vyncke (evyncke) <[email-masked]>
Sent: Tuesday, July 7, 2020 2:07 AM
To: Huaimo Chen <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Adrian Farrel <[email-masked]>
Subject: Re: Éric Vyncke's No Objection on draft-ietf-pce-stateful-pce-lsp-scheduling-18: (with COMMENT)

Regards

-éric

Hi Eric,

Best Regards,

Huaimo

Please refer to https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&amp;data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce52618a253284bdcf29608d821bd921a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296445383410363&amp;sdata=avjm%2BwJ4A%2FKpyAnTbGY0hN6nut2w5uDwjOxu%2BV2j%2B%2FI%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4bc8a891d5814eacc1ef08d8223bfd03%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296988340758292&sdata=0%2Bn9btoebhL3b0FjG3qrzGMlgZq%2BF3aFimIakLgsmrw%3D&reserved=0>
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-pce-stateful-pce-lsp-scheduling%2F&amp;data=02%7C01%7Chuaimo.chen%40futurewei.com%7Ce52618a253284bdcf29608d821bd921a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296445383420360&amp;sdata=q4C8iND0oAGJgcy6HfpVt1zvlC6ck%2BKrfQxVBpN8jG0%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-pce-stateful-pce-lsp-scheduling%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C4bc8a891d5814eacc1ef08d8223bfd03%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637296988340758292&sdata=dcO8Zmmu9UU3H6sUoCCNapCQRaMycMsgTPbF%2BO6QaYk%3D&reserved=0>

Regards,

-éric

== COMMENTS ==

-- Section 4.2.2.1 --

There are two sentences:

   where -P <= X <= Q.

== NITS ==

-- Section 4.2.2.1 --