Subject: [Pce] Comments and questions for draft-chen-pce-pcep-ifit-00

From: "qinfengwei" <[email-masked]>
Date: Fri, 11 Sep 2020 09:22:12 +0800

Hi authors,

Thanks a lot for your continue work on this draft. This draft is very useful
and helpful to enable IFIT method automatically along with the initiation of
LSP, especially for SR and IPv6. 

As you have mentioned in your draft, I also have proposed another companion
document draft-qin-idr-sr-policy-ifit-03
https://datatracker.ietf.org/doc/draft-qin-idr-sr-policy-ifit/ , which
extend BGP to distribute SR policies with IFIT information for automatically
activating and running IFIT methods. Please let me know your questions and
comments for this draft.

After reading your draft, I have following questions and comments. Please
feel free to let me know your thought.

First, in section 3, regarding Flag field, do you see necessary to encode
different flags respectively for Alternate Marking method and IOAM method?

Second, in section 5, this document only presents the example of operation
in case of the PCE initiated SR Policy. Does the draft cover the case of PCC
Initiated SR Policy?

Third, We need to acknowledge that IFIT attributes can be exploited as any
other LSP attributes. Thus, due care should be taken. In section 7, I
suggest to expand details for security considerations. 

Finally, in section 2, there's an editorial error in the following sentence.

OLD: "IFIT TLVs are o ptional and can be taken into account by the PCE
during path computation."

NEW: "IFIT TLVs are optional and can be taken into account by the PCE during
path computation."

----------------------------------------------------------------

Thanks & BR！

Fengwei Qin

China Mobile Research Institute

No.32 Xuanwumen west street, Xicheng District, Beijing 100053, China 

MOBILE: 13810256551

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 14 Sep 2020 18:07:58 +0800

Hi Fengwei,

Thank you very much for comments.
Please see as follows.

First, in section 3, regarding Flag field, do you see necessary to encode different flags respectively for Alternate Marking method and IOAM method?
Agree, Alternate Marking can also work without IOAM (and viceversa) so, in general, it could be better to define them separately. In the next version, we propose to have 5 flags for four kinds of IOAM options and Alternate marking respectively.
 
Second, in section 5, this document only presents the example of operation in case of the PCE initiated SR Policy. Does the draft cover the case of PCC Initiated SR Policy?
Yes, it works in both direction. We will add this example in the next revision.
 
Third, We need to acknowledge that IFIT attributes can be exploited as any other LSP attributes. Thus, due care should be taken. In section 7, I suggest to expand details for security considerations.
We will add more details about the security considerations for IFIT-CAPABILITY TLV and IFIT Attributes TLVs in the next version.
 
Finally, in section 2, there's an editorial error in the following sentence.
OLD: "IFIT TLVs are o ptional and can be taken into account by the PCE during path computation."
NEW: "IFIT TLVs are optional and can be taken into account by the PCE during path computation."
We will fix this.

HUANAN CHEN（陈华南）
Data Communication Research Department
Research Institute of China Telecom Co.,Ltd.
 
发件人： qinfengwei
发送时间： 2020-09-11 09:22
收件人： [email-masked]
抄送： [email-masked]
主题： Comments and questions for draft-chen-pce-pcep-ifit-00
Hi authors,
 
Thanks a lot for your continue work on this draft. This draft is very useful and helpful to enable IFIT method automatically along with the initiation of LSP, especially for SR and IPv6. 
 
As you have mentioned in your draft, I also have proposed another companion document draft-qin-idr-sr-policy-ifit-03 https://datatracker.ietf.org/doc/draft-qin-idr-sr-policy-ifit/ , which extend BGP to distribute SR policies with IFIT information for automatically activating and running IFIT methods. Please let me know your questions and comments for this draft.
 
After reading your draft, I have following questions and comments. Please feel free to let me know your thought.
 
First, in section 3, regarding Flag field, do you see necessary to encode different flags respectively for Alternate Marking method and IOAM method?
 
Second, in section 5, this document only presents the example of operation in case of the PCE initiated SR Policy. Does the draft cover the case of PCC Initiated SR Policy?
 
Third, We need to acknowledge that IFIT attributes can be exploited as any other LSP attributes. Thus, due care should be taken. In section 7, I suggest to expand details for security considerations. 
 
Finally, in section 2, there's an editorial error in the following sentence. 
OLD: "IFIT TLVs are o ptional and can be taken into account by the PCE during path computation."
NEW: "IFIT TLVs are optional and can be taken into account by the PCE during path computation."

 
Fengwei Qin