Subject: [Pce] Shepherd's Review of draft-ietf-pce-binding-label-sid

From: <[email-masked]>
Date: Fri, 28 May 2021 19:47:16 +0200

Dear authors,

Please find below the review of the aforementioned document.

_Summary_
The document looks ready for publication, but the fixes below should be
considered.

_Issues_
None.

_Nits_
------
Abstract
---
- The phrase "network opacity" feels like a negative objective. How
about "network confidentiality"?
- s/RSVP-TE signaled Traffic/RSVP-TE-signaled Traffic/
- s/Label Switching Path/Label Switched Path/

------
1. Introduction
---
- s/either set up using the RSVP-TE signaling protocol or Segment
Routing/set up using either the RSVP-TE signaling protocol or Segment
Routing/
- s/headend node/head-end node/  [x2, for consistency along the I-D]
- s/an Segment Routing Policy/a Segment Routing Policy/
- s/an Segment Routed (SR) Policy/a Segment Routing (SR) Policy/
- s/enables instantiation/enables the instantiation/
- s/type of interfaces or tunnel/type of interface or tunnel/
- s/SID-list/SID list/
- s/Path Computation Element Protocol/PCE communication Protocol/
- s/a network controller (acting as a PCE) /a PCE (acting as a network
controller)/
- s/SID allocated by it/SID it allocated/
OLD
   A PCC could report the binding label/SID allocated by it to the
   stateful PCE via Path Computation State Report (PCRpt) message.
NEW
   A PCC could report to the stateful PCE the binding label/SID it
   allocated via a Path Computation LSP State Report (PCRpt) message.

- s/Path Computation Update Request (PCUpd) message/Path Computation LSP
Update Request (PCUpd) message/
- s/an MPLS label or SID/an MPLS label or a SID/
- s/PCE based/PCE-based/

------
3. Terminology
---
- "TLV" is flagged as "well know" in the RFC Editor's list
(https://www.rfc-editor.org/materials/abbrev.expansion.txt): it can
safely be removed from this section (otherwise, it should have been
expanded at 1st occurrence in the introduction).
- "PCE" is similarly flagged, but PCC and PCEP aren't, so it can be kept
(adding a period at the end of the line).
- s/Path Computation Element Protocol/Path Computation Element
communication Protocol/

------
4. Path Binding TLV
---
- s/TLV is called/TLV called/
- Since it's already allocated, Figure 2 may include the codepoint, i.e.
"Type = 55".
- s/TLV comprise of:/TLV comprises:/
- s/and first 20 bits/and the first 20 bits/
- s/a 16 octet IPv6 address/a 16-octet IPv6 address/
- s/Note that, multiple/Note that multiple/
- s/Following flag/The following flag/
- s/For the BT as 0/When the BT is 0/  [idem w/ 1 and 2]
- s/the 32-bits represent/the 32 bits represent/
- s/the 128-bits represent/the 128 bits represent/
- s/This section specify/This section specifies/
- s/The Binding Value consist of/The Binding Value consists of/
- s/The 128-bits IPv6 address/The 128-bit IPv6 address/

------
5. Operation
---
- s/via PCRpt message/via a PCRpt message/
- s/send PCErr with/send a PCErr with/
- s/existing instances/the existing instances/
- s/the old binding value/the former binding value/
- s/the old TE-PATH-BINDING TLV/the former TE-PATH-BINDING TLV/
- s/Note that, other instances/Note that other instances/
- s/a specific binding value(s)/a (or several) specific binding value(s)
- s/Note that in case of an error,/Note that, in case of an error,/
- s/can carry/can include/
- s/request withdrawal/request the withdrawal/  [x2]
- s/the old binding value/the former binding value/
- s/the old TE-PATH-BINDING TLV/the former TE-PATH-BINDING TLV/
- s/making the length field of the TLV as 4/bringing the Length field of
the TLV to 4/
- s/request PCC/request a PCC/

------
8. PCE Allocation of Binding label/SID
---
- s/on its own accord/of its own accord/  [x2]
- s/A PCC would set this bit/A PCC MUST set this bit/
- s/A PCE would set this bit/A PCE MUST set this bit/
- s/towards PCC/towards the PCC/
- s/a PCE would set this bit to 0/a PCE MUST set this bit to 0/
- s/a PCE could set/a PCE MUST set/

- OLD
A PCC could request that the PCE allocate the binding label/SID by
setting P=1, D=1, and including...
  NEW
To request that the PCE allocate the binding label/SID, a PCC MUST set
P=1, D=1, and include...

- s/The PCE would allocate/The PCE SHOULD allocate/
- The paragraph about by-PCE allocation should say what happens
otherwise, i.e. error behavior.
- s/out of scope of/out of the scope of/

------
9. Implementation Status
---
- Huawei: "An experimental code-point is used and plan to request early
code-point allocation from IANA after WG adoption." If the
implementation doesn't use the early allocated code point, I wonder if
it was worth the effort.
- Cisco: "An experimental code-point is currently used." Currently in
April 2021? Same comment as above.

------
11. Manageability Considerations
---
- s/the policy based on which PCC needs to allocates /the policy the PCC
needs to apply when allocating/
- s/Mechanisms defined/ The mechanisms defined/  [x4]
- s/to PCEP extensions defined/to the PCEP extensions defined/

------
12. IANA Considerations
---
- The new Error-Type entry should include Error-value 0 as Unassigned.

------
14. References
---
- When reading section 7, draft-ietf-pce-segment-routing-ipv6 really
felt like a normative reference: it should be moved to section 14.1.

------

Cheers,

Julien

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Sat, 29 May 2021 01:18:13 +0000

Hi Julien，

Many thanks for your comments! Will address the comments and then post the new revision for discussion ASAP.

Respect,
Cheng

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, May 29, 2021 1:47 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Pce] Shepherd's Review of draft-ietf-pce-binding-label-sid

Dear authors,

_Summary_
The document looks ready for publication, but the fixes below should be considered.

_Issues_
None.

_Nits_
------
Abstract
---
- The phrase "network opacity" feels like a negative objective. How about "network confidentiality"?
- s/RSVP-TE signaled Traffic/RSVP-TE-signaled Traffic/
- s/Label Switching Path/Label Switched Path/

------
1. Introduction
---
- s/either set up using the RSVP-TE signaling protocol or Segment Routing/set up using either the RSVP-TE signaling protocol or Segment Routing/
- s/headend node/head-end node/  [x2, for consistency along the I-D]
- s/an Segment Routing Policy/a Segment Routing Policy/
- s/an Segment Routed (SR) Policy/a Segment Routing (SR) Policy/
- s/enables instantiation/enables the instantiation/
- s/type of interfaces or tunnel/type of interface or tunnel/
- s/SID-list/SID list/
- s/Path Computation Element Protocol/PCE communication Protocol/
- s/a network controller (acting as a PCE) /a PCE (acting as a network controller)/
- s/SID allocated by it/SID it allocated/ OLD
   A PCC could report the binding label/SID allocated by it to the
   stateful PCE via Path Computation State Report (PCRpt) message.
NEW
   A PCC could report to the stateful PCE the binding label/SID it
   allocated via a Path Computation LSP State Report (PCRpt) message.

- s/Path Computation Update Request (PCUpd) message/Path Computation LSP Update Request (PCUpd) message/
- s/an MPLS label or SID/an MPLS label or a SID/
- s/PCE based/PCE-based/

------
3. Terminology
---
- "TLV" is flagged as "well know" in the RFC Editor's list
(https://www.rfc-editor.org/materials/abbrev.expansion.txt): it can safely be removed from this section (otherwise, it should have been expanded at 1st occurrence in the introduction).
- "PCE" is similarly flagged, but PCC and PCEP aren't, so it can be kept (adding a period at the end of the line).
- s/Path Computation Element Protocol/Path Computation Element communication Protocol/

------
4. Path Binding TLV
---

------
5. Operation
---
- s/making the length field of the TLV as 4/bringing the Length field of the TLV to 4/

------

- OLD
A PCC could request that the PCE allocate the binding label/SID by setting P=1, D=1, and including...
  NEW
To request that the PCE allocate the binding label/SID, a PCC MUST set P=1, D=1, and include...

- s/The PCE would allocate/The PCE SHOULD allocate/
- The paragraph about by-PCE allocation should say what happens otherwise, i.e. error behavior.
- s/out of scope of/out of the scope of/

------
9. Implementation Status
---
- Huawei: "An experimental code-point is used and plan to request early code-point allocation from IANA after WG adoption." If the implementation doesn't use the early allocated code point, I wonder if it was worth the effort.
- Cisco: "An experimental code-point is currently used." Currently in April 2021? Same comment as above.

------
11. Manageability Considerations
---
- s/the policy based on which PCC needs to allocates /the policy the PCC needs to apply when allocating/
- s/Mechanisms defined/ The mechanisms defined/  [x4]
- s/to PCEP extensions defined/to the PCEP extensions defined/

------
12. IANA Considerations
---

------
14. References
---
- When reading section 7, draft-ietf-pce-segment-routing-ipv6 really felt like a normative reference: it should be moved to section 14.1.

------

Cheers,

Julien