Subject: [Pce] draft-chen-pce-sr-ingress-protection

From: Huaimo Chen <[email-masked]>
Date: Mon, 15 Nov 2021 16:16:34 +0000

Hi Dhruv,

    I have updated the draft to address your comment in IETF112 meeting.

Best Regards,
Huaimo
________________________________
A new version of I-D, draft-chen-pce-sr-ingress-protection-07.txt
has been successfully submitted by Huaimo Chen and posted to the
IETF repository.

Name:           draft-chen-pce-sr-ingress-protection
Revision:       07
Title:          Path Ingress Protections
Document date:  2021-11-13
Group:          Individual Submission
Pages:          22
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-chen-pce-sr-ingress-protection-07.txt&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=QcMEuLlNgf5Vm6t2EQOs9VYh8sVRfKTW889uoZNNurc%3D&amp;reserved=0
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-pce-sr-ingress-protection%2F&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=yUT6B1%2BkQ3DQxj85mP9xyE%2F3jV4kD7%2FvPS%2Fc5Ml0pEs%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-chen-pce-sr-ingress-protection&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=715W0xjH6s1TAK9aYbLAiSIXQ0Lx6Tk0%2FuP8sh83ZL4%3D&amp;reserved=0
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-chen-pce-sr-ingress-protection-07&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=l7YEwXlj3bdPPfXKmi%2F1lJR4%2FUB8MYObU7KGAXIlHP0%3D&amp;reserved=0

Abstract:
   This document describes extensions to Path Computation Element (PCE)
   communication Protocol (PCEP) for fast protecting the ingress nodes
   of two types of paths or tunnels, which are Segment Routing (SR)
   paths and Bit Index Explicit Replication Tree/Traffic Engineering
   (BIER-TE) paths.  The extensions comprise a foundation for protecting
   the ingress nodes of different types of paths.  Based on this, the
   ingress protection of a new type of paths can be easily supported.

The IETF Secretariat

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 15 Nov 2021 17:18:48 +0000

Hi Zheng,

    Thanks much for your comments in the PCE WG meeting.
    I have asked people in SPRING and BIER to review this draft.

Best Regards,
Huaimo

Abstract:

The IETF Secretariat

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 15 Nov 2021 20:50:20 +0000

Hi Pavan,

    Thanks much for your comments in IETF 111.
    RFC8424 "Extensions to RSVP-TE for Label Switched Path (LSP) Ingress Fast Reroute (FRR) Protection" has Staus/Category: Experimental because there are two different proposed signaling approaches to transfer the information for ingress protection in the final document.  We do/will not have this case in the PCE draft, which has Intended status: Standards Track.

Best Regards,
Huaimo

Name:           draft-chen-pce-sr-ingress-protection
Revision:       07
Title:          Path Ingress Protections
Document date:  2021-11-13
Group:          Individual Submission
Pages:          22
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-chen-pce-sr-ingress-protection-07.txt&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=QcMEuLlNgf5Vm6t2EQOs9VYh8sVRfKTW889uoZNNurc%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-chen-pce-sr-ingress-protection-07.txt&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C37a4589fd30546238f7808d9a85c0603%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637725935499563777%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=gv528GcK5DDjw1Cr9nT%2BJoIdzB3T5R9wMYIe6wU9VAQ%3D&reserved=0>
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-pce-sr-ingress-protection%2F&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=yUT6B1%2BkQ3DQxj85mP9xyE%2F3jV4kD7%2FvPS%2Fc5Ml0pEs%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-chen-pce-sr-ingress-protection%2F&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C37a4589fd30546238f7808d9a85c0603%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637725935499573725%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=TaFQ3U2PYe3dgyQhyy6kmJzqMm8RuK026QaseZI1QCo%3D&reserved=0>
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-chen-pce-sr-ingress-protection&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=715W0xjH6s1TAK9aYbLAiSIXQ0Lx6Tk0%2FuP8sh83ZL4%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-chen-pce-sr-ingress-protection&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C37a4589fd30546238f7808d9a85c0603%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637725935499912237%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=2y1xIFVrs6odNX5i1gnYb5k8asCbZQVn83DP855d5N8%3D&reserved=0>
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-chen-pce-sr-ingress-protection-07&amp;data=04%7C01%7CHuaimo.chen%40futurewei.com%7C9595017592264777276008d9a7021648%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637724449691420416%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=l7YEwXlj3bdPPfXKmi%2F1lJR4%2FUB8MYObU7KGAXIlHP0%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-chen-pce-sr-ingress-protection-07&data=04%7C01%7Chuaimo.chen%40futurewei.com%7C37a4589fd30546238f7808d9a85c0603%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637725935499922195%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=9CBFQwcciFRRejgLKKijurF8A40IhE8oIGzvfePO8ZM%3D&reserved=0>

Abstract:

The IETF Secretariat