Subject: Re: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 21 Mar 2022 16:07:07 +0000

Hi Samuel,

Sorry for the late reply.  It is good to see this document adopted, and please see some further replies inline with [Jie #2]:

From: Samuel Sidor (ssidor) [mailto:[email-masked]]
Sent: Tuesday, February 22, 2022 5:49 PM
To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mahendra Negi <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi Jie,

Thanks for your comments. Please see inline <S>:

Regards,
Samuel

From: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 21, 2022 4:45 PM
To: Samuel Sidor (ssidor) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mahendra Negi <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi Samuel,

Thanks for your reply. Please see further inline:

From: Samuel Sidor (ssidor) [mailto:[email-masked]]
Sent: Friday, February 18, 2022 7:27 PM
To: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mahendra Negi <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi Jie,

Combining responses for 1. and 2. as those are related:

Encoding of SID/ERO-subobject level was used, because of multiple reasons:

a)      We may need to signal SL, which is explicitly configured by user (not just computed by PCE) and in such case user can potentially mix SIDs with different algorithms (if user is accepting risk of loops or if user knows that it cannot happen for various reasons in that specific case).

[Jie] Do you mean using PCEP to signal a configured SID list which consists of SIDs with different algorithms? To avoid the risk of loop, normally user would prefer to configure either SID list with strict path, or SIDs with consistent algorithm. Even if it is known that there is no loop, different algorithms represent different requirements to the path, logically can a path built with different algorithms meet specific requirement?

Thus it would be helpful to describe the typical scenario(s) of configuring SIDs with different algorithms .

<S> In most of the cases, requirements == algo used, but there are cases, where it may not be possible. Some examples.

·        case b) bellow (inter-domain)

·        support for less capable nodes (e.g. some node/nodes without SSPF/Algo1 support, but user want to use SSPF SIDs wherever possible and where user knows that it is still safe to mix SIDs). Implementation (PCE/PCC) can have local policy (e.g. some configuration) to decide if potentially unsafe paths should be used or blocked.

As soon as we have at least possible use case (even if it is corner case), it may be bad idea to block it on protocol level. I agree that it may be good to describe use cases above in the draft.

[Jie #2] OK, I understand there can be cases of falling back from a specific Algorithm to the default algorithm, in such case the PCE may need to be responsible for determining whether the path with Mixed SID is safe or not, as the PCCs may not have enough information for such check.

b)      Different algorithm ID != different algorithm. With flex-algo different ID can be used for identification of same algorithm (e.g. in different IGP domains). Mixing SIDs with different algorithm ID in such case is safe, but we would not be able to signal such path in PCEP.

[Jie] I agree in the inter-domain case, the same algorithm can be represented using different IDs, and SIDs associated with different algorithm IDs can be used to build an inter-domain path to meet certain requirement. I’d suggest to add some description about this case to the document, and it would be better to limit the usage of different algorithm IDs in the ERO to this inter-domain case only.

<S> I’m not sure if we can really have hard requirement for PCC or PCE to check it. E.g. in case of configured SID list on PCC - PCC may not have visibility to whole topology in case of inter-domain paths, so it may not be able to verify it. E.g. consider that user configured SID list like this:

1.      Label 26000 (algo 128)

2.      Label 26005 (algo 129)
PCC can just blindly report such path to PCE even if it does not know if both SIDs are in same area/domain or not. If we will strictly say that it is not valid, then user configured path can result in breaking protocol level limitations. Same applies to PCE, which can be potentially used only as a proxy.

[Jie #2] Agree that the PCC may not have visibility to the whole inter-domain topology, and the PCE may need to take the responsibility when possible.

c)      Also related to explicit SL – in some cases, user may configure SL explicitly on headend. Headend may not be able to resolve complete SL, so it may not be sure if algorithm of all SIDs is same.

[Jie] Understood.

3. We defined new types in older version of this draft – see:
https://datatracker.ietf.org/doc/html/draft-tokar-pce-sid-algo-03#section-6.1
but there were multiple comments indicating that it is resulting in too many new types (we need to extend draft for Adjacency SIDs as well) and it would be hard to maintain it for future – e.g. for cases where new NAI types are added. With this change we would have to double number of NAI types. Any extension like this in the future would double it again.

[Jie] Thanks for the pointer, I understand the cost of introducing new NAI types. While comparing to the format of SID types in BGP SR Policy, there is a fixed algorithm field and a A Flag is used to indicate whether this field carries an algorithm value or not. Perhaps another approach is to update the format of the existing NAI types to include the algorithm field. This could also better align the NAI types in PCEP with the Segment types in BGP.

Thoughts?

<S> In case of approach with fixed algorithm field – what is the benefit of always including algorithm field even if it is not used? Because PCEP implementation will have to support both formats of SR-ERO – with and without algorithm field anyway (backward compatibility with implementations with algo draft support), so if algorithm is not really specified, we will just increase size of encoded ERO with no added value.

[Jie #2] In principle my suggestion was to consider whether it is possible to align the encoding of the segments in BGP and PCEP (if it is not too late).

For approach with updating existing NAI types – yes, I think that it can be done, but:

1.      At least for me, SID Algo logically does not belong into NAI – even based on name NAI is supposed to be used for Node or Adjacency identifiers – I’m not sure how algo is identifying node or adjacency here.

2.      NAI is optional – it will be required to include NAI even if it is not really needed in specific cases

3.      Draft would still have to update them one by one, so it will have similar problem as original version of this draft – limited/expensive extensibility.

[Jie #2] My understanding is that the algorithm field is needed when the SID field is optional, so that the PCC or PCE can use the NAI together with the algorithm to determine the SID to be used for the path. Thus we may consider the algorithm is coupled with the NAI part, not the SID. Please note that in BGP SR Policy, for the segment types which carries the SID only, the algorithm field is not needed.

Just my 2 cents.

Best regards,
Jie

Best regards,
Jie

4. Makes sense. We will align it.

Regards,
Samuel

From: Dongjie (Jimmy) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, February 18, 2022 10:09 AM
To: Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Mahendra Negi <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi WG, chairs,

I just read the latest version of this document. In general incorporating Algorithm into PCEP could be useful. While I have the below questions on this version and it would be helpful if they can be resolved before adoption.

1.      This document introduces the algorithm constraint in the LSPA object, which means the algorithm needs to be considered in the computation of the path. IMO this is important for computing a loop-free path. While the draft also says that the “the PCE MAY insert prefix SIDs with a different Algorithm in order to successfully compute a path.” Mixing SIDs with different algorithms in a path has the risk of loops. It is suggested that the document provides some analysis about such risk, and the example of scenarios where mixing SIDs with different algorithms is safe and desired.

2.      This is related to the first question. If the analysis shows that using SIDs with different algorithms in a path is not a good idea, then it would be unnecessary to carry the algorithm ID in SERO subobjects, instead carrying it as a path attribute would be enough.

3.      Assuming the answer to question 2 is YES, the SR-ERO and SRv6-ERO subobjects were defined with a fixed format (do not support sub-TLVs), this document introduces an additional optional field to those sub-objects, and use a new flag to indicate the existence of the new optional field. To my understanding this is not a usual approach for protocol extension. Usually a new Type needs to be defined for a new format. It would be necessary to understand the implication of using flags to indicate the modification to the format of an existing object.

4.      The term “SID Algorithm” in this document is different from that is used in the RFCs of SR/SRv6 IGP/BGP extensions, where it is called “SR-Algorithm”. Suggest to make them consistent.

Best regards,
Jie

From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, February 18, 2022 12:08 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Mahendra Negi <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi WG,

A reminder to please respond to the WG adoption poll by Monday!

Please be more vocal. The silence makes it difficult to judge consensus.

Also, the IPR responses from Alex, Shuping, and Mahendra are missing still.

Thanks!
Dhruv & Julien

On Fri, Feb 4, 2022 at 10:44 PM Dhruv Dhody <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

This email begins the WG adoption poll for draft-tokar-pce-sid-algo-05.

https://datatracker.ietf.org/doc/draft-tokar-pce-sid-algo/

Should this draft be adopted by the PCE WG? Please state your reasons - Why / Why not? What needs to be fixed before or after adoption? Are you willing to work on this draft? Review comments should be posted to the list.

Please respond by Monday 21st Feb 2022.

Have a great weekend.

Thanks!
Dhruv & Julien

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 21 Mar 2022 12:20:03 -0400

I support WG adoption of this important PCEP  FlexAlgo extension and I am
willing to work on the draft to progress.

Thanks

Gyan

On Fri, Feb 4, 2022 at 12:15 PM Dhruv Dhody <[email-masked]> wrote:

> Should this draft be adopted by the PCE WG? Please state your reasons -
> Why / Why not? What needs to be fixed before or after adoption? Are you
> willing to work on this draft? Review comments should be posted to the list.
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Samuel Sidor (ssidor)" <[email-masked]>
Date: Tue, 22 Mar 2022 10:42:06 +0000

Hi Jie,

Please see inline <S #2>.

Regards,
Samuel

From: Dongjie (Jimmy) <[email-masked]>
Sent: Monday, March 21, 2022 5:07 PM
To: Samuel Sidor (ssidor) <[email-masked]>
Cc: [email-masked]; Dhruv Dhody <[email-masked]>; [email-masked]; Mahendra Negi <[email-masked]>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi Samuel,

Hi Jie,

Regards,
Samuel

Hi Samuel,

Hi Jie,

<S #2> Ack. If PCE is doing path-computation, then it can be responsible for considering if path is safe or not. If it is explicitly configured SL on PCC, then PCC/operator are responsible. Anyway – I assume that we are in sync that algo per SID/hop may be needed.

[Jie] Understood.

Thoughts?

<S #2> Agree that sync between BGP and PCEP would be good, just question is if added value of consistency between protocols is higher than added value of better maintainability/ (having to add duplicate type in the future for any NAI extension) and lower efficiency of encoded path (extra algo field if even if it is not needed per hop). I’m still tracking a few other (bigger) changes, which needs to be done to this draft, so if other co-authors or WG members will prefer consistency, then we can still do that.

<S #2> Good point about case, where SID is not included and algorithm may be needed to find SID. I’ll  discuss with other co-authors if we want to move algorithm field to NAI, but obviously that would result in negative consequences mentioned above (duplicate types,..).

Just my 2 cents.

Best regards,
Jie

Best regards,
Jie

Regards,
Samuel

Hi WG, chairs,

Best regards,
Jie

Hi WG,

Thanks!
Dhruv & Julien

Have a great weekend.

Thanks!
Dhruv & Julien

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 24 Mar 2022 15:38:09 +0000

Hi Samuel,

Thanks for your response, please see some replies inline [Jie #3]

From: Samuel Sidor (ssidor) [mailto:[email-masked]]
Sent: Tuesday, March 22, 2022 6:42 PM
To: Dongjie (Jimmy) <[email-masked]>
Cc: [email-masked]; Dhruv Dhody <[email-masked]>; [email-masked]; Mahendra Negi <[email-masked]>
Subject: RE: [Pce] WG Adoption of draft-tokar-pce-sid-algo-05

Hi Jie,

Regards,
Samuel

Hi Samuel,

Hi Jie,

Regards,
Samuel

Hi Samuel,

Hi Jie,

[Jie #3] Yes. And some descriptions to the draft to reflect the discussion in this thread would be helpful.

[Jie] Understood.

Thoughts?

[Jie #3] Duplicated types may not be needed if some update to the NAIs could be done.  And look forward to the changes you mentioned.

[Jie #3] Looking forward to your feedback, thanks.

Best regards,
Jie

Just my 2 cents.

Best regards,
Jie

Best regards,
Jie

Regards,
Samuel

Hi WG, chairs,

Best regards,
Jie

Hi WG,

Thanks!
Dhruv & Julien

Have a great weekend.

Thanks!
Dhruv & Julien