Subject: [PCN] ProblemStatement Issue NEW: Notion of TRUST

From: "Kwok-Ho Chan" <[email-masked]>
Date: Tue, 10 Oct 2006 19:28:43 -0400

Hi all:
I am working on a new draft to be submitted for the PCN BOF (reason 
for my silence lately :).

For this new draft, I had some private conversations with couple of 
people on the notion of TRUST.
IMHO, I think this is a fundamental issue and needs to be explored 
for the PCN BOF/WG.

So far we have indicated we want to solve the Flow Admission Control 
and Flow "Preemption"
problem for a controlled environment (please see section 4.1 of -00 
ProblemStatement draft).
But we have not state in detail of the different trust relationships.

Hence I would like to indicate here that we may want to think about 
trust relationships
between (please see section 2.1 of -00 ProblemStatement for 
terminology definitions):
1. PCN Interior Node (PIN) and PIN.
2. PCN End Node (PEN) and PIN.
3. User/Application and PEN.
     For this #3, I am further asking:
     (a) in this case is PEN really representing PCN as a whole?
     (b) is this really about trust between Application Layer and 
Packet Forwarding Network Layer?

Are there any other trust relationships we need to consider?
The scope/degree of these trust relationships?
How may some of these trust relationships be established?

I would like to open this up to the list and gain some insights on 
what may be acceptable
assumptions, approaches related to this topic.

Thanks!
-- Kwok --

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Geib, Ruediger" <[email-masked]>
Date: Wed, 11 Oct 2006 08:54:38 +0200

Hi Kwok,

good point, the issue should be part of the problem statement.

The topic is probably one of the most tricky parts of PCN. By 
that I mean that we have a fair chance to over-engineer a 
solution. But on the other hand, we can't afford to ignore 
the topic.

Regards,

Rudiger

|-----Original Message-----
|From: Kwok-Ho Chan [mailto:[email-masked]]
|Sent: Wednesday, October 11, 2006 1:29 AM
|To: [email-masked]
|Subject: [PCN] ProblemStatement Issue NEW: Notion of TRUST
|
|
|Hi all:
|I am working on a new draft to be submitted for the PCN BOF (reason 
|for my silence lately :).
|
|For this new draft, I had some private conversations with couple of 
|people on the notion of TRUST.
|IMHO, I think this is a fundamental issue and needs to be explored 
|for the PCN BOF/WG.
|
|So far we have indicated we want to solve the Flow Admission Control 
|and Flow "Preemption"
|problem for a controlled environment (please see section 4.1 of -00 
|ProblemStatement draft).
|But we have not state in detail of the different trust relationships.
|
|Hence I would like to indicate here that we may want to think about 
|trust relationships
|between (please see section 2.1 of -00 ProblemStatement for 
|terminology definitions):
|1. PCN Interior Node (PIN) and PIN.
|2. PCN End Node (PEN) and PIN.
|3. User/Application and PEN.
|     For this #3, I am further asking:
|     (a) in this case is PEN really representing PCN as a whole?
|     (b) is this really about trust between Application Layer and 
|Packet Forwarding Network Layer?
|
|Are there any other trust relationships we need to consider?
|The scope/degree of these trust relationships?
|How may some of these trust relationships be established?
|
|I would like to open this up to the list and gain some insights on 
|what may be acceptable
|assumptions, approaches related to this topic.
|
|Thanks!
|-- Kwok --
|
|
|_______________________________________________
|PCN mailing list
[email-masked]
|https://www1.ietf.org/mailman/listinfo/pcn
|

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Wed, 11 Oct 2006 11:05:27 -0400

Ruediger:
At this point, IMHO, we need to at least understand how
the notion of trust may affect PCN.
We may not have all the answers or may not include them
in the charter.  But we should open this up and make
conscientious decisions.  I believe this is the right thing
to do for the BOF/WG.

Also, by opening this up, we may learn of solutions out there
that we don't know of.

I would like to include the result of these discussions into
future versions of the Problem Statement draft if appropriate.

Thanks!
-- Kwok --