Subject: RE: [PCN] Protection against flash crowds: slow-admission marking

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 16 Oct 2006 09:14:14 +0200

Hello Michael,

I mentioned earlier that I also prefer PCN to work without signaling 
between backbone routers. 

I'm open to a discussion on mechanisms and code point consumption on 
IP level. One of my main concerns is to allow operation of PCN 
within an MPLS domain. There, the overall codepoint space to 
differentiate traffic or to congestion mark it is 3 bits or 
8 Codepoints. That means no matter what is specified for PCN on 
IP level, a simplified and interoperable implementation should 
be possible on MPLS level.

Regards,

Rüdiger

-----Original Message-----
From: Michael Menth [mailto:[email-masked]]
Sent: Monday, October 16, 2006 9:03 AM
To: [email-masked]
Cc: [email-masked]
Subject: [PCN] Protection against flash crowds: slow-admission marking

Dear Phil,

yes, I proposed "quizzing" the routers along the way for their unused CL 
capacity. When only little capacity is left, the ingress slows down its 
admission rate to, e.g. (1 Mbit/s)/10 s. Note that this does not require 
the routers to keep any states.

But if quizzing still too complex, "slow-admission marking" by 
intermediate PCN nodes could be used:

1) no marking: there is lot's of capacity on all links and new flows can 
be admitted as fast as possible
2) slow-admission marking: only little admissible capacity is left and 
the link runs the risk being overloaded by a flash crowd when a large 
rate of new flows is admitted within a short interval, therefore, 
additional flows should be admitted only slowly.
3) stop-admission marking: the admissible link capacity is consumed and 
no more flows over this link should be admitted
4) excess-traffic marking: the link carries too much traffic and flows 
should be preempted

Example:
a) slow-admission threshold: 10 Mbit/s
b) admissible link capacity: 20 Mbit/s
c) tolerable link capacity 40 Mbit/s
d) physical link bandwidth: 50 Mbit/s

a) If the CL traffic rate on a link exceeds the slow-admission 
threshold, all packets are slow-admission marked; the egress signals the 
information back to the respective ingress routers which slow down their 
admission rate for the specific egress to, e.g., 1 (Mbit/s)/10 s. As a 
consequence, flash crowds cannot swamp a medium loaded system.
b)  If the CL traffic rate on a link exceeds the admissible link 
capacity, all packets are stop-admission marked; the egress signals the 
information back to the respective ingress routers and the they stop 
admitting further calls to the specific egress.
c) If the CL traffic rate on a link exceeds the tolerable link capacity, 
all excess packets are excess-traffic marked; the egress signals the 
information back to the respective ingress routers and the they preempt 
the necessary number of calls to the specific egress.
d) If the CL traffic rate on a link exceeds the physical link capacity, 
packet loss and heavy delay occurs.

As 1), 3), and 4) already exist, two bits are needed for encoding the 
marking anyway, therefore, the implementation of 2) wouldn't need 
another bit. As slow-admission marking is technically the same as 
stop-admission marking, this solution should be compliant with the 
existing philosophy.

Best wishes,

    Michael

> Thanks
> phil

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: Michael Menth <[email-masked]>
Date: Mon, 16 Oct 2006 09:57:37 +0200

Hi Ruediger,

> be possible on MPLS level.
Well, as I also see this problem, I pointed out that so far 3 code 
points have been consumed for
1) no marking,
3) stop-admission marking, and
4) excess-traffic marking.

Slow-admission marking (2) would add only a fourth code point such that 
altogether two bits are required. And the existing solution also 
requires two bits.

Best regards,

    Michael

---

From: Michael Menth <[email-masked]>
Date: Mon, 16 Oct 2006 11:00:16 +0200

Hi Ruediger,

once more again regarding the number of additional code points. I don't 
think that all four markings need to be mandatory. There may be networks 
operating only with stop-admission marking to perform admission control. 
Others wish to have preemption and need, therefore, excess-traffic 
marking. And those expecting flash crowds can implement slow-admission 
marking in addition. Thus, there is a tradeoff between the number of 
used features and the code point consumption.

Best regards,

    Michael

---

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 16 Oct 2006 11:36:24 +0200

Hello Michael,

I share the philosophy expressed by your statement. The resulting 
drafts hopefully separate between "basic" and "optional" 
PCN features.

Regards,

Rüdiger

|-----Original Message-----
|From: Michael Menth [mailto:[email-masked]]
|Sent: Monday, October 16, 2006 11:00 AM
|To: Geib, Rüdiger
|Cc: [email-masked]
|Subject: Re: [PCN] Protection against flash crowds: slow-admission
|marking
|
|
|Hi Ruediger,
|
|once more again regarding the number of additional code 
|points. I don't 
|think that all four markings need to be mandatory. There may 
|be networks 
|operating only with stop-admission marking to perform 
|admission control. 
|Others wish to have preemption and need, therefore, excess-traffic 
|marking. And those expecting flash crowds can implement slow-admission 
|marking in addition. Thus, there is a tradeoff between the number of 
|used features and the code point consumption.
|
|Best regards,
|
|    Michael
|
|Geib, Ruediger wrote:
|> Hello Michael,
|>
|> I mentioned earlier that I also prefer PCN to work without signaling 
|> between backbone routers. 
|>
|> I'm open to a discussion on mechanisms and code point consumption on 
|> IP level. One of my main concerns is to allow operation of PCN 
|> within an MPLS domain. There, the overall codepoint space to 
|> differentiate traffic or to congestion mark it is 3 bits or 
|> 8 Codepoints. That means no matter what is specified for PCN on 
|> IP level, a simplified and interoperable implementation should 
|> be possible on MPLS level.
|>
|> Regards,
|>
|> Rüdiger
|>
|>
|> -----Original Message-----
|> From: Michael Menth [mailto:[email-masked]]
|> Sent: Monday, October 16, 2006 9:03 AM
|> To: [email-masked]
|> Cc: [email-masked]
|> Subject: [PCN] Protection against flash crowds: 
|slow-admission marking
|>
|>
|> Dear Phil,
|>
|> yes, I proposed "quizzing" the routers along the way for 
|their unused CL 
|> capacity. When only little capacity is left, the ingress 
|slows down its 
|> admission rate to, e.g. (1 Mbit/s)/10 s. Note that this does 
|not require 
|> the routers to keep any states.
|>
|> But if quizzing still too complex, "slow-admission marking" by 
|> intermediate PCN nodes could be used:
|>
|> 1) no marking: there is lot's of capacity on all links and 
|new flows can 
|> be admitted as fast as possible
|> 2) slow-admission marking: only little admissible capacity 
|is left and 
|> the link runs the risk being overloaded by a flash crowd 
|when a large 
|> rate of new flows is admitted within a short interval, therefore, 
|> additional flows should be admitted only slowly.
|> 3) stop-admission marking: the admissible link capacity is 
|consumed and 
|> no more flows over this link should be admitted
|> 4) excess-traffic marking: the link carries too much traffic 
|and flows 
|> should be preempted
|>
|> Example:
|> a) slow-admission threshold: 10 Mbit/s
|> b) admissible link capacity: 20 Mbit/s
|> c) tolerable link capacity 40 Mbit/s
|> d) physical link bandwidth: 50 Mbit/s
|>
|> a) If the CL traffic rate on a link exceeds the slow-admission 
|> threshold, all packets are slow-admission marked; the egress 
|signals the 
|> information back to the respective ingress routers which 
|slow down their 
|> admission rate for the specific egress to, e.g., 1 
|(Mbit/s)/10 s. As a 
|> consequence, flash crowds cannot swamp a medium loaded system.
|> b)  If the CL traffic rate on a link exceeds the admissible link 
|> capacity, all packets are stop-admission marked; the egress 
|signals the 
|> information back to the respective ingress routers and the they stop 
|> admitting further calls to the specific egress.
|> c) If the CL traffic rate on a link exceeds the tolerable 
|link capacity, 
|> all excess packets are excess-traffic marked; the egress signals the 
|> information back to the respective ingress routers and the 
|they preempt 
|> the necessary number of calls to the specific egress.
|> d) If the CL traffic rate on a link exceeds the physical 
|link capacity, 
|> packet loss and heavy delay occurs.
|>
|>
|> As 1), 3), and 4) already exist, two bits are needed for 
|encoding the 
|> marking anyway, therefore, the implementation of 2) wouldn't need 
|> another bit. As slow-admission marking is technically the same as 
|> stop-admission marking, this solution should be compliant with the 
|> existing philosophy.
|>
|> Best wishes,
|>
|>     Michael
|>
|>   
|>> Thanks
|>> phil
|>>   
|>>     
|>
|>   
|
|-- 
|Dr. Michael Menth, Assistant Professor
|University of Wuerzburg, Institute of Computer Science
|Am Hubland, D-97074 Wuerzburg, Germany, room B206
|phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
|mailto:[email-masked]
|http://www3.informatik.uni-wuerzburg.de/research/ngn
|
|
|_______________________________________________
|PCN mailing list
[email-masked]
|https://www1.ietf.org/mailman/listinfo/pcn
|