Subject: [PCN] Core Marked Flow Termination anti-cheating?

From: Bob Briscoe <[email-masked]>
Date: Fri, 21 Mar 2008 00:40:02 +0000

Michael,

In your presentation on marked flow termination, you mentioned a 
couple of times that the core-based approach prevents cheating. Can 
you elaborate? - I don't see how.

Bob

____________________________________________________________________________
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196 

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Michael Menth <[email-masked]>
Date: Fri, 21 Mar 2008 01:48:20 +0100

Hi Bob,

when I am talking about anti-cheating, I am talking about an end-to-end 
PCN architecture. with CMFT, every flow with at least one marked packet 
must be terminated. The egress nodes see these packets and know which 
flows must stop. This can be enforced at the ingress by setting up 
appropriate policers. With EMFT this is not possible as not any marked 
packet requires its flow to stop.

Regards

    Michael

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: Bob Briscoe <[email-masked]>
Date: Tue, 25 Mar 2008 09:57:38 +0000

Michael,

OK - understood

This assumes:
i) there is some edge-edge signalling even in the e2e case, between 
the egress that detects marked packets and the ingress that polices flows.
ii) in a multi-domain scenario that an ingress network will act 
against it's own interests by blocking its own customers' sessions 
even if the congestion is in some other network downstream, nearer to 
the receiver.

[Apologies to the list: both these cases are currently off-charter, 
but this seems a valid consideration for later.]

Bob

At 00:48 21/03/2008, Michael Menth wrote:
>Hi Bob,
>
>when I am talking about anti-cheating, I am talking about an 
>end-to-end PCN architecture. with CMFT, every flow with at least one 
>marked packet must be terminated. The egress nodes see these packets 
>and know which flows must stop. This can be enforced at the ingress 
>by setting up appropriate policers. With EMFT this is not possible 
>as not any marked packet requires its flow to stop.
>
>Regards
>
>    Michael
>
>Bob Briscoe wrote:
>>Michael,
>>

____________________________________________________________________________
Notice: This contribution is the personal view of the author and does 
not necessarily reflect the technical nor commercial direction of BT plc.
____________________________________________________________________________
Bob Briscoe,                           Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196

---

From: "Anna Charny (acharny)" <[email-masked]>
Date: Tue, 25 Mar 2008 08:47:19 -0400

Hi Michael, Bob,

Wouldn't the same argument hold for CL-style termination if you say that
the ingress, after choosing the flows to terminate,  can police these
flows?   (Sorry if I am missing the crux of the argument).

Anna 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Bob Briscoe
> Sent: Tuesday, March 25, 2008 5:58 AM
> To: [email-masked]
> Cc: PCN IETF list
> Subject: Re: [PCN] Core Marked Flow Termination anti-cheating?
> 
> Michael,
> 
> OK - understood
> 
> This assumes:
> i) there is some edge-edge signalling even in the e2e case, 
> between the egress that detects marked packets and the 
> ingress that polices flows.
> ii) in a multi-domain scenario that an ingress network will 
> act against it's own interests by blocking its own customers' 
> sessions even if the congestion is in some other network 
> downstream, nearer to the receiver.
> 
> [Apologies to the list: both these cases are currently 
> off-charter, but this seems a valid consideration for later.]
> 
> 
> Bob
>

---

From: Michael Menth <[email-masked]>
Date: Tue, 25 Mar 2008 15:23:39 +0100

Hi Bob,

> the egress that detects marked packets and the ingress that polices 
Yes. End-to-end PCN is only attractive if it can rely on the marking of 
edge-to-edge PCN domains that already exist, otherwise the deployment of 
end-to-end PCN is not realistic at all. I assume that edge-to-edge PCN 
domains have some edge-to-edge signaling to terminate flows.

> even if the congestion is in some other network downstream, nearer to 
Yes, that's true.

Regards,

    Michael

>> by setting up appropriate policers. With EMFT this is not possible as 
>> not any marked packet requires its flow to stop.
>>
>> Regards
>>
>>    Michael
>>
>> Bob Briscoe wrote:
>>> Michael,
>>>

---

From: Michael Menth <[email-masked]>
Date: Tue, 25 Mar 2008 15:30:53 +0100

Hi Anna,

> flows?   (Sorry if I am missing the crux of the argument).

Yes, the ingress could police a flow. The problem is: how does a single 
PCN domain realize that an end-to-end PCN flow should terminate? With 
core-assisted marked flow termination, every flow with at least one 
marked packet must be terminated and this is easy to recognize by a PCN 
domain's egress node.

Regards,

    Michael

>>>> ____________________________________________________________
>>>>         
>> ________________
>>     
>>>> Bob Briscoe, <[email-masked]>      Networks Research 
>>>>         
>> Centre, BT Research
>>     
>>>> B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.   
>>>>         
>>  +44 1473 645196
>>     
>>> --