Subject: Re: [PCN] Concensus questions from Thursday's PCN meeting

From: "Anna Charny (acharny)" <[email-masked]>
Date: Thu, 20 Mar 2008 08:46:39 -0400

Ah, I see what you mean.  At this level of approximation however this
does  not matter at all - so I just ignored this issue. Just assume that
whatever throughput a device can sustain under heavy overload is 100% of
your desired capacity. Just how low this throughput might be depends on
the queuing architecture of your device and details of traffic arrivals.

I indeed ignored all that.

Anna

> -----Original Message-----
> From: Wei Gengyu [mailto:[email-masked]] 
> Sent: Thursday, March 20, 2008 8:34 AM
> To: Anna Charny (acharny)
> Subject: Re: [PCN] Concensus questions from Thursday's PCN meeting
> 
> Hi, See comments inline.
> 
> ----- Original Message -----
> From: "Anna Charny (acharny)" <[email-masked]>
> To: "Wei Gengyu" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, March 20, 2008 7:49 PM
> Subject: RE: [PCN] Concensus questions from Thursday's PCN meeting
> 
> 
> >Hi Gengyu,
> 
> >Can you clarify please?
> 
> >If you have 5x congestion overall on a link, (which means you have 5
> >times more traffic than your link can carry),  would you not 
> expect to
> >lose 4/5 of your traffic?
> 
> The amount of traffic lost may be more than 4/5 of your traffic.
> The link output may not sustain to be the link capacity, 
> it may be near to zero.
> 
> >You may have misunderstood that in this example the IEA in question
> >itself only has K amount of traffic arriving to this link, 
> not 16K. I am
> >assuming then that approximately 4/5 of k will be lost. This clearly
> >assumes that the loss is proportionally spread among all 
> IEAs, which is
> >indeed not always the case - but seems like a fair approximation for
> >this level of discussion.
> 
> >If I am missing something fundamental, can you explain? 
> 
> >Anna 
> 
> > -----Original Message-----
> > From: Wei Gengyu [mailto:[email-masked]] 
> > Sent: Thursday, March 20, 2008 2:05 AM
> > To: Anna Charny (acharny); Georgios Karagiannis; 
> > [email-masked]; [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [PCN] Concensus questions from Thursday's PCN meeting
> > 
> > Hi, all,
> > 
> > No matter what you want to express,
> > the explanation of your assumed model is incorrect.
> > 
> > Also, see comments inline.
> > 
> > Gengyu
> > 
> > ----- Original Message -----
> > From: "Anna Charny (acharny)" <[email-masked]>
> > To: "Georgios Karagiannis" <[email-masked]>; 
> > <[email-masked]>; <[email-masked]>
> > Cc: <[email-masked]>
> > Sent: Thursday, March 20, 2008 4:33 AM
> > Subject: Re: [PCN] Concensus questions from Thursday's PCN meeting
> > 
> > 
> > > Hi Georgios,
> > >
> > 
> > >  Assume now that the link in question has a very high 
> overload.  I 
> > > would assume is 5X overload is quite large (Rudiger I am 
> sure will 
> > > agree :)), so let us just take 5.  That means that 
> > approximately 80% 
> > > of traffic of this IEA is dropped at the input, so we end 
> up having 
> > > only 0.2K actually leaving this link.
> > 
> > It is wrong.
> > You can not get 0.2K ACTUALLY!
> > And because of this, the following calculation is inredible.
> > 
> > 
> > >
> > > Now assume that the admission threshold is set to 80% of 
> your link 
> > > (picking a high value to make things worse). And assume we 
> > are running 
> > > SM - or LC-PCN (or whatever other alg that uses excess 
> > marking).  Now 
> > > that means that ~20% of our remaining traffic of the IEA 
> aggregate 
> > > gets marked. The egress now sees:  0.2*0.2K=0.04K of 
> marked traffic 
> > > and (M-1)K+0.2*0.8K unmarked traffic.  The CLE now is now 
> > ~0.04K/15K~0.002.
> > > If you need a larger CLE than that, then neither SM, nor, 
> for that 
> > > matter, LC-PCN, would trigger admission stop on that aggregate 
> > > (without probing added).
> > >
> > >
> > > Anna
> > >
> > 
> > Strongly suggest people refer to textbook about throughput 
> > performance of congested node.
> > The throughput of the congested will be different in case the 
> > input is 5*X and 16*X.
> > 
> > Gengyu 
> > 
> > 
> 
> 
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Wei Gengyu" <[email-masked]>
Date: Thu, 20 Mar 2008 21:10:42 +0800

----- Original Message ----- 
From: "Wei Gengyu" <[email-masked]>
To: "Geib, Ruediger" <[email-masked]>
Sent: Thursday, March 20, 2008 9:08 PM
Subject: Re: [PCN] Concensus questions from Thursday's PCN meeting

> Hi, Rudiger,
>
> I have to say some your assumption is not correct.
> For voice custotmer, which is called the subscriber in telecom industry.
>
> When the subscriber come across an unsuccessful call-setup process or 
> break-up,
> and he hears the busy tone, he will hangup first.
>
> But consider what he will do then.
> Most of the subscriber will handoff immediatelly and make a new call.
> This is the real case.
>
> When you measure the SS7 link when a sudden event happens,
> the the number of call attempt may increase sharply, not decrease.
> the number of successful calls decrease if the exchange is highly 
> congested.
> This situation may last more than 60s.
>
>
> What I want to say is the mechanism based on counting the number of 
> packets should be stable even in statistics.
> But the output of count process may not be stable in the case that 
> Georgios gave.
>
> regards,
>
> Gengyu
>
> From: "Geib, Ruediger" <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, March 20, 2008 7:18 PM
> Hi Gengyu, hi Anna
> please don't argue over this. It doesn't matter whether it is 80%, 90%
> or 70% loss. Voice customers will hang up and people watching a video
> will turn off. This will reduce the catastrophic overload within
> 10-60 seconds. Standard operation can resume then to the extent
> possible after a catastrophy.
>
> Anna>  Assume now that the link in question has a very high overload.  I
> | > would assume is 5X overload is quite large (Rudiger I am sure will
> | > agree :)), so let us just take 5.  That means that approximately 80%
> | > of traffic of this IEA is dropped at the input, so we end up having
> | > only 0.2K actually leaving this link.
> |
> Genyu| It is wrong.
> | You can not get 0.2K ACTUALLY!
> | And because of this, the following calculation is inredible.
>
> Anna: yes, "5% congestion" is a reasonable assumption for a link congested
> under regular network conditions for engineered carrier backbones (i.e.
> including single outages).
>
> Regards,
>
> Rudiger
>