Subject: [PCN] **DRAFT** PCN wg agenda for IETF 72

From: Steven Blake <[email-masked]>
Date: Wed, 16 Jul 2008 07:03:53 -0400

Greetings.  I plan to upload the following draft agenda for Dublin
today.  There are a few presentations that may be added at the end, time
permitting.

Please send comments to the list.

Regards,

// Steve
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Wed, 16 Jul 2008 12:40:19 +0100

Hi,

I remember at/after the last ietf we had this "consensus question"

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Steven Blake
Sent: 20 April 2008 18:41
To: pcn
Subject: Re: [PCN] Consensus questions: Q4, Q5, and Q6

> Q6: If presented with sufficient evidence in a timely fashion, would
>     the PCN wg entertain the option of modifying the interior router
>     Excess-Rate marking behavior for the standards-track PCN scheme
(as
>     described in question 4)?
> 

The feedback for Q6 was a mixture of abstain and Yes with caveats.  If
and when someone wants to propose modifications to the Excess-Rate
marking behavior, we can see if there is interest to discuss it on the
list, but I *strongly encourage* that any such discussion needs to
happen before the Dublin meeting.

----------------------------------

as far as I know, there've been no proposals. But if I missed them, then
I guess that draft-eardley-pcn-marking-behavior-01 would need more than
15mins (it captures the Consensus on marking behaviour, ie Questions 4 &
5)

thanks,
phil

{ -----Original Message-----
{ From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ Steven Blake
{ Sent: 16 July 2008 12:04
{ To: pcn
{ Subject: [PCN] **DRAFT** PCN wg agenda for IETF 72
{ 
{ Greetings.  I plan to upload the following draft agenda for Dublin
{ today.  There are a few presentations that may be added at the end,
time
{ permitting.
{ 
{ Please send comments to the list.
{ 
{ 
{ Regards,
{ 
{ // Steve
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Michael Menth <[email-masked]>
Date: Wed, 16 Jul 2008 14:55:20 +0200

Hi Phil,

there is a requirement for packet-size independent marking
http://tools.ietf.org/wg/pcn/draft-menth-pcn-emft-00.txt
which is necessary to achieve fairness for marked flow termination. 
Evidence for its relevance it given in
http://www3.informatik.uni-wuerzburg.de/staff/menth/Publications/Menth08-PCN-MFT.pdf
I raised this issue already at the last meeting since I think it's a 
useful feature.

Regards,

    Michael

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 16 Jul 2008 13:16:26 +0000

Hi Steven, Hi all

Please note that the authors of the LC-PCN draft would like to have a
time slot of 15 minutes. In this presnetation the main updates of LC-PCN
will be presented and also some results of the performance experiments.

Please note that the draft does not include experiments, but these
results could be shown during the IETF meeting.

Please note that I will not be able to come to the IETF.

Hein Mekkes will give the presentation!

Best regards,
Georgios

---

From: <[email-masked]>
Date: Wed, 16 Jul 2008 14:34:13 +0100

Michael,
Sure, hopefully already got your suggestion

2.5.  Excess traffic meter function
...
If the token bucket is within an MTU of being empty, then
   the meter SHOULD indicate to the Marking function that the packet is
   to be excess-traffic-marked; MTU means the maximum size of PCN-
   packets on the link.  Otherwise the meter does not indicate marking.

And In appendix B.5.  Excess traffic metering
   Packet size independent marking is specified as a SHOULD in Section
   2.4 ( "If the token bucket is within an MTU of being empty, then the
   meter SHOULD indicate to the Marking function that the packet is to
   be excess-traffic-marked; MTU means the maximum size of PCN-packets
   on the link.")  Without it, large packets are more likely to be
   excess-traffic-marked than small packets and this means that, with
   some edge behaviours, flows with large packets are more likely to be
   terminated than flows with small packets
   [I-D.draft-briscoe-tsvwg-byte-pkt-mark] [Menth].

Ok or need improving?

Thanks
phil
{ -----Original Message-----
{ From: Michael Menth [mailto:[email-masked]]
{ Sent: 16 July 2008 13:55
{ To: Eardley,PL,Philip,CXR9 R
{ Cc: [email-masked]; [email-masked]
{ Subject: Re: [PCN] **DRAFT** PCN wg agenda for IETF 72
{ 
{ Hi Phil,
{ 
{ there is a requirement for packet-size independent marking
{ http://tools.ietf.org/wg/pcn/draft-menth-pcn-emft-00.txt
{ which is necessary to achieve fairness for marked flow termination.
{ Evidence for its relevance it given in
{
http://www3.informatik.uni-wuerzburg.de/staff/menth/Publications/Menth08
-
{ PCN-MFT.pdf
{ I raised this issue already at the last meeting since I think it's a
{ useful feature.
{ 
{ Regards,
{ 
{     Michael
{ 
{ [email-masked] wrote:
{ > Hi,
{ >
{ > I remember at/after the last ietf we had this "consensus question"
{ >
{ > -----Original Message-----
{ > From: [email-masked] [mailto:[email-masked]] On Behalf
Of
{ > Steven Blake
{ > Sent: 20 April 2008 18:41
{ > To: pcn
{ > Subject: Re: [PCN] Consensus questions: Q4, Q5, and Q6
{ >
{ >
{ >> Q6: If presented with sufficient evidence in a timely fashion,
would
{ >>     the PCN wg entertain the option of modifying the interior
router
{ >>     Excess-Rate marking behavior for the standards-track PCN scheme
{ >>
{ > (as
{ >
{ >>     described in question 4)?
{ >>
{ >>
{ >
{ > The feedback for Q6 was a mixture of abstain and Yes with caveats.
If
{ > and when someone wants to propose modifications to the Excess-Rate
{ > marking behavior, we can see if there is interest to discuss it on
the
{ > list, but I *strongly encourage* that any such discussion needs to
{ > happen before the Dublin meeting.
{ >
{ > ----------------------------------
{ >
{ > as far as I know, there've been no proposals. But if I missed them,
then
{ > I guess that draft-eardley-pcn-marking-behavior-01 would need more
than
{ > 15mins (it captures the Consensus on marking behaviour, ie Questions
4 &
{ > 5)
{ >
{ > thanks,
{ > phil
{ >
{ > { -----Original Message-----
{ > { From: [email-masked] [mailto:[email-masked]] On Behalf
Of
{ > { Steven Blake
{ > { Sent: 16 July 2008 12:04
{ > { To: pcn
{ > { Subject: [PCN] **DRAFT** PCN wg agenda for IETF 72
{ > {
{ > { Greetings.  I plan to upload the following draft agenda for Dublin
{ > { today.  There are a few presentations that may be added at the
end,
{ > time
{ > { permitting.
{ > {
{ > { Please send comments to the list.
{ > {
{ > {
{ > { Regards,
{ > {
{ > { // Steve
{ > _______________________________________________
{ > PCN mailing list
{ > [email-masked]
{ > https://www.ietf.org/mailman/listinfo/pcn
{ >
{ 
{ --
{ Dr. Michael Menth, Assistant Professor
{ University of Wuerzburg, Institute of Computer Science
{ Am Hubland, D-97074 Wuerzburg, Germany, room B206
{ phone: (+49)-931/888-6644, fax: (+49)-931/888-6632
{ mailto:[email-masked]
{ http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: Michael Menth <[email-masked]>
Date: Wed, 16 Jul 2008 16:23:56 +0200

Hi Phil,

>    packets on the link.  Otherwise the meter does not indicate marking.
This achieves packet-size independent marking.

The addition of this sentence would be good to tell the reader why this 
is done. I indeed overlooked this paragraph.

>    [I-D.draft-briscoe-tsvwg-byte-pkt-mark] [Menth].

That's ok.

Regards,

    Michael