Subject: Re: [PCN] FW: New Version Notification fordraft-moncaster-pcn-3-state-encoding-00

From: <[email-masked]>
Date: Tue, 15 Jul 2008 10:55:16 +0100

Toby, Michael, bob,

It looks good to me.

S3: terminology
PCN-flow - a flow covered by a reservation but which hasn't
      signalled that it requires end-to-end ECN support.

I think the concept of PCN-flows should include PCN-enabled-ECN-flows.

I'm not sure about "reservation", surely something like "using the PCN
mechanisms". Or protected by them. 

6.1: 
In addition all packets should have their DSCP reset to the
   appropriate DSCP for the next hop.  If the next hop is not another
   PCN region this will not be a PCN enabled DSCP, and by default will
   be the best-efforts DSCP.  Alterntively higher layer signalling
   mechanisms may allow the DSCP that packets entered the PCN-domain
   with to be re-instated.

All packets -> all PCN-packets
Should have -> SHOULD have (or possibly MUST have)
Last sentence - this is a likely example of what the higher layer
signalling could do, however the domain on the far side of the
pcn-domain might use a different DSCP from the domain on the near side. 

S7.1:
Transports wishing to use both a reservation and end-to-end ECN
I think "PCN" would better than "reservation"

S7.2.0: indicate that the context is PCN-traffic

7.2.1:
downgrading is here a MAY, whereas in the baseline-encoding-02 it was an
"SHOULD... or ..."
rather than "lower (non-PCN) service class" it would be better to say
lower priority (non-PCN) behaviour aggregate 

Typos:
S4: an additional PCN enabled DiffServ codepoints. -> codepoint
S5: ., -> .
S6.1: Alterntively -> Alternatively 

phil
{ -----Original Message-----
{ From: [email-masked] [mailto:[email-masked]] On Behalf Of
{ [email-masked]
{ Sent: 23 June 2008 18:15
{ To: [email-masked]
{ Subject: [PCN] FW: New Version Notification fordraft-moncaster-pcn-3-
{ state-encoding-00
{ 
{ 
{ As promised in earlier emails here is the first version of the
extended
{ PCN encoding scheme draft. Note it hasn't been completely checked for
{ consistency, grammar, etc so any and all reviews gratefully accepted.
{ 
{ My hope is to get a 01 version out in plenty of time for Dublin.
{ 
{ Toby
{ ____________________________________________________________________
{ Toby Moncaster, <[email-masked]> Networks Research Centre, BT
{ B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 1473 648734
{ 
{ 
{ -----Original Message-----
{ From: IETF I-D Submission Tool [mailto:[email-masked]]
{ Sent: 23 June 2008 18:09
{ To: Moncaster,T,Toby,CXR9 R
{ Cc: Briscoe,RJ,Bob,CXR9 R; [email-masked]
{ Subject: New Version Notification for
{ draft-moncaster-pcn-3-state-encoding-00
{ 
{ 
{ A new version of I-D, draft-moncaster-pcn-3-state-encoding-00.txt has
{ been successfuly submitted by T Moncaster and posted to the IETF
{ repository.
{ 
{ Filename:	 draft-moncaster-pcn-3-state-encoding
{ Revision:	 00
{ Title:		 A three state extended PCN encoding scheme
{ Creation_date:	 2008-06-23
{ WG ID:		 Independent Submission
{ Number_of_pages: 13
{ 
{ Abstract:
{ Pre-congestion notification (PCN) is a mechanism designed to protect
{ the Quality of Service of inelastic flows.  It does this by marking
{ packets when traffic load on a link is approaching or has exceeded a
{ threshold below the physical link rate.  This baseline encoding
{ specified how two encoding states could be encoded into the IP
{ header.  This document specified an extension to the baseline
{ encoding that enables three encoding states to be carried in the IP
{ header as well as enabling limited support for end-to-end ECN.
{ 
{ Status
{ 
{ This memo is posted as an Internet-Draft with an intent to eventually
{ be published as an experimental RFC.
{ 
{ 
{ 
{ 
{ The IETF Secretariat.
{ 
{ 
{ _______________________________________________
{ PCN mailing list
{ [email-masked]
{ https://www.ietf.org/mailman/listinfo/pcn
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: <[email-masked]>
Date: Tue, 15 Jul 2008 11:55:48 +0100

Hi Phil,

Thanks for the comments. I will make those changes in the 01 version of
the draft which I will aim to release straight after the submission
server re-opens in 3 weeks time.

Toby

> -----Original Message-----
> From: Eardley,PL,Philip,CXR9 R 
> Sent: 15 July 2008 10:55
> To: Moncaster,T,Toby,CXR9 R; [email-masked]
> Subject: RE: [PCN] FW: New Version Notification 
> fordraft-moncaster-pcn-3-state-encoding-00
> 
> Toby, Michael, bob,
> 
> It looks good to me.
> 
> S3: terminology
> I'm not sure about "reservation", surely something like 
> "using the PCN mechanisms". Or protected by them. 
> 
> 
> 6.1: 
> Last sentence - this is a likely example of what the higher 
> layer signalling could do, however the domain on the far side 
> of the pcn-domain might use a different DSCP from the domain 
> on the near side. 
> 
> S7.1:
> downgrading is here a MAY, whereas in the 
> baseline-encoding-02 it was an "SHOULD... or ..."
> rather than "lower (non-PCN) service class" it would be 
> better to say lower priority (non-PCN) behaviour aggregate 
> 
> 
> Typos:
> { As promised in earlier emails here is the first version of 
> the extended
> { A new version of I-D, 
> draft-moncaster-pcn-3-state-encoding-00.txt has