Subject: [PCN] Re : draft-moncaster-pcn-3-state-encoding-00.txt

From: "Ingemar Johansson S" <[email-masked]>
Date: Mon, 28 Jul 2008 17:52:31 +0200

Hi

Reading chapter 9 in draft-moncaster-pcn-3-state-encoding-00 (security considerations). 
Another transport that may use the nonce is DCCP with CCID 3 (see section 9 in http://tools.ietf.org/html/rfc4342 )

That said, ECN nonce is probably only useful in a client-server scenario as it builds on some kind of trust relationship. For normal UDP transport such as VoIP between two "untrusted" clients I see very little use for the ECN nonce.

Besides this I would say that this is probably a quite neat solution to the e2e ECN preservation problem and to some extent it may be possible to also be possible for atleast the PCN egress nodes to do some additional policing on flows that don't comply to the ThM and Etm marks but this is probably a later headache.

/Ingemar
******************************************* 
Ingemar Johansson 
Senior Research Engineer, IETF "nethead" 
EAB/TVP - Multimedia Technologies 
Ericsson Research Ericsson AB 
Box 920 S-971 28 Luleå, Sweden 
Tel: +46 (0)8 4043042 
ECN: 850-43042 
ECC: 850-43074 
Mobile: +46 (0)730 783289 
******************************************* 
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 31 Jul 2008 17:46:35 +0100

Ingemar,

Tx. I agree (and plenty of people at the IETF got 
bored with me saying it) that the ECN nonce is 
only useful if the sender is in some sense acting 
on behalf of the network. I tried to write that 
piece of text without giving opinion, just fact.

Just to point out that the nonce can't be used by 
the PCN egress, given a 1-bit nonce requires 
packet ordering otherwise it gives false 
negatives. The egress doesn't necessarily receive 
packets in order, and it can't necessarily put 
them in order because that's not it's role.

Bob

At 16:52 28/07/2008, Ingemar Johansson S wrote:
>Hi
>
>Reading chapter 9 in 
>draft-moncaster-pcn-3-state-encoding-00 (security considerations).
>Another transport that may use the nonce is DCCP 
>with CCID 3 (see section 9 in http://tools.ietf.org/html/rfc4342 )
>
>That said, ECN nonce is probably only useful in 
>a client-server scenario as it builds on some 
>kind of trust relationship. For normal UDP 
>transport such as VoIP between two "untrusted" 
>clients I see very little use for the ECN nonce.
>
>Besides this I would say that this is probably a 
>quite neat solution to the e2e ECN preservation 
>problem and to some extent it may be possible to 
>also be possible for atleast the PCN egress 
>nodes to do some additional policing on flows 
>that don't comply to the ThM and Etm marks but 
>this is probably a later headache.
>
>/Ingemar

____________________________________________________________________________
Bob Briscoe, <[email-masked]>      Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196