Subject: [PCN] clarification of "PCM-marked" in draft-ietf-pcn-marking-behaviour

From: <[email-masked]>
Date: Tue, 9 Dec 2008 12:23:57 -0000

Prompted by a comment from Fortune, I've realised that a small issue
needs clarifying in the marking draft. 

The draft has statements like: "PCN-packets that arrive at the PCN-node
already excess-traffic-marked SHOULD be preferentially dropped;"
The problem is that if the baseline encoding is being used, then NO pkts
are ever excess-traffic-marked! - because they are actually PCN-marked. 
 
At the moment, this is the simplest way I can find of making the
Standard say what we mean it to say(!) is to add two Notes, one to
Section 1.1 Terminology & one to Section 2.5 Marking function:
 
S1.1: Note: excess-traffic-marked means a packet that is marked as a
result of the excess traffic meter function; threshold-marked means a
packet that is marked as a result of the threshold meter function.
[baseline-encoding] defines only two PCN encoding states available
(PCN-marked and not-marked); the deployment MUST choose whether
PCN-marked is interpreted as excess-traffic-marked or threshold-marked;
a consistent choice MUST be made throughout a PCN-domain. 

S2.5: Note: In some deployment scenarios there may be only two PCN
encoding states available (PCN-marked and not-marked). In such
scenarios, the deployment MUST choose whether the Threshold meter
function or the Excess traffic meter function triggers a packet to be
PCN-marked; a consistent choice MUST be made throughout a PCN-domain. 
 
It's a bit repetitive - is there a way of saying this just once?
It would also be possible to add a similar note to the Baseline encoding
draft, although initial thought is that this isn't necessary.

Comments?

Thanks

Phil/ 

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Geib, Ruediger" <[email-masked]>
Date: Tue, 9 Dec 2008 14:08:55 +0100

Hi Phil,
 
repeating this phrase shouldn't be an issue, its not that long. And correct description is sometimes more important than smart writing. So I propose repetition. That also means, I agree to the proposed wording.
 
Regards,
 
Ruediger

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, December 09, 2008 1:24 PM
To: [email-masked]
Subject: [PCN] clarification of "PCM-marked" indraft-ietf-pcn-marking-behaviour

Prompted by a comment from Fortune, I've realised that a small issue needs clarifying in the marking draft. 

The draft has statements like: "PCN-packets that arrive at the PCN-node already excess-traffic-marked SHOULD be preferentially dropped;"
The problem is that if the baseline encoding is being used, then NO pkts are ever excess-traffic-marked! - because they are actually PCN-marked. 
 
At the moment, this is the simplest way I can find of making the Standard say what we mean it to say(!) is to add two Notes, one to Section 1.1 Terminology & one to Section 2.5 Marking function:
 
S1.1: Note: excess-traffic-marked means a packet that is marked as a result of the excess traffic meter function; threshold-marked means a packet that is marked as a result of the threshold meter function. [baseline-encoding] defines only two PCN encoding states available (PCN-marked and not-marked); the deployment MUST choose whether PCN-marked is interpreted as excess-traffic-marked or threshold-marked; a consistent choice MUST be made throughout a PCN-domain. 

neS2.5: Note: In some deployment scenarios there may be only two PCN encoding states available (PCN-marked and not-marked). In such scenarios, the deployment MUST choose whether the Threshold meter function or the Excess traffic meter function triggers a packet to be PCN-marked; a consistent choice MUST be made throughout a PCN-domain. 
 
It's a bit repetitive - is there a way of saying this just once?
It would also be possible to add a similar note to the Baseline encoding draft, although initial thought is that this isn't necessary.

Comments?

Thanks

Phil/