Subject: Re: [PCN] New edge behaviour: draft-karagiannis-pcn-hose-edge-behaviour-00

From: Fortune HUANG <[email-masked]>
Date: Tue, 03 Nov 2009 17:42:24 +0800

Hi Georgios,

Basically, I think the HOSE model has its great advantage to solve the ECMP
issue, which is well described in this draft.
 
But I still have a comment that it should be the decision node that makes
the decision to admit/block/terminate a flow. According to the PCN
architecture, neither PCN-ingress-node nor PCN-egress-node contains the
function of making decision. So I think the role of decision node is missing
and
the behaviour of making decision is misplaced in this draft.

Best regards,
Fortune

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Georgios Karagiannis
Sent: Wednesday, October 21, 2009 9:59 PM
To: [email-masked]
Subject: [PCN] New edge behaviour:
draft-karagiannis-pcn-hose-edge-behaviour-00

 Hi all

During the last two IETF meetings I had promissed to publish the HOSE edge
behaviour draft.

Via the following URL you can find this draft:

http://www.ietf.org/id/draft-karagiannis-pcn-hose-edge-behaviour-00.txt

If you have any comments please let me know!

--------------------------------------------------------

   Abstract ++

   Precongestion notification (PCN) is a means for protecting quality of
   service for inelastic traffic admitted to a Diffserv domain.  The
   overall PCN architecture is described in RFC 5559.  This memo is one
   of a series describing possible boundary node behaviours for a PCN
   domain.  The behaviour described here is denoted as the HOSE model.
   In this document the term HOSE is referring to the
   aggregation of incoming traffic from all ingress edges, which is
   associated with one traffic class, i.e., PHB, towards one egress
   edge.  This type of HOSE model is equivalent to the Multiple Point to
   Point (MP2P) type of aggregation.

   The HOSE model ensures bandwidth limits without the need of
   maintaining per each ingress and egress pair ingress-egress-
   aggregated states.  In this case all edges maintain one aggregated
   state per each traffic class, i.e., PHB (Per Hop Behaviour), used in
   the PCN domain. Moreover, the HOSE model is able to provide solutions
   for the ECMP (Equal Cost Multi Path) problem for both admission
   control and flow termination procedures.

-------------------------------------

Best regards,
Georgios

_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 3 Nov 2009 11:04:07 +0100

Hi Fortune

Thank you very much for the comments!
Please see in line!

> From: Fortune HUANG [mailto:[email-masked]] 
> Sent: dinsdag 3 november 2009 10:42
> To: 'Georgios Karagiannis'; [email-masked]
> Subject: RE: [PCN] New edge 
> behaviour:draft-karagiannis-pcn-hose-edge-behaviour-00
> 
> Hi Georgios,
> 
> Basically, I think the HOSE model has its great advantage to 
> solve the ECMP issue, which is well described in this draft.
>  
> But I still have a comment that it should be the decision 
> node that makes the decision to admit/block/terminate a flow. 
> According to the PCN architecture, neither PCN-ingress-node 
> nor PCN-egress-node contains the function of making decision. 
> So I think the role of decision node is missing and the 
> behaviour of making decision is misplaced in this draft.

Georgios: You are right, we are not emphasizing which entity is the decision
point. 
Please note that the decision point can be either the ingress, the egress or
a centralized 
decision point. Please note that in a future version of the draft we can
clarify this, 
by explicitly using the notion of the decission point.

Best regards,
Georgios

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Georgios Karagiannis
> During the last two IETF meetings I had promissed to publish 
> the HOSE edge behaviour draft.
>

---

From: "Holtzer, A.C.G. (Arjen)" <[email-masked]>
Date: Fri, 6 Nov 2009 15:02:45 +0100

Hello Georgios,

I think that the proposed combination of signalling and PCN-marking
really has advantages for solving the ECMP issue and am interested in
seeing how it would perform (in both the trunk and HOSE model). I think
the draft clearly explains the proposed mechanisms. I have two minor
remarks:

1) Maybe the addition of a short description of the actual ECMP problem
that is solved here would make the draft more complete.

2) Section 2, bullet 5a says:
	
"the interior SHOULD preferentially drop unmarked packets instead of
marked packets". 

Shouldn't this be changed into:

"the interior node SHOULD preferentially drop unmarked or Threshold
marked packets instead of Excess marked packets"?

Best regards,
Arjen 

> Sent: woensdag 21 oktober 2009 15:59
> To: [email-masked]
> Subject: [PCN] New edge 
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/disclaimer/email.html

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 6 Nov 2009 18:06:48 +0100

Hi Arjen

Thank you very much for your comments!
Please see in line!

> From: Holtzer, A.C.G. (Arjen) [mailto:[email-masked]] 
> Sent: vrijdag 6 november 2009 15:03
> To: Georgios Karagiannis
> Cc: [email-masked]
> I think that the proposed combination of signalling and 
> PCN-marking really has advantages for solving the ECMP issue 
> and am interested in seeing how it would perform (in both the 
> trunk and HOSE model). I think the draft clearly explains the 
> proposed mechanisms. I have two minor
> remarks:
> 
> 1) Maybe the addition of a short description of the actual 
> ECMP problem that is solved here would make the draft more complete.

Georgios: yes that is a good idea. The next version of the draft will
include this description.

> "the interior SHOULD preferentially drop unmarked packets 
> instead of marked packets". 
> 
> "the interior node SHOULD preferentially drop unmarked or 
> Threshold marked packets instead of Excess marked packets"?

Georgios: Yes you are right! This is actually what we were willing to say,
but is written in 
a wrong way! We will correct it in the next version of the draft!

Best regards,
Georgios

> > During the last two IETF meetings I had promissed to 
> publish the HOSE 
> > edge behaviour draft.
> > 
> >    Precongestion notification (PCN) is a means for 
> protecting quality 
> > of
> >    edge.  This type of HOSE model is equivalent to the 
> Multiple Point 
> > to
> >    state per each traffic class, i.e., PHB (Per Hop 
> Behaviour), used 
> > in