Subject: [PCN] comments on controlled load boundary behaviour draft

From: <[email-masked]>
Date: Sun, 21 Mar 2010 03:10:39 -0000

looking good. i think this (and the singl marking) are ready. my comments are minor 
 
abstract
i think "three-state" is probably too obtuse for an ietf abstract
 
unify some of the terminology to the rfcs
eg PCN-ingress-node
not-marked (you have unmarked)  or not PCN-marked
'admit-rate'
 
termination MUST be a configurable option - is the same true for admissin? if not, why?
 
3.4.2
if admit-rate is a tiny bit greater than SAR, then you say you MUST terminate. more likely, i think, is that you allow a little bit of lee-way
 
you have: the decision point MUST select flow to terminate using its knowledge of bw required by individual flows. i think a MUST is too strong here. eg if it knew they all had similar requirements, then it might keep it simple and not bother with knowledge of bw required per flow.
 
3.5
2 * Tmax or less. where does this choice come from? i had a feeling that 3* was normal for assuming something wrong - otherwise you might raise an alarm if just one msg was lost
 
somewhere, maybe 5.4, you could note that normally all egress nodes are also pcn-ingress-nodes
 
5.5
reserved -> prioritised
 
thanks
phil

---

From: <[email-masked]>
Date: Fri, 26 Mar 2010 21:25:47 -0000

I think this is ready. some of the comments on the CL boundary node behaviour i made earlier also apply
 
minor comment - final bullet of S2, re-phrase as
"PCN-interior-nodes do not perform threshold-metering"
 
Thanks
phil