Subject: [PCN] CL edge behaviour-03 posted

From: Tom Taylor <[email-masked]>
Date: Mon, 21 Jun 2010 23:37:30 -0400

I have posted draft-ietf-pcn-cl-edge-behaviour-03.txt. I should warn you that 
Michael Menth disagrees with the proposal to send the calculated CLE along the 
raw rates. Authors Fortune Huang and Georgios Karagiannis have accepted it, and 
Anna Charny hasn't commented. I just figured it was time to get things moving.

I'll provide a similar update to the SM edge behaviour draft tomorrow and give a 
detailed report of the differences from the previous versions. These drafts 
should then be ready for WGLC unless the chairs want to achieve a consensus on 
the CLE issue first.

Tom Taylor

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Tue, 22 Jun 2010 08:43:03 +0200

Hi all

I am updating the signaling draft, but before completing it I would like to
know whether 
the proposals given in the edge behaviour drafts regarding signaling are
accepted by the working group!

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tom Taylor
> Sent: dinsdag 22 juni 2010 5:38
> To: pcn
> Subject: [PCN] CL edge behaviour-03 posted
> 
> I have posted draft-ietf-pcn-cl-edge-behaviour-03.txt. I 
> should warn you that Michael Menth disagrees with the 
> proposal to send the calculated CLE along the raw rates. 
> Authors Fortune Huang and Georgios Karagiannis have accepted 
> it, and Anna Charny hasn't commented. I just figured it was 
> time to get things moving.
> 
> I'll provide a similar update to the SM edge behaviour draft 
> tomorrow and give a detailed report of the differences from 
> the previous versions. These drafts should then be ready for 
> WGLC unless the chairs want to achieve a consensus on the CLE 
> issue first.
> 
> Tom Taylor
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcn
>

---

From: Michael Menth <[email-masked]>
Date: Tue, 22 Jun 2010 10:57:51 +0200

Hi Tom, hi all,

the egress node sends to the ingress node the rates of NM-, ThM-, and 
ETM-traffic. The CLE is computed as CLE=(Rates of 
ThM+ETM-traffic)/(Rates of NM+ThM+ETM-traffic). As it can be computed 
from the other data in a very simple way, including the CLE in the 
signalling message seems redundant to me. However, I don't want to delay 
things and can live with this redundant data as it is only little. It 
does no other harm than at most an infinitesimal contribution to global 
warming ;-)

Apart from that, I would like to point out that CLE smoothing is harmful 
as it leads to overadmission in case of flash crowds. See Section IV.E 
in our revised paper at
http://www3.informatik.uni-wuerzburg.de/~menth/Publications/papers/Menth08-Sub-8.pdf
The mere existence of CLE smoothing in the draft is not harmful as long 
as it is not mandatory. So this is neither a reason to delay things.

Best wishes,

    Michael

Tom Taylor schrieb:
> I have posted draft-ietf-pcn-cl-edge-behaviour-03.txt. I should warn 
> you that Michael Menth disagrees with the proposal to send the 
> calculated CLE along the raw rates. Authors Fortune Huang and Georgios 
> Karagiannis have accepted it, and Anna Charny hasn't commented. I just 
> figured it was time to get things moving.
>
> I'll provide a similar update to the SM edge behaviour draft tomorrow 
> and give a detailed report of the differences from the previous 
> versions. These drafts should then be ready for WGLC unless the chairs 
> want to achieve a consensus on the CLE issue first.
>
> Tom Taylor

-- 
PD Dr. habil. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/31-86644 (new), fax: (+49)-931/31-86632 (new)
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: "Toby Moncaster" <[email-masked]>
Date: Tue, 22 Jun 2010 10:20:38 +0100

Hi All,

It's been a good few months since I looked at PCN at all. In the meantime I
have left BT, hence my new email address. I will (probably) start getting
sporadically involved again over the next few weeks unless I get a new job
before then...

On to the meat of what I wanted to say:

I will admit right now I haven't actually read this draft, but reading what
Michael writes below, would it be possible to have a compromise along the
following lines:

"The ingress node can calculate the rates of CLE etc in the following
manner: {set out appropriate equations}. However this requires the ingress
to perform additional calculations which might not be desirable. In that
case it would be sensible to explicitly send the CLE in the signalling
message from the egress. This latter approach is RECOMMENDED, but an
operator COULD calculate the rate instead"

I know that isn't very well written, but it seems to me we don't need to
make either of these a MUST as long as there is a MUST that the ingress has
to find out the CLE somehow... Although no expert on hardware, I am sure
there are instances where you wouldn't want to waste effort doing extra
calculations at the ingress, equally I can think of times you would want to
reduce the volume of signalling traffic...

Toby

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Michael Menth
> Sent: 22 June 2010 09:58
> To: Tom Taylor
> Cc: pcn
> Subject: Re: [PCN] CL edge behaviour-03 posted
> 
> Hi Tom, hi all,
> 
> http://www3.informatik.uni-
> wuerzburg.de/~menth/Publications/papers/Menth08-Sub-8.pdf