Subject: [pcp] comments about PCP

From: Dayong Guo <[email-masked]>
Date: Tue, 14 Sep 2010 11:27:46 +0800

Hi, Authors of PCP,
  Here are some comments about draft-wing-softwire-port-control-protocol-02:
  1. Should the 'R' bit in n Figure 4: PIN-REQUEST be replaced by 'M' bit? I
could NOT find 'R' bit in descriptions of the  PIN-REQUEST.
  2. Information Elements (IE) MAY appear in requests. But how can we locate
the start bit of the Information Elements  because the PIN-REQUEST body is
variable length. A solution is that the PIN-REQUEST body are laid out fixed
length: 

 0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
:               Internal IP address (32 or 128 bits)            :
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
:               External IP address (32 or 128 bits)            :
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|   Proto       |W|    Reserved                                 |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                  Assigned Pinhole Lifetime in Seconds         |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Some optional IEs  follow the PIN-REQUEST body. The 'Internal Port' and
'Assigned External Port' fields in PIN-REQUEST body are removed and they can
occer as two new IEs

Dayong Guo

---

From: <[email-masked]>
Date: Tue, 14 Sep 2010 08:00:15 +0200

Dear Dayong, 

Thank you for your comments. 

Please see inline.

Cheers,
Med 

-----Message d'origine-----
De : Dayong Guo [mailto:[email-masked]] 
Envoyé : mardi 14 septembre 2010 05:28
À : BOUCADAIR Mohamed NCPI/NAD/TIP; [email-masked]; [email-masked]
Cc : [email-masked]; 'CUI Yong'
Objet : comments about PCP

Hi, Authors of PCP,

Med: Yes, this was a typo in 02 version. The format of the PIN request is as follows:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     :              Internal IP address (32 or 128 bits)             :
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |             Requested Pinhole Lifetime (seconds)              |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     :    Proto      |W|M|            reserved                 |p-cnt:
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     : Internal Port                 | Requested External Port       :
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

P-cnt being the number of (internal port, requested ext port) pairs included in a request.
FYI, we have a pending point: maintain W bit or use a reserved value of the Proto field to indicate a wildcard protocol.

  2. Information Elements (IE) MAY appear in requests. But how can we locate
the start bit of the Information Elements  because the PIN-REQUEST body is
variable length. 
A solution is that the PIN-REQUEST body are laid out fixed
length: 

 0                   1                   2                   3

Med: The start of the IEs can be easily found because the fields preceding the IE set have "known" lengths (whatever the value of W bit). Did I missed something?

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Dayong Guo <[email-masked]>
Date: Tue, 14 Sep 2010 17:35:42 +0800

Med, 
        thanks for your responses.

> Med: The start of the IEs can be easily found because the 
> fields preceding the IE set have "known" lengths (whatever 
> the value of W bit). Did I missed something?

      Maybe I mistake the 'OpCode-length'  in PCP header.  It's NOT message
length. 
      But Most protocols has a length field in header which indicates the
length of total message. It is beneficial to the program to read protocol
message. Without message length, programer will be puzzled when two PCP
messages encapsulated in a UDP:  It is difficult to judge the IEs of the
first PCP message or the second PCP header.
    Would you think it is better when PCP header has a message length.

Dayong Guo

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Tuesday, September 14, 2010 2:00 PM
> To: Dayong Guo; [email-masked]; [email-masked]
> Cc: [email-masked]; 'CUI Yong'
> Subject: RE: comments about PCP
> 
> Dear Dayong, 
> 
> De : Dayong Guo [mailto:[email-masked]] Envoyé : mardi 14 
> septembre 2010 05:28 À : BOUCADAIR Mohamed NCPI/NAD/TIP; 
> [email-masked]; [email-masked] Cc : [email-masked]; 'CUI Yong'
>   Here are some comments about 
> draft-wing-softwire-port-control-protocol-02:
>   1. Should the 'R' bit in n Figure 4: PIN-REQUEST be 
> replaced by 'M' bit? I could NOT find 'R' bit in descriptions 
> of the  PIN-REQUEST.
> 
> FYI, we have a pending point: maintain W bit or use a 
> reserved value of the Proto field to indicate a wildcard protocol.
> 
> 
>   2. Information Elements (IE) MAY appear in requests. But 
> how can we locate the start bit of the Information Elements  
> because the PIN-REQUEST body is variable length. 
> Some optional IEs  follow the PIN-REQUEST body. The 'Internal 
> Port' and 'Assigned External Port' fields in PIN-REQUEST body 
> are removed and they can occer as two new IEs
> 
> Med: The start of the IEs can be easily found because the 
> fields preceding the IE set have "known" lengths (whatever 
> the value of W bit). Did I missed something?
> 
> 
> 
> 
> This message and any attachments (the "message") are 
> confidential and intended solely for the addressees. 
> If you are not the intended addressee of this message, please 
> cancel it immediately and inform the sender.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 14 Sep 2010 11:45:13 +0200

>    Would you think it is better when PCP header has a message length.

Isn't the length field in the IP header sufficient?

In fact, even that field is generally superfluous. The link layer knows how long packets are, with the exception of cases like ethernet where there is a minimum frame length that is larger than the minimum IP packet size (e.g., a ping packet can be 28 bytes while the minimum ethernet payload size is 46 bytes). You'll also note that the TCP header doesn't have a length field.

---

From: Alain Durand <[email-masked]>
Date: Tue, 14 Sep 2010 06:10:19 -0700

Dayong,

draft-wing-softwire-port-control-protocol-02 was a strawman proposal to get the work started.
We are now restarting from scratch. We should see a new proposed packet format published very soon
and we plan to discuss it during the upcoming interim meeting.

  - Alain.

On Sep 13, 2010, at 11:27 PM, Dayong Guo wrote:

> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Alain Durand <[email-masked]>
Date: Tue, 14 Sep 2010 06:14:32 -0700

Dayong,

 - Alain.

---

From: Dayong Guo <[email-masked]>
Date: Wed, 15 Sep 2010 09:18:22 +0800

Alain, 
      That's OK. 
      
Dayong Guo

> From: Alain Durand [mailto:[email-masked]] 
> Sent: Tuesday, September 14, 2010 9:15 PM
> To: Dayong Guo
> Cc: [email-masked]; [email-masked]; 
> Reinaldo Penno; CUI Yong; [email-masked]
> Subject: Re: [pcp] comments about PCP
> 
> Dayong,
> 
> We are now restarting from scratch. We should see a new 
> proposed packet format published very soon and we plan to 
> discuss it during the upcoming interim meeting.
> 
>  - Alain.
> 
>