Subject: Re: [pcp] Fwd: PCP WG creation

From: Lin Tao <[email-masked]>
Date: Fri, 03 Sep 2010 11:48:58 +0800

Congratulations!

I'm studying the port control protocol! I hope I can do something for this working group!

Should these draft be moved to here?

draft-wing-softwire-port-control-protocol
draft-bpw-softwire-pcp-dhcp
draft-bpw-softwire-pcp-flow-examples
draft-bpw-softwire-upnp-pcp-interworking 

Lintao

  ----- Original Message ----- 
  From: Alain Durand 
  To: [email-masked] 
  Cc: Dave Thaler 
  Sent: Tuesday, August 31, 2010 11:42 PM
  Subject: [pcp] Fwd: PCP WG creation

  The creation of the PCP wg just got approved.

  Alain

  Sent from my iPhone

  Begin forwarded message:

  From: Jari Arkko <[email-masked]<mailto:[email-masked]>>
  Date: August 30, 2010 7:55:25 PM GMT+02:00
  To: IESG <[email-masked]<mailto:[email-masked]>>, Alain Durand <[email-masked]<mailto:[email-masked]>>, Dave Thaler <[email-masked]<mailto:[email-masked]>>
  Subject: PCP WG creation

  Secretary (Bcced),

  The IESG approved the creation of the PCP working group. Please send the
  approval announcement, use this charter and set up the chairs appropriately.

  Jari

  Port Control Protocol (pcp)
  ---------------------------------------------
  Status: Approved
  Last updated: 2010-07-27

  Chairs:
    Alain Durand <[email-masked]<mailto:[email-masked]>>
    Dave Thaler <[email-masked]<mailto:[email-masked]>>

  Internet Area Directors:
    Ralph Droms<[email-masked]<mailto:[email-masked]>>
    Jari Arkko<[email-masked]<mailto:[email-masked]>>

  Internet Area Advisor:
    Jari Arkko<[email-masked]<mailto:[email-masked]>>

  Mailing Lists:
    General Discussion: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
    To Subscribe: <https://www.ietf.org/mailman/listinfo/pcp> https://www.ietf.org/mailman/listinfo/pcp
    Archive: <http://www.ietf.org/mail-archive/web/pcp/current/maillist.html> http://www.ietf.org/mail-archive/web/pcp/current/maillist.html

  Description of the working group:

  Middleboxes such as NATs and firewalls have seen significant deployment
  in residential and enterprise networks for years. Applications have
  adapted to such environments. A first family of solutions involves some
  form of static configuration on the middlebox to perform port opening
  and/or port forwarding. Another family of solutions works indirectly,
  using external services to help the establishment of connections and
  work around the NAT. STUN (RFC 5389) and TURN (RFC 5766) are examples of
  such solutions. A third family of solutions include protocols that work
  directly with the  middlebox to dynamically open up ports. Universal
  Plug and Play Internet Gateway Device (UPnP-IGD) and NAT Port Mapping
  Protocol (NAT-PMP) are examples of such solutions.

  IPv4 address exhaustion is now forcing ISPs to deploy carrier-grade NAT
  devices in their network. Those devices could operate either in addition
  to or instead of an existing NAT device. An example of the former case
  is a double NAT configuration and an example of the latter case is the
  application of Dual Stack Lite (DS-Lite) in a network. These deployments
  will break a fundamental assumption made by protocols, such UPnP or
  NAT-PMP, that the NAT is located on the same link as the host running
  the client application. As a result, such applications may break in the
  presence of a carrier grade NAT.

  The PCP working group is chartered to standardize a client/server Port
  Control Protocol (PCP) to enable an explicit dialog with a middlebox
  such as a NAT or a firewall to open up and/or forward TCP or UDP port,
  regardless of the location of that middlebox. A PCP client can be used
  by applications to directly dialog with the middlebox running a PCP
  server. It can also be used by a home gateways on behalf of
  applications. This eases the deployment of PCP in situations where
  applications have already changed to support the APIs necessary for
  communicating with UPnP-IGD or NAT-PMP. Those applications only work
  today when the home gateway gets a public address, but may no longer
  work in situations where the gateway is behind another NAT. Home
  gateways could use PCP to translate and relay those UPnP and NAP-PMP
  messages to the PCP server, thus allowing such applications to continue
  working as they do today.

  The functionality that enables the control of IPv4 middleboxes such as
  NAT devices or firewalls can also be useful in IPv6 context, to control
  IPv6 functionality in firewalls. As such, PCP will be defined for both
  IPv4 and IPv6.

  The discovery PCP servers, using classic methods such as DHCP options,
  is in scope for the PCP working group. The working group will also
  ensure that the protocol has the necessary security mechanisms. The
  IETF will make no changes to either NAT-PMP or UPnP-IGP protocols,
  and they will be used only as is.

  Deliverables:
  - PCP protocol description and terminology document
  - PCP service discovery document
  - PCP relay of UPnP document
  - PCP relay of NAT-PMP document

  Goals&  Milestones
  - Oct 2010 First WG draft on PCP protocol description
  - Dec 2010 First WG draft on PCP service discovery
  - Feb 2011 First WG draft on UPnP relay
  - Feb 2011 First WG draft on NAT-PMP relay
  - May 2011 Send PCP protocol description to IESG for publication as
  Proposed Standard
  - May 2011 Send PCP service discovery to IESG for publication as
  Proposed Standard
  - Oct 2011 Send UPnP relay to IESG for publication as Proposed Standard
  - Oct 2011 Send NAT-PMP relay to IESG for publication as Proposed
  Standard
  _______________________________________________
  pcp mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/pcp

---

From: <[email-masked]>
Date: Fri, 3 Sep 2010 07:20:44 +0200

Dear Lintao,

Yes, these drafts are to be discussed in this WG.

Please if you have any comment, please don't hesitate to share them with us.

Cheers,
Med

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de Lin Tao
Envoyé : vendredi 3 septembre 2010 05:49
À : [email-masked]; Alain Durand
Cc : Dave Thaler
Objet : Re: [pcp] Fwd: PCP WG creation

Congratulations!

Lintao

----- Original Message -----
From: Alain Durand<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Cc: Dave Thaler<mailto:[email-masked]>
Sent: Tuesday, August 31, 2010 11:42 PM
Subject: [pcp] Fwd: PCP WG creation

Alain

Sent from my iPhone

Begin forwarded message:

From: Jari Arkko <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>
Date: August 30, 2010 7:55:25 PM GMT+02:00
To: IESG <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>, Alain Durand <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>, Dave Thaler <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>
Subject: PCP WG creation

Secretary (Bcced),

Jari

Chairs:
  Alain Durand <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>
  Dave Thaler <[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>

Internet Area Directors:
  Ralph Droms<[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>
  Jari Arkko<[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>

Internet Area Advisor:
  Jari Arkko<[email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>>

Mailing Lists:
  General Discussion: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]<mailto:[email-masked]<mailto:[email-masked]>>
  To Subscribe: <https://www.ietf.org/mailman/listinfo/pcp> https://www.ietf.org/mailman/listinfo/pcp
  Archive: <http://www.ietf.org/mail-archive/web/pcp/current/maillist.html> http://www.ietf.org/mail-archive/web/pcp/current/maillist.html

Deliverables:

Goals&  Milestones
[email-masked]<mailto:[email-masked]>

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************