Subject: [pcp] Comments on draft-chen-pcp-discovery-llmnr-00

From: Dave Thaler <[email-masked]>
Date: Sun, 7 Nov 2010 09:12:04 +0000

This document would seem to target two scenarios:

1)      When the PCP server is on the same link as the PCP client, but is not the default gateway, or

2)      When the PCP server is not on the same link, but is reachable via multicast
And requires that an FQDN of the PCP server be available to the client (e.g., via a DHCP option).

Scenario 2 above cannot work with LLMNR because it's defined to be link-local (that's the LL part),
it would have to be a non-link-scoped version of say mDNS.

However, if you can get an FQDN via DHCP or manual configuration or whatever else, then you'd
just resolve it.   Whether it uses DNS, LLMNR, mDNS, hosts file, or whatever else is something that
a typical configuration mechanism wouldn't know.   I think this draft is simply pointing out that
in scenario 1, you don't have to update DNS if all the PCP clients on the link support LLMNR.

-Dave

---

From: "ChenGang" <[email-masked]>
Date: Sun, 7 Nov 2010 23:53:19 +0800

Thanks for the comments.

Reply inline.

  _____  

From: Dave Thaler [mailto:[email-masked]] 
Sent: Sunday, November 07, 2010 5:12 PM
To: [email-masked]; [email-masked]
Subject: Comments on draft-chen-pcp-discovery-llmnr-00

1)      When the PCP server is on the same link as the PCP client, but is
not the default gateway, or

2)      When the PCP server is not on the same link, but is reachable via
multicast

And requires that an FQDN of the PCP server be available to the client
(e.g., via a DHCP option).

Scenario 2 above cannot work with LLMNR because it's defined to be
link-local (that's the LL part),

[Gang]  Non-link-scoped version of mDNS is necessary. BTW, LLMNR is
desirable to consider expand multi-cast

scope beyond link-local depending on the specific deployment experiences and
service demands.

However, if you can get an FQDN via DHCP or manual configuration or whatever
else, then you'd

just resolve it.   Whether it uses DNS, LLMNR, mDNS, hosts file, or whatever
else is something that

a typical configuration mechanism wouldn't know.   I think this draft is
simply pointing out that

in scenario 1, you don't have to update DNS if all the PCP clients on the
link support LLMNR.

[Gang] Yes. That is the benefit. 

-Dave