Subject: [pcp] Pinhole lifetime (was RE: draft-wing-pcp-base-01 posted)

From: <[email-masked]>
Date: Wed, 3 Nov 2010 09:29:32 +0100

Hi Dan, all,

(I'm concerned with the CGN case)

In order to avoid having longer lifetime and encourage applications to request for a reasonable lifetime value, I propose the Lifetime field to be encoded in 16 bits (i.e., the maximum allowed value would be 18 hours) instead of 32 bits. 

IMHO, limiting the maximum lifetime value by design is more efficient than having a configuration recommendation in the I-D.

Moreover, with shortened maximum lifetime stale entries will last at maximum 18 hours in any case (whatever the config of the PCP Server, requested value by the PCP Client) and unwanted mappings (if any) won't last for ever (lifetime of 32 bits), etc.

Opinions?

Cheers,
Med
*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Francis Dupont <[email-masked]>
Date: Wed, 03 Nov 2010 15:42:45 +0100

In your previous mail you wrote:

   In order to avoid having longer lifetime and encourage applications
   to request for a reasonable lifetime value, I propose the Lifetime
   field to be encoded in 16 bits (i.e., the maximum allowed value
   would be 18 hours) instead of 32 bits.
   
=> note in UPnP IGD 2.0 the maximum lifetime is one week and
unlimited lifetime of version 1.0 is remapped to this maximum.
(this means nothing strong about the PCP maximum lifetime as
the IWF can simulate any lifetime with renewals)

   IMHO, limiting the maximum lifetime value by design is more
   efficient than having a configuration recommendation in the I-D.
   
=> this closes the door, i.e., there are strong pros and cons.

   Moreover, with shortened maximum lifetime stale entries will last
   at maximum 18 hours in any case (whatever the config of the PCP
   Server, requested value by the PCP Client) and unwanted mappings
   (if any) won't last for ever (lifetime of 32 bits) , etc.
   
=> this is a drastic way to solve the stale PF issue.

Regards

[email-masked]

---

From: <[email-masked]>
Date: Wed, 3 Nov 2010 17:21:14 +0100

Hi Francis,

Please see inline.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 3 novembre 2010 15:43
À : BOUCADAIR Mohamed NCPI/NAD/TIP
Cc : Dan Wing; [email-masked]
Objet : Re: [pcp] Pinhole lifetime (was RE: draft-wing-pcp-base-01 posted) 

   

Med: I know. In first versions of PCP I wanted to have something like "unlimited lifetime", but I changed my mind since then. I think we need to avoid having longer validity PCP timers in the CGN to ease cleaning stale entries for instance.

Med: Aside reducing the load on the CGN induce by refreshing mappings (which I don't think it would be significant), what are other cons?

Med: Yes, indeed ;-)

---

From: Francis Dupont <[email-masked]>
Date: Wed, 03 Nov 2010 18:02:03 +0100

Med: Aside reducing the load on the CGN induce by refreshing
   mappings (which I don't think it would be significant), what are
   other cons?
   
=> it is more a pro than a con. IMHO the main issue is we need to go back
to a maximum larger than one day, for instance for operational reasons,
it will be hard.

Regards

PS: I think it is too soon to take this kind of decisions.

---

From: <[email-masked]>
Date: Thu, 4 Nov 2010 10:20:04 +0100

Hi Francis,

I'm sure you have an idea about those operational reasons you are referring to. Can you please elaborate on this further? (We can discuss it offline if you want)

Thanks in advance.

Cheers,
Med