Subject: [pcp] blocking issue: PCP UDP port

From: Francis Dupont <[email-masked]>
Date: Fri, 17 Dec 2010 14:50:22 +0100

I've just finished to read the last pcp-base-01 I-D: we have a major
implementation issue about the PCP UDP port. In previous versions
the NAT-PMP port was overloaded but there are some concerns about
this idea so either:
 - there is no decision about this point
 - or the decision is to get another port in a (far) future.
The result is today the whole thing is not implementable at all?!
(what I'll do during Christmas? :-)

I suggest we fix this ASAP.
I vote for the overloading for these reasons:
 - I have the concrete proof it works well
 - this is no need to wait for an IANA action
 - the only issue (what to answer to a version 0 request) is
  marginal and Stuart should be able to confirm if a 4 byte
  error 1 response is correct.

Regards

[email-masked]

---

From: <[email-masked]>
Date: Fri, 17 Dec 2010 15:00:10 +0100

Hi Francis,

If I'm not mistaken, I think we have discussed this point during the first PCP interim meeting where it seems to me we agreed to not use the NAT-PMP port because this would avoid PCP to manage backward compatibility with NAT-PMP. BTW, I tried to find the minutes of the first interim meeting, but I failed.

FWIW, we have already this discussion in this thread: http://www.ietf.org/mail-archive/web/pcp/current/msg00173.html

What prevents the WG to ask IANA for a PCP port right now and not wait to have the PCP RFC published?

Cheers,
Med 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Francis Dupont
Envoyé : vendredi 17 décembre 2010 14:50
À : [email-masked]
Objet : [pcp] blocking issue: PCP UDP port

Regards

[email-masked]
_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Francis Dupont <[email-masked]>
Date: Fri, 17 Dec 2010 15:48:27 +0100

In your previous mail you wrote:

   What prevents the WG to ask IANA for a PCP port right now and not
   wait to have the PCP RFC published?
   
=> nothing but what I suggest is to minimize delays in all cases
so I am in favor of ways I know to be fast...

Regards

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 20 Dec 2010 12:52:38 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Francis Dupont
> Sent: Friday, December 17, 2010 5:50 AM
> To: [email-masked]
> Subject: [pcp] blocking issue: PCP UDP port
> 

One of the few changes between draft-wing-pcp-base and draft-ietf-pcp-base
was moving PCP to its own port number and removal of "NAT-PMP Backwards
Compatibility",
http://tools.ietf.org/rfcdiff/?url1=http://tools.ietf.org/id/draft-wing-pcp-
base-01.txt&url2=http://tools.ietf.org/id/draft-ietf-pcp-base-00.txt
because there seemed to be no value in using the same port.

In draft-ietf-pcp-base-01, I realized it was still using version=1,
so changed it to version=0.  I expect that is what you noticed.

> I suggest we fix this ASAP.

Chairs, I don't know if we can make an IANA request now that there
is a WG document?

-d

---

From: Francis Dupont <[email-masked]>
Date: Mon, 20 Dec 2010 22:34:54 +0100

One of the few changes between draft-wing-pcp-base and draft-ietf-pcp-base
   was moving PCP to its own port number

=> s/own/unkown/ (:-)

=> it was not changed everywhere BTW.

=> we can put a number in the list and the next version
(with some magic/help from IANA, it could be the number allocated
to PCP in the RFC).

Regards