Subject: [pcp] discuss: PCP mappings same public IP address as dynamic mappings

From: "Dan Wing" <[email-masked]>
Date: Tue, 7 Dec 2010 11:18:30 -0800

This is one of the PCP discussion points.

Currently, BEHAVE has a requirement in draft-ietf-behave-lsn that dynamic
connections are all mapped to the same public IP address:

   REQ-1: A LSN MUST allocate one external IP address to each CPE.

      a) LSN external IP address allocated to the CPE MUST be same for
      the UDP, TCP and ICMP.

   Justification: If a LSN allocates multiple LSN external IP addresses
   to each CPE, some applications might not work.

However, is there a requirement that a PCP server create mappings on the
same public IP address as dynamic mappings?   The answer to this question
relies, partially, on how applications might use dynamic connections in
conjunction with PCP (see "discuss: using PCP to reduce application-level
keepalive traffic") -- if the PCP request is done first it could be on a
different IP address than dynamic connections.  

I cannot think of a protocol, or scenario, that would *need* the
PCP-allocated public IP address to be the same as the IP address used for
dynamic connections (e.g., TCP SYN).  So I am tempted to say that the IP
addresses can be different.

The advantage of different addresses is it provides more flexibility to NAT
implementations and to ISPs that might want to separate dynamic connections
from PCP-allocated connections (AS MERELY ONE EXAMPLE, the ISP might provide
high availability to PCP-allocated connections but not provide high
availability to dynamically-created connections).

-d

---

From: Lars Eggert <[email-masked]>
Date: Wed, 8 Dec 2010 12:25:16 +0200

Hi,

> connections are all mapped to the same public IP address:

if we have BEHAVE consensus for this, PCP should follow it. If we have a strong reason for doing something different, that reason should be enough to change the consensus in BEHAVE.

Lars

---

From: <[email-masked]>
Date: Wed, 8 Dec 2010 13:15:18 +0100

Re-,

I would recommend the default behaviour to be: the same IP address to be used for all NAT mappings, bound to the same customer, instantiated in a NAT whatever how the mapping has been instantiated (dynamic, static, PCP-instructed, etc.). This can be relaxed by configuration if there is no available port for instance, etc. Relaxing this constraint should be a configurable option in a CGN. In our case, we have considered other scenarios to relax the use of the same external IP address such as DNS queries. 

For HA purposes, PCP-instructed entries or static mappings should be tagged accordingly: i.e., adding a field to the mapping table to show whether the entry is dynamic/static/PCP-instructed/etc. This can be implementation specific.

Cheers,
Med

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Dan Wing
Envoyé : mardi 7 décembre 2010 20:19
À : [email-masked]
Objet : [pcp] discuss: PCP mappings same public IP address as dynamic mappings

-d

_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Francis Dupont <[email-masked]>
Date: Wed, 08 Dec 2010 16:58:06 +0100

I am not against the idea to make this requirement external to PCP,
i.e., to rely on requirements (or no requirements) about the NAT
function itself...

Regards

[email-masked]

PS: so I suggest to explicitely say nothing about this, i.e., only
requires the PCP mappings using the same external IP address.
PPS: BTW for AFTR the softwire document requires to use the same external
IP address for all mappings.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 8 Dec 2010 09:36:46 -0800

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, December 08, 2010 4:15 AM
> To: Dan Wing; [email-masked]
> Subject: RE: [pcp] discuss: PCP mappings same public IP address as
> dynamic mappings
> 
> Re-,
> 
> I would recommend the default behaviour to be: the same IP address to
> be used for all NAT mappings, bound to the same customer, instantiated
> in a NAT whatever how the mapping has been instantiated (dynamic,
> static, PCP-instructed, etc.). This can be relaxed by configuration if
> there is no available port for instance, etc.

But allowing such variance in a standards-track protocol causes grief
to implementers who can't rely on specific behavior, and to troubleshooting
because the behavior changes depending on port utilization.

> Relaxing this constraint
> should be a configurable option in a CGN. In our case, we have
> considered other scenarios to relax the use of the same external IP
> address such as DNS queries.

Probably a good idea to get those ideas discussed in BEHAVE as part
of draft-ietf-behave-lsn-requirements.

> For HA purposes, PCP-instructed entries or static mappings should be
> tagged accordingly: i.e., adding a field to the mapping table to show
> whether the entry is dynamic/static/PCP-instructed/etc. This can be
> implementation specific.

Yes, that is an implementation detail.

-d

---

From: Tina Tsou <[email-masked]>
Date: Thu, 09 Dec 2010 11:04:04 -0800

I tend to agree with Dan, to modify the requirements of LSN, not limiting the LSN only allocate one external IP to one CPE. This makes the protocol more flexible.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dan Wing
Sent: Wednesday, December 08, 2010 9:37 AM
To: [email-masked]; [email-masked]
Subject: Re: [pcp] discuss: PCP mappings same public IP address as dynamic mappings

-d