Subject: [pcp] PCP interop

From: Paul Selkirk <[email-masked]>
Date: Wed, 27 Jul 2011 21:25:51 +0000

When we got to Quebec, we had only been planning a very simple PCP demo -
our client, our server, and our IWF. But there was the Huawei/France
Telecom group, with all of their kit. And it turns out we both implement
draft-12 over DS-Lite, so we're using the same packet format in the same
environment. Hmm...

Today we used our client to request mappings from their server. We did
this with both a simple command-line client and with a modified torrent
client.

Testing was limited to MAP4, with and without PREFER_FAILURE.
They don't seem to support FILTER, we don't support things like
draft-tsou-pcp-natcoord-03, neither support the DHCP option, etc.
But the core functionality works.

				for rough consensus and running code,
				paul

---

From: Tina TSOU <[email-masked]>
Date: Wed, 27 Jul 2011 21:38:34 +0000

Paul,
Thanks for the message.
We do support FILTER at PCP Server.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Selkirk
Sent: Wednesday, July 27, 2011 5:26 PM
To: [email-masked]
Subject: [pcp] PCP interop

				for rough consensus and running code,
				paul
_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

---

From: Paul Selkirk <[email-masked]>
Date: Wed, 27 Jul 2011 21:44:38 +0000

> We do support FILTER at PCP Server.

Sorry, my bad. It was a quick test on the way out the door to BEHAVE,
and we didn't spend any time to debug it.

				paul

---

From: Alain Durand <[email-masked]>
Date: Wed, 27 Jul 2011 15:01:13 -0700

This is GREAT! During the PCP meeting, when I introduced the demo, I asked for an interop session next IETF, you guys have delivered 4 months early!
Congratulations!

   -Alain.

---

From: Francis Dupont <[email-masked]>
Date: Thu, 28 Jul 2011 00:04:38 +0200

In your previous mail you wrote:

=> for an unknown reason (*) the PCP Server returned 5 "malformed option"
when I tried... I got PREFER_FAILURE in responses too (**).
What we should note is the important things worked well.

Regards

[email-masked]

PS: (*) IMHO we should not waste time to investigate: draft 12 was
upgraded by draft 13 which itself was phased out Yesterday so anyway
both codes we experimented are obsolete for more than one version.
PPS: (**) looking at the draft 12 it is not consistent, draft 13 was
fixed and says no. I remember to have changed it for draft 13 and
backported to the draft 12 support as any thing which was wrong in
12 but fixed in 13.

---

From: Tina TSOU <[email-masked]>
Date: Thu, 28 Jul 2011 14:08:32 +0000

Our pleasure, your majesty.
Francis and I suggest having the DHCP code point soon, then people can interop for that.

Best Regards,
Tina TSOU

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alain Durand
Sent: Wednesday, July 27, 2011 6:01 PM
To: Paul Selkirk
Cc: [email-masked]
Subject: Re: [pcp] PCP interop

   -Alain.

---

From: Francis Dupont <[email-masked]>
Date: Thu, 28 Jul 2011 16:34:44 +0200

Francis and I suggest having the DHCP code point soon, then people
   can interop for that.
   
=> in fact IMHO the DHC WG is the right place to get the code point,
I am presently at the DHC WG session so if there are some free time
at the end I'll ask directly at the micro.

Thanks

PS: for DHCPv6 options are registered by IANA and the registry is noted:
Expert Review and Standards Action (section 24.3).
Some lines upper I can read "IETF Consensus" for BOOTP and DHCP options.
So it seems the best is to publish and last called the DHCP spec ASAP.

---

From: Alain Durand <[email-masked]>
Date: Thu, 28 Jul 2011 08:52:44 -0700

On Jul 28, 2011, at 10:11 AM, "Tina TSOU" <[email-masked]<mailto:[email-masked]>> wrote:

We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

---

From: Tina TSOU <[email-masked]>
Date: Thu, 28 Jul 2011 18:02:42 +0000

This Demo shows the running code and rough consensus.

Best Regards,
Tina TSOU

---

From: <[email-masked]>
Date: Fri, 29 Jul 2011 05:09:32 +0800

In case  a story between rough consensus and interop sounds fun:

Francis and I have had a conversation before Quebec meeting about
whether putting IPv6 or IPv4 source  
address in the common header, and that time being Francis thought it
should be IPv4 while Paul  
thought IPv6.  After that, Francis, finally, changed one line of code
because our implementation  
agreed with Paul, which make the two implementations interop. 

Well, rough consensus, indeed, makes things happen! ;-) 

Xiaohong

|-----Original Message-----
|From: Alain Durand [mailto:[email-masked]] 
|Sent: Thursday, July 28, 2011 6:01 AM
|To: Paul Selkirk
|Cc: [email-masked]
|Subject: Re: [pcp] PCP interop
|
|This is GREAT! During the PCP meeting, when I introduced the 
|demo, I asked for an interop session next IETF, you guys have 
|delivered 4 months early!
|Congratulations!
|
|   -Alain.
|
|
|
|On Jul 27, 2011, at 5:25 PM, Paul Selkirk wrote:
|
|> When we got to Quebec, we had only been planning a very simple PCP 
|> demo - our client, our server, and our IWF. But there was the 
|> Huawei/France Telecom group, with all of their kit. And it turns out 
|> we both implement
|> draft-12 over DS-Lite, so we're using the same packet format in the 
|> same environment. Hmm...
|> 
|> Today we used our client to request mappings from their 
|server. We did 
|> this with both a simple command-line client and with a modified 
|> torrent client.
|> 
|> Testing was limited to MAP4, with and without PREFER_FAILURE.
|> They don't seem to support FILTER, we don't support things like 
|> draft-tsou-pcp-natcoord-03, neither support the DHCP option, etc.
|> But the core functionality works.
|> 
|> 				for rough consensus and running code,
|> 				paul
|> _______________________________________________
|> pcp mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/pcp
|
|
|

---

From: "Lee, Yiu" <[email-masked]>
Date: Sun, 31 Jul 2011 01:27:03 +0000

Congrats and well done!