Subject: Re: [pcp] WG last call on draft-ietf-pcp-base-13

From: Tina Zouting <[email-masked]>
Date: Fri, 22 Jul 2011 03:32:12 +0000

Hi,
It seems that http://trac.tools.ietf.org/wg/pcp/trac/ticket/24, "PCP mappings same public IP address as dynamic mappings" is not reflected in the latest version.
Sorry for the late feedback.

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alain Durand
Sent: Wednesday, July 06, 2011 8:34 PM
To: [email-masked]
Subject: [pcp] WG last call on draft-ietf-pcp-base-13

draft-ietf-pcp-base-13 has been published to address the comments received during wg last call on the -12 revision. We would like to start a 1-week working group last call on this new revision.

The PCP wg chairs, Alain & Dave.

Sent from my iPad

On Jul 5, 2011, at 11:19 PM, "Dan Wing" <[email-masked]> wrote:

> draft-ietf-pcp-base-13 was just posted.  Changes are in
> http://tools.ietf.org/html/draft-ietf-pcp-base-13#appendix-B.1, and copied
> below.
> 
> Side-by-side diffs between -12 and -13 are at:
> http://tools.ietf.org/rfcdiff?url2=draft-ietf-pcp-base-13.txt
> 
> This should resolve all comments from -12's WGLC.
> 
> -d
> 
>   o  All addresses are 128 bits.  IPv4 addresses are represented by
>      IPv4-mapped IPv6 addresses (::FFFF/96)
> 
>   o  PCP request header now includes PCP client's port (in addition to
>      the client's IP address, which was in -12).
> 
>   o  new ADDRESS_MISMATCH error.
> 
>   o  removed PROCESSING_ERROR error, which was too similar to
>      MALFORMED_REQUEST.
> 
>   o  Tweaked text describing how PCP client deals with multiple PCP
>      server addresses (Section 6.1)
> 
>   o  clarified that when overloaded, the server can send
>      SERVER_OVERLOADED (and drop requests) or simply drop requests.
> 
>   o  Clarified how PCP client chooses MAP4 or MAP6, depending on the
>      presence of its own IPv6 or IPv4 interfaces (Section 7).
> 
>   o  compliant PCP server MUST support MAPx and PEERx, SHOULD support
>      ability to disable support.
> 
>   o  clarified that MAP-created mappings have no filtering, and PEER-
>      created mappings have whatever filtering and mapping behavior is
>      normal for that particular NAT / firewall.
> 
>   o  Integrated WGLC feedback (small changes to abstract, definitions,
>      and small edits throughout the document)
> 
>   o  allow new Options to be defined with a specification (rather than
>      standards action)
> 
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp
_______________________________________________
pcp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcp

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 22 Jul 2011 14:01:09 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tina Zouting
> Sent: Thursday, July 21, 2011 8:32 PM
> To: [email-masked]
> Subject: Re: [pcp] WG last call on draft-ietf-pcp-base-13
> 
> Hi,
> It seems that http://trac.tools.ietf.org/wg/pcp/trac/ticket/24, "PCP
> mappings same public IP address as dynamic mappings" is not reflected
> in the latest version.

I am not online at the moment, so I can't read ticket #24.

Section 7 says:
   It is REQUIRED that the PCP-controlled device assign the same
   external IP address to PCP-created explicit dynamic mappings and to
   implicit dynamic mappings for a given Internal Host.  

Is that ok?

-d

> draft-ietf-pcp-base-13 has been published to address the comments
> received during wg last call on the -12 revision. We would like to
> start a 1-week working group last call on this new revision.
>

---

From: Tina TSOU <[email-masked]>
Date: Tue, 26 Jul 2011 13:55:16 +0000

Dan,
Thanks.
It is what we agreed on the texts in the mailing list before:
"If there is already an active explicit dynamic mapping,
  it will be mapped to a certain external IP address.
  When the PCP client makes another explicit dynamic mapping,
  it SHOULD place the external IP address of the existing
  mapping into the Requested External Address of the MAP
  request.  By doing this, all of the PCP client's explicit
  dynamic mappings will be on the same external address."

We should specify the action of the PCP client.

Best Regards,
Tina TSOU

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Friday, July 22, 2011 5:01 PM
To: Tina TSOU; [email-masked]
Subject: RE: [pcp] WG last call on draft-ietf-pcp-base-13

Section 7 says:

Is that ok?

-d

> Alain Durand

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 26 Jul 2011 10:07:39 -0400

> From: Tina TSOU [mailto:[email-masked]]
> Sent: Tuesday, July 26, 2011 9:55 AM
> To: Dan Wing; [email-masked]

That's saying something different -- that is saying that
all PCP-created explicit dynamic mappings have to be on
the same external address.

I added a second sentence, so it now reads:

      It is REQUIRED that the PCP-controlled device assign the same
      external IP address to PCP-created explicit dynamic mappings and
      to implicit dynamic mappings for a given Internal Host.  It is
...............................................................^^^^^
      also REQUIRED that PCP-created explicit dynamic mappings be
......^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      assigned the same external IP address.
......^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

-d

---

From: Tina TSOU <[email-masked]>
Date: Tue, 26 Jul 2011 14:21:02 +0000

Dan,
It is OK.

Best Regards,
Tina TSOU

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: Tuesday, July 26, 2011 10:08 AM
To: Tina TSOU; [email-masked]
Subject: RE: [pcp] WG last call on draft-ietf-pcp-base-13

-d

---

From: Reinaldo Penno <[email-masked]>
Date: Wed, 27 Jul 2011 01:52:03 -0400

I actually disagree with this requirement. I would like to see it relaxed
since for various reasons a client might actually wants certain explicit
mappings bound to different public Ips.

The reasons are discussed in:

http://tools.ietf.org/html/draft-penno-pcp-zones-00

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 27 Jul 2011 09:24:33 -0400

> From: Reinaldo Penno [mailto:[email-masked]]
> Sent: Wednesday, July 27, 2011 1:52 AM
> To: Dan Wing; 'Tina TSOU'; [email-masked]

Then how about:

   In the
   absence of a PCP option indicating otherwise, it is 
   REQUIRED that PCP-created explicit dynamic mappings be assigned
   the same external IP address

-d

> to
> >>>> http://tools.ietf.org/html/draft-ietf-pcp-base-13#appendix-B.1,
> and
> >>> copied
> >>>> below.
> >>>>
> >>>>   o  PCP request header now includes PCP client's port (in
> addition
> >>> to

---

From: Reinaldo Penno <[email-masked]>
Date: Wed, 27 Jul 2011 11:07:50 -0400

Looks good.

---

From: Tina TSOU <[email-masked]>
Date: Thu, 28 Jul 2011 10:51:52 +0000

Reinaldo, Dan et al,
How about
"In the absence of a PCP option indicating otherwise, it is
   REQUIRED that PCP-created explicit dynamic mappings be assigned
   the same external IP address with the existing dynamic mappings. PCP client will put external IP address of the existing mapping into the Requested External Address of the MAP request."

Best Regards,
Tina TSOU

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Wednesday, July 27, 2011 11:08 AM
To: Dan Wing; Tina TSOU; [email-masked]
Subject: Re: [pcp] WG last call on draft-ietf-pcp-base-13

Looks good.

---

From: Reinaldo Penno <[email-masked]>
Date: Thu, 28 Jul 2011 07:12:53 -0400

The last sentence you added seem disconnected from the others giving the
idea that it is an additional requirement that should be always enforced,
whether there is an option or not.

On 7/28/11 3:51 AM, "Tina TSOU" <[email-masked]> wrote:

>    the same external IP address with the existing dynamic mappings. PCP client
> will put external IP address of the existing mapping into the Requested
> External Address of the MAP request."
> 
> 
> 
> Best Regards,
> Tina TSOU

---

From: Francis Dupont <[email-masked]>
Date: Thu, 28 Jul 2011 15:38:25 +0200

In your previous mail you wrote:

  Address of the MAP request."
                     ^^^^^^^ => response   
   
Regards

[email-masked]

PS: BTW if I agree about this external address "stability", and even
would like to get stricter one (both for all mapping kinds and across
CGN reboots), this clearly belongs to the BEHAVE CGN requirements
(so I agree the text in the base specs is fine and should not follow
my wish :-).

---

From: Tina TSOU <[email-masked]>
Date: Fri, 29 Jul 2011 19:24:31 +0000

Reinaldo,
The last sentence is the supplement of "it is REQUIRED that PCP-created explicit dynamic mappings be assigned the same external IP address with the existing dynamic mappings."

Best Regards,
Tina TSOU