Subject: Re: [pcp] pcp-base-29

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Wed, 7 Nov 2012 20:21:28 +0000

I'm not sure how can we conclude from this text that the nonce is relaxed
for Advanced.

Couldn't one argue that since the "If.." precedes Internal address, that
means that internal address does need to match in advanced thread model?

I suggest we just add explicit text about this case if WG agrees.

On 11/7/12 3:02 PM, "Dave Thaler" <[email-masked]> wrote:

>The nonce is only used in the basic model.
>In the advanced model, the nonce value is ignored.
>
>This was made clear in a recent change on page 46:
>> If operating in the Simple Threat Model (Section 18.1), and the
>> Internal port, Protocol, and Internal Address match an existing
>> explicit dynamic mapping, but the Mapping Nonce does not match, the
>
>That is, the "If..." condition precedes the check for nonce match.
>
>-Dave
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Reinaldo Penno (repenno)
>> Sent: Wednesday, November 7, 2012 2:23 PM
>> To: Sam Hartman
>> Cc: [email-masked]
>> Subject: Re: [pcp] pcp-base-29
>> 
>> 
>> 
>> On 11/7/12 2:20 PM, "Sam Hartman" <[email-masked]>
>> wrote:
>> 
>> >>>>>> "Reinaldo" == Reinaldo Penno (repenno) <[email-masked]>
>> writes:
>> >
>> >    Reinaldo> Hello Sam, The scenario as written in -28 is the
>> >    Reinaldo> following:
>> >
>> >    Reinaldo> - end hosts gets a new address when joins the network and
>> >    Reinaldo> want to clear old mappings associated with this address.
>> >
>> >Sure. Two ways:
>> >
>> >1) it's an authenticated request it uses to do that.
>> 
>> The nonce and IP addresses would not match, can these checks be relaxed?
>> 
>> >
>> >2)  The server implements authentication and thus falls under the
>> >advanced threat model. Its policy permits an unauthenticated flush
>> >request.
>> 
>> 
>> See above.
>> 
>> >
>> >--Sam
>> 
>> _______________________________________________
>> pcp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pcp

---

From: Sam Hartman <[email-masked]>
Date: Wed, 07 Nov 2012 16:50:08 -0500

>>>>> "Dave" == Dave Thaler <[email-masked]> writes:

    Dave> The draft says nothing about what the rule is under the
    Dave> advanced model.  I think we said that could be specified in
    Dave> the pcp-auth spec eventually, since we might not know enough
    Dave> now to know exactly what the right rule is under that model
    Dave> until we know all the security properties of the solution.

My personal hope is that gets left to the implementation.