Subject: [pcp] I-D Action: draft-ietf-pcp-proxy-04.txt

From: [email-masked]
Date: Sun, 28 Jul 2013 23:12:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Port Control Protocol Working Group of the IETF.

	Title           : Port Control Protocol (PCP) Proxy Function
	Author(s)       : Mohamed Boucadair
                          Reinaldo Penno
                          Dan Wing
	Filename        : draft-ietf-pcp-proxy-04.txt
	Pages           : 11
	Date            : 2013-07-28

Abstract:
   This document specifies a new PCP functional element denoted as a PCP
   Proxy.  The PCP Proxy relays PCP requests received from PCP clients
   to upstream PCP server(s).  A typical deployment usage of this
   function is to help establish successful PCP communications for PCP
   clients that can not be configured with the address of a PCP server
   located more than one hop away.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pcp-proxy

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-pcp-proxy-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-pcp-proxy-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Mon, 29 Jul 2013 08:25:17 +0200

Dear all,

The main changes in the new version are:

* Add explicit text about configuring which interface(s) the PCP Proxy will act on as a PCP Server
* Explicit the PCP error code to be returned
* Explicit the ICMP error code to be returned when an error on the UDP socket is experienced
* The PCP Proxy is now in charge to enforce the message size limit instead of relaying the message to the ultimate server
* If the PCP Proxy processing (e.g., adding a THIRD_PARTY Option) makes a request that exceeds 1100 octets, a MALFORMED_REQUEST response is sent to the PCP client
* Update the security considerations section with some text about THIRD_PARTY

To check the detailed modifs, a diff is available at: http://www.ietf.org/rfcdiff?url2=draft-ietf-pcp-proxy-04 

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De la part de
>[email-masked]
>Envoyé : lundi 29 juillet 2013 08:12
>À : [email-masked]
>Cc : [email-masked]
>Objet : [pcp] I-D Action: draft-ietf-pcp-proxy-04.txt
>
>
>_______________________________________________
>pcp mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pcp