Subject: Re: [pcp] Comments on draft-ietf-pcp-nat64-prefix64-02

From: Dave Thaler <[email-masked]>
Date: Tue, 30 Jul 2013 10:24:46 +0000

I reviewed -03 and am happy with everything (there's a couple grammar nits in new text
I will send separately, but very minor) except one of my comments was not
addressed where the text in section 4.2 contradicts itself:

> Upon receipt of the message from the PCP server, the PCP client

> replaces any old prefix(es)/suffix(es) received from the same PCP

> server with the new one(s) included in the PREFIX64 option(s).
And

> Upon receipt of this message, the PCP client

> replaces the old prefix/suffix received from the same PCP server with

> the new Pref64::/n and suffix included in the PREFIX64 option.

Both imply that a client MUST remember which PCP server they were received from,
since otherwise it could not possibly do what is stated.

However, it also says:

> The PCP client SHOULD associate each

> received Pref64::/n and suffix with the PCP server from which the
> Pref64::/n and suffix information was retrieved.

Above says it's only a SHOULD and hence contradicts the other two paragraphs.
Changing the SHOULD to a MUST is the simplest fix.

-Dave

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 4, 2013 4:45 PM
To: Dave Thaler
Cc: [email-masked]
Subject: RE: Comments on draft-ietf-pcp-nat64-prefix64-02

Hi Dave,

Thank you for the review.
I accepted most of your proposed modifications.

Cheers,
Med

De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] De la part de Dave Thaler
Envoyé : samedi 1 juin 2013 02:34
À : [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Objet : [pcp] Comments on draft-ietf-pcp-nat64-prefix64-02

Looks pretty good.  My marked up copy is at
http://research.microsoft.com/~dthaler/draft-ietf-pcp-nat64-prefix64-02.pdf
(or for those who can use .docx:
http://research.microsoft.com/~dthaler/draft-ietf-pcp-nat64-prefix64-02.docx).

Summary:

1)      Text appears contradictory as to whether remembering which server a Pref64

was from is required or just a SHOULD. My preference is to change the SHOULD

to a MUST, and then the rest of the text is fine.

2)      Add reference to draft-ietf-behave-nat64-discovery-heuristic and explain what

cases this handles that the simple heuristic cannot.

3)      Steal a few phrases from draft-ietf-behave-nat64-discovery-heuristic that are

applicable here too.

4)      Various grammatical corrections/suggestions.

-Dave

---

From: <[email-masked]>
Date: Tue, 30 Jul 2013 14:02:50 +0200

Hi Dave,

Thanks for catching this. I agree with the fix.

Cheers,
Med

De : Dave Thaler [mailto:[email-masked]]
Envoyé : mardi 30 juillet 2013 12:25
À : BOUCADAIR Mohamed OLNC/OLN
Cc : [email-masked]
Objet : RE: Comments on draft-ietf-pcp-nat64-prefix64-02

And

-Dave

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, June 4, 2013 4:45 PM
To: Dave Thaler
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Comments on draft-ietf-pcp-nat64-prefix64-02

Hi Dave,

Cheers,
Med

Summary:

applicable here too.

-Dave