Subject: [pcp] [Softwires] Fwd: New Version Notification for draft-perreault-softwire-lw4over6-pcp-00.txt

From: Qiong <[email-masked]>
Date: Wed, 3 Jul 2013 06:26:44 +0800

Dear Simon,

On Thursday, June 6, 2013, Simon Perreault <[email-masked]>
wrote:
> Le 2013-06-06 11:07, Qiong a écrit :
>>
>>     The hash computation can be updated to rely on IP-based information,
>>     no port numbers would be needed.
>>
>> [Qiong] That will cost a lot, especially when lwAFTR is deployed in more
>> a centralized way that a lot of routers along the path all need to be
>> updated.
>
> I think this is a core issue that needs discussion.
>
> Qiong, are you referring to ECMP?

Right, exactly. Currently, different vendors, even different versions are
implementing in a different way.

Best wishes
Qiong
> Simon

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/ *
===============================================

---

From: Qiong <[email-masked]>
Date: Wed, 3 Jul 2013 12:10:16 +0800

Dear Med,

Sorry for so late reply...just find I have missed it.

Some comments inline.

On Fri, Jun 7, 2013 at 8:39 PM, <[email-masked]> wrote:

> Please see inline.
>
> >-----Message d'origine-----
> >De : [email-masked] [mailto:[email-masked]]
> >Envoyé : jeudi 6 juin 2013 15:27
> >À : Simon Perreault
> >Cc : BOUCADAIR Mohamed OLNC/OLN; [email-masked]
> >Objet : Re: [pcp] Fwd: New Version Notification for draft-perreault-
> >softwire-lw4over6-pcp-00.txt
> >
> >Hi Simon,
> >
> >On 2013-6-6, at 17:41, Simon Perreault <[email-masked]>
> wrote:
> >
> [Med] .. but isn't L3-based ECMP LB needed for lw4over6 to work in your
> case?
>
[Qiong] right. But different vendors (even different versions) have
different default configurations on L3 or L4-based ECMP LB.
For example, the default configuration of NE5000e with version V3 is using
L3 ECMP while V8 100G is using L4 ECMP.
So if there are a lot of existing routers along the path, we need to check
whether the current configuration is L3-based ECMP or L4-based. That will
introduce a lot of work.
The encapsulation mode will get rid of all these work and the intermediate
routers have to use L3-base ECMP even configured with L4-based ECMP.

> >[Qiong] Right, exactly. Currently, our routers from different vendors even
> >with different versions may implement ECMP differently.
> [Med] Can you please point out an industrial product which supports
> L4-based ECMP LB and not L3-based one?
>
[Qiong] see above

Thanks a lot!

Best wishes
Qiong