Subject: Re: [pcp] Comments on draft-ietf-pcp-optimize-keepalives-00

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 2 Dec 2013 09:55:42 +0000

Hi Reinaldo,

Responding to your comments in the pdf

Comment1> The application keepalive would keep the state alive in the FW/NAT as well, right ? This sentence seems out of place here.

Reply1> No. The time interval to send keepalives for maintaining state on the Application Server could be greater than FW/NAT mapping lifetime. In this case application keepalives will not maintain the FW/NAT mappings. For example in case where application keepalive interval every 60 minutes is required whereas FW/NAT keepalive interval is 30 minutes.

Comment2>  I believe this section should have an introduction and two sub-sections. One subsection should be called "PCP based detection" and have the first paragraph part of it since it only talks about PCP based detection. The second subsection should talk about application based detection.

Reply2> Agreed, updated the draft.

Comment3> Then the title of this section needs to change to "NAT Topologies and Detection"

Reply3> Yes, changed the title.

Comment4> Suggest to change title to "Detection of..". But more generally, I wonder if this discussion of detection belongs in this draft. Can this  section be removed ?

Reply4> Yes, changed the title. In the previous WG discussions there was specific ask to add this section explaining the "Detection of PCP Unaware Firewalls".

Comment5> Needs RFC reference
Reply4> RFC reference is already provided

Comment 6>It will insert if it supports this experimental RFC, if it has another IP address, etc. I believe some more clarification is needed.
Reply6> Agreed, updated the text.

Comment 7> Application layer protocols ?
Reply7> Yes

Comment 8> This is all STUN, why this is in this draft ?
Reply8> In the previous WG discussions there was specific ask from Dave to add this section and explain the Keepalive Interval determination procedure when PCP unaware Firewall or NAT is detected.

-Tiru.
From: Prashanth Patil (praspati)
Sent: Monday, October 21, 2013 3:51 AM
To: Reinaldo Penno (repenno); [email-masked]
Subject: Re: [pcp] Comments on draft-ietf-pcp-optimize-keepalives-00

Hi Reinaldo,
Sections "3.3 Detect PCP Unaware Firewall" and "4. Keepalive Interval Determination Procedure when PCP unaware Firewall or NAT is detected" were added based on Dave's recommendation.

Section 3.3 does not introduce anything new, it only provides an example on how a PCP unaware firewall can be detected using STUN. Section 4 is also a recommendation on what can be potentially done if a PCP unaware firewall was detected.

Dave, what are your thoughts on this?

-Prashanth

On 11/10/13 4:45 PM, "Reinaldo Penno (repenno)" <[email-masked]<mailto:[email-masked]>> wrote:

I reviewed this draft for a possible WGLC but I do not think it is ready.
My summary is that this draft has lots of text related to detection of PCP
unaware NAT/FW using STUN which IMO belong in a separate draft, or some
other document since it is generic text. Maybe the WG sees value in having
a separate document that talks exclusively about detection of PCP unaware
FWs.

This draft could just say "assuming all NAT/FW in the path are PCP
aware..." and take it from there since the goal is optimizing keep-alive
and not standardizing detection mechanisms.

Removing all detection text would make this draft quite short and easier
to understand its purpose.

Thanks,

Reinaldo

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Mon, 2 Dec 2013 10:32:47 +0000

Thanks, looking forward to the new version

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 2, 2013 at 1:55 AM
To: "Prashanth Patil (praspati)" <[email-masked]<mailto:[email-masked]>>, Cisco Employee <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [pcp] Comments on draft-ietf-pcp-optimize-keepalives-00

Hi Reinaldo,

Comment2>  I believe this section should have an introduction and two sub-sections. One subsection should be called “PCP based detection” and have the first paragraph part of it since it only talks about PCP based detection. The second subsection should talk about application based detection.

Comment3> Then the title of this section needs to change to “NAT Topologies and Detection”

Comment4> Suggest to change title to “Detection of..”. But more generally, I wonder if this discussion of detection belongs in this draft. Can this  section be removed ?

-Tiru.
From: Prashanth Patil (praspati)
Sent: Monday, October 21, 2013 3:51 AM
To: Reinaldo Penno (repenno); [email-masked]<mailto:[email-masked]>
Subject: Re: [pcp] Comments on draft-ietf-pcp-optimize-keepalives-00

Hi Reinaldo,

-Prashanth

Thanks,

Reinaldo